Atheros QCA9377 - Slow internet on kernel 5.4


I have a problem with my internet. Sometimes it gets like 5mbps, but then it just decrease to 15kbps. I check the speed test and it gives me 35mbps. Do you know what can be happening?


Not without posting your system specs:

There they are, hope this is

System:
  Host: eclair Kernel: 5.4.22-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 Desktop: Gnome 3.34.4 wm: gnome-shell dm: GDM 3.34.1 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 81F5 v: Lenovo ideapad 330S-15IKB 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 330S-15IKB 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> 
  UEFI: LENOVO v: 7SCN32WW date: 03/11/2019 
Battery:
  ID-1: BAT0 charge: 25.8 Wh condition: 26.7/30.0 Wh (89%) volts: 8.3/7.4 
  model: LENOVO BASE-BAT type: Li-poly serial: <filter> status: Charging 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Display: x11 server: X.org 1.20.7 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) 
  v: 4.6 Mesa 19.3.4 compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.4.22-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 3040 bus ID: 01:00.0 
  chip ID: 168c:0042 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-4:2 
  chip ID: 0cf3:e500 
Drives:
  Local Storage: total: 960.44 GiB used: 10.89 GiB (1.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10 
  size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: 1A04 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Generic model: SD MMC MS PRO 
  size: 28.92 GiB serial: <filter> rev: 1.00 scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 3060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition:
  ID-1: / size: 906.94 GiB used: 10.50 GiB (1.2%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 8.80 GiB used: 210.2 MiB (2.3%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 260 Uptime: 4h 01m Memory: 7.68 GiB used: 2.46 GiB (32.0%) 
  Init: systemd v: 242 Compilers: gcc: 9.2.1 Shell: bash v: 5.0.16 
  running in: gnome-terminal inxi: 3.0.37 ```

Does it slow down while you are using bluetooth?

Have you tested other kernels yet?

Have you rebooted your router?

Is your bios up to date?

I haven't used bluetooth.
No, I haven't try with other kernels. Do you sugest to change it?
I don't know if my bios is updated, how do I check it?

Search your model on your manufacturers website.

I have checked it, it's updated

Yes, I've just rebooted it, and the problem still exist.

Test kernels 4.19, 5.5, and lastly the real time kernels.

Install kernels through manjaro settings manager then reboot. You can change the kernel at reboot through the grub advanced menu.

Check if auto-negotiation is on or not if you're on a wired connection. You want it on.

Also, using different kernels can help.

try calling your internet service providor tell them you have slow connections ask them to reset your connection

Resetting your router to the factory defaults is also a very good troubleshooting procedure when your internet speeds drop.

If you get high speed sometimes, and low speed other times, it's not the hardware, and it's not your OS. It's the server you're downloading from.

There's nothing to do but be patient. Servers do get overloaded on some files.

It worked! Thank you! I'm using now 5.5 and now, It's at least, stable!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by