Atom can't find (install) packages or themes

In the past, I successfully installed packages in Atom (in preferences - install packages), but today, it just keeps searching without ever finishing or showing an error. I could update installed packages though.

Atom 1.44.0 x64 (community repo)
Up-to-date Manjaro stable.

Do you also encounter this problem? Any solution?

1 Like

What output do you get when it's running from a terminal?

I tried starting atom from the terminal, but there is no output, it jumps to a new $ line and starts Atom.
There is also nothing in the internal Atom console.

Had the same problem.
As Hansonw said in https://github.com/atom/apm/issues/791#issuecomment-389266140
i solved it by uninstalling atom and reinstalling it from https://atom.io/releases
from terminal but not from pacman but using tar

1 Like

So the version from the community repo is broken, because Atom needs different versions of its dependencies. Can we report this as a bug somewhere?
Since I would like to keep my software repo based, I will have a look at atom-editor-bin 1.44.0-2 [AUR] and see if it works.
edit: Yes, it does and it also had all my previous addons already installed, very nice!

1 Like

don't know where to report but it will be great

@Dave4 and @rrr You can report packages from the community repo that need updating here:

May I suggest, in the future, if you are not sure about something, use the search function on the forum. The linked thread will come up in the results.

Don't use the Version atom 1.44.0-1 from the AUR but the Version atom-editor-bin 1.44.0-2, this one works and is in the AUR too, had the same problem with the packages and this helped.

atom is an Arch package, https://www.archlinux.org/packages/community/x86_64/atom/

A bug report has already been filed: https://bugs.archlinux.org/task/65700?project=5&string=atom

It likely needs a rebuild.

3 Likes

@jonathon. Thank you for the correction. I read the initial post that said it was from the community Repo. I will do some more research in the future before posting.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by