Attempting to install graphics card

I hope this is in the right section.

Anyway, I recently have attempted to put in a dedicated graphics card into my computer. There was some difficulty getting it to fit, but I managed just fine. I plugged everything in and made sure to plug the monitor to where the dedicated graphics is located.

But upon booting it up, the computer doesn't load up all the way. Instead, I am greeted with a constant loop of messages about starting and stopping the display manager. I do attempt to get into the terminal using ctrl+alt+f2 and it does work...for a few seconds. The computer will just take me back to the constantly expanding string of the computer trying to turn off and on the display manager. It will sometimes flicker back to the terminal only to shift back. This renders me unable to log in to diagnose the problem.

My plan was to install the appropriate drivers, as I had been told the computer will simply use a fallback video driver until the new ones are installed. But this doesn't appear to be the case.

What should I do in order to fix this situation? I will provide the information below:

The graphics card I am attempting to use is a Nvidia GeForce GT 710, MSI brand with 1 GB DDR3 RAM.

And here's my computer information.

  Host: kacie Kernel: 4.14.67-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.0 Desktop: Openbox 3.6.1 Distro: Manjaro Linux 
  Type: Desktop System: Dell product: Inspiron 545s v: 00 
  serial: <root required> 
  Mobo: Dell model: 0T287N v: A01 serial: <root required> BIOS: Dell v: A11 
  date: 09/07/2009 
  Topology: Dual Core model: Intel Core2 Duo E7500 bits: 64 type: MCP 
  arch: Penryn rev: A L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 11708 
  Speed: 1596 MHz min/max: 1600/2933 MHz Core speeds (MHz): 1: 2506 2: 1852 
  Device-1: Intel 82G33/G31 Express Integrated Graphics driver: i915 
  v: kernel bus ID: 00:02.0 
  Display: server: X.Org 1.20.1 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel G33 v: 1.4 Mesa 18.1.7 direct render: Yes 
  Device-1: Intel 82801I HD Audio driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.14.67-1-MANJARO 
  Device-1: Qualcomm Atheros AR928X Wireless Network Adapter driver: ath9k 
  v: kernel bus ID: 03:00 
  IF: wlp3s0 state: down mac: 5e:61:62:6c:1a:30 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  v: 2.3LK-NAPI port: be00 bus ID: 04:00 
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: 00:24:e8:27:0e:5b 
  Local Storage: total: 931.51 GiB used: 306.34 GiB (32.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-00BN5A0 
  size: 931.51 GiB 
  ID-1: / size: 29.40 GiB used: 20.05 GiB (68.2%) fs: ext4 dev: /dev/sda3 
  ID-2: /boot size: 1006.9 MiB used: 123.1 MiB (12.2%) fs: ext2 
  dev: /dev/sda1 
  ID-3: /home size: 878.38 GiB used: 286.17 GiB (32.6%) fs: ext4 
  dev: /dev/sda4 
  ID-4: swap-1 size: 8.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
  System Temperatures: cpu: 40.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 824 
  Processes: 147 Uptime: 16m Memory: 5.81 GiB used: 1.45 GiB (24.9%) 
  Init: systemd Compilers: gcc: 8.2.0 clang: 6.0.1 Shell: bash v: 4.4.23 
  inxi: 3.0.21 >

Not sure if this is exactly what you want:

There is a more detailed tutorial for this but I can't seem to find it so here is a brief summary,

Download and boot off the live media.

Once you are up and running open a terminal and type:

manjaro-chroot -a

You should then get a list of volumes, if there is more than one select the appropriate volume.

If it works, you will then be inside your real system. You can then use mhwd to install the appropriate drivers and remove the old.

If you need more details, please let us know.


Or you can boot to TTY directly, avoiding the problems you faced.

My advice, since your system is Desktop and might not care for power consumption:

  • Boot to your BIOS and disable integrated GPU adapter
  • Continue boot to Grub and edit (press e) to go to TTY (details in the above tutorial)
  • In TTY:
    • Login and run a full update
    • Check if your card is compatible to the latest nvidia (it depends on the exact model) and your installed config
mhwd -l
mhwd -li
  • Install the nvidia driver, preferably video-nvidia if available, with mhwd
sudo mhwd -r pci <old config>
sudo mhwd -i pci video-nvidia <or video-nvidia390xx>
  • Reboot
1 Like

Update: I managed to get the drivers installed and the computer is now able to use the new graphics card.

However, there's now a new problem. While most things appear to be working just fine, Minecraft now runs slower than it did before, and when I attempted to test my copies of Halo and Spore, they ran at a snail's pace.

Is there some kind of configuration or another driver I need to install for this? Or do I just need to reboot the computer again?

This topic is solved. Mark the answer that describes how you solved it as the solution and create a new topic for your applications' issues. Totally different cases.. I have no clue about games.. :stuck_out_tongue:

I used TTY like was suggested by Petsam. Once I was able to get in, I ran this command:

sudo mhwd -a pci nonfree 0300

And after it was finished installing, the monitor went black and then the screen popped up. I tested out Blender immediately to make sure that it was working. It was able to load up, which it did not before. So that's how I knew that the card was doing its job.

Now it's just a matter of figuring out why some games are running slower than they had before.

Did you reboot after your driver installation? You better do it..

I would recommend disabling the onboard intel graphics in your bios if you haven't already.

The GT710 isn't really a performance card and with 1GB dedicated DDR3 RAM it will still tend to struggle (and will need some shared system RAM) with any modern titles just like the onboard Intel GPU. You are limited as to what you can shoe-horn into any SFF chassis though.

In addition to dalto's wise words above, as for running anything other than nouveau, try the non-free 390.XX driver from nvidia. support seems to have been dropped for this card after 390.XX

I rebooted the computer and the gaming performance issues I've had before vanished. So there aren't any further issues.

1 Like

Yeah I'm aware it's not a performance card. I bought it as an upgrade to my very old pre-2010 computer so I could play old games like Halo that stopped working after I installed Manjaro Linux. I don't intend on playing anything really new on this card.

fair enough, did you install halo via PlayOnLinux or straight to WINE? it may be necessary to change the rendering profile. If you have PlayOnLinux installed. click on Configure. click on the Halo game icon and then click Display. experiment with those settings and you may find the right one for Halo. Each game can differ as to the best rendering method.

I have halo but have not installed it to my Linux desktop so can't really advise the best settings. The best resource for that is WINEHQ though.

Forum kindly sponsored by