Attempting to install Manjaro Gnome on a Windows UEFI Machine, It gets stuck at Starting User Manger for UID 1000

As mentioned in the title I am attempting to install Manjaro(gnome) onto my windows UEFI machine, Attempting to boot the live USB, I do get to the grub environment but (only if I write it in DD mode on Rufus, which I think is a limitation of grub).

Attempting to boot into the environment, is another case since it would always get stuck at 'Starting User Manager For UID 1000'. My previous installation of Ubuntu went fine if I set nomodset on the boot parameters, and there wasn't any need for that on updating the kernel, which is weird since Manjaro should use the latest version. I tried setting radeon.modeset and nouveau.modeset, and another value to be = 0 when attempting to boot but it still gets stuck on the aforementioned, thus the cause for making a post here.

I believe the problem is in gdm, but as I mentioned before, it did work fine on Ubuntu


EDIT:- I used one of the beta builds, xfce to be exact, I do get an absolutely garbled screen but it works, I'll attempt an install later.

If you still have Ubuntu handy, please post your inxi -Fxzzz. Did you try non free drivers?

I don't have Ubuntu installed right now,
And I believe I have tried using the non-free drivers and it failed to launch still, and to my memory, AMD doesn't have proprietary Linux drivers for the Ryzen 3 APU

what kind of cpu / video cards have you ?
you may need more recents isos

The fact that one can fly a paper plane, does not mean he is capable of flying a drone, with no previous training, or experience, or reading any user manual, IMHO. :grin:

You can edit grub commandline and test any extra flags.
If you think gdm is the problem, boot directly to TTY and then startx.

Please, have some reading on this basic tutorial and search the forum for similar issues

1 Like

Ok. You mention Ryzen 3 apu. Try installing on another machine, updating it fully, installing kernel418, then putting it back into your Ryzen machine. You could also try a beta. Lastly, you could try simply re burning your flash drive.
Petsam is right however, if you can, it makes it a lot easier to solve problems when we have relevant info as aid.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by