Audacity still not working

For newcomers to the conversation this topic refers back to Audacity fails to open


Hi @LizziAS, @kainonergon & @yotties. Sorry to open another post, but I tried to reply to the last reply from @LizziAS and the system banned my reply as "Your post was flagged as spam: the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected. " :grimacing:

I have never been a member of such a ridiculous forum. However.....getting back to the point, I took up @LizziAS suggestions and installed a couple of the packages listed in her images which were missing from my pacman and also uninstalled and reinstalled Audacity without an iota of change. The GUI loads perfectly but I still can't record.

Have you tried to configure input device with pavucontrol?

1 Like

I think someone accidentally flagged your posts, maybe just clicked wrong button. Now they are unblocked again.

did you get it working?

Thanks @kainonergon & @LizziAS. Sorry about all the confusion. Still not working. Am out for the day today, so will look at your suggestions this evening. Ciao.

Hi @LizziAS, @kainonergon and @yotties. Back to grind the grist.

First of all yotties, regarding your latest reply to the other connected post, I hope you accept that my outbursts were based in frustration and not a general comment about this OS. I had problems with Windows and Ubuntu in various ways over the years. No OS is perfect, but I am committed to Manjaro as it serves my general needs extremely well.

Back to the problem. Since the last I have (following the Manjaro manual):

  1. Purged Audacity (sudo pacman -Rns audacity)
  2. Purged orphans (sudo pacman -Rs $(pacman -Qdtq)
  3. Cleaned the cache (sudo pacman -Sc)
  4. Installed Audacity (sudo pacman -S audacity)

Unfortunately, even with this housekeeping, Audacity opens (both from its icon and terminal) but refuses to register an input. The output when started in terminal is the same as in the Pastebin (http://pastebin.com/YYLqjUvj).

I have ALSA & Pulseaudio running and have Pulse Audio Volume Control and Gnome ALSA Mixer installed and working.

Given this update is there any other information I could provide for any of you to suggest fixes?

Thank you once again.

It sounds like what you're wanting to do is record using Audacity. And getting audio input is the only problem you have with Audacity. Have you been able to record or use audio input with other programs (such as Skype)?

Hi @cimarronline. Welcome to the conversation.

My audio output is working fine in other applications and indeed Audacity will open a .wav and play it. The problem seems to be on the record side. No matter what input I select there is no signal.

Okay. But are you able to record or get audio input with any other programs besides Audacity? If not, then the problem is elsewhere...

I do not have any other application which records audio. I don't have Skype installed. Is there anything else available in Manjaro?

There is gnome-sound-recorder, though I haven't used it. You can give it a try.

If you open Pulseaudio volume control, and choose the Input tab, you can select your input device. It has a meter there that should show you if it's detecting sound (like when you talk into it).

If that's working okay, then it's just a matter of selecting the right audio input channel with Audacity (there's lots of options). Using pulseaudio, I chose pulse:Mic:0 (then hit record button) to get it to record.

We have success!!!!!!!! :smile:

I fiddled about with a lot of controls in Pulseaudio volume control until I found ones that worked, Thank you to @cimarronline, @kainonergon, @LizziAS and @yotties for all your help and support xx :heart:

PS: Is there a way of marking a post as SOLVED?
PPS: Found it!

3 Likes

Just click the little check mark at the bottom of the post you want to mark as the solution.

Glad to hear it's working!

Glad it's working for you!

Hi Rebecca,

I just wanted to encourage you to persist. No need to be defensive or explain yourself at all.
I am delighted it is all working for you.
You can also try Ardour, but I prefer Audacity for my purposes (simple stereo sound from different sources and minor cuts).
Good Luck
Y.

Ardour requires jackaudio. So you'll need to configure JackAudio first and then you can use Ardour. I've made tutorial on how to do that here:


Also, you may need our rt kernel to get the best performance of jackaudio:

Of course, you can just stay with Audacity if you find it too complicated :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by