Audio not working (Intel Cannon Lake PCH cAVS and NVIDIA TU106 High Definition Audio)

Hi!

Today I installed Manjaro and it is beautiful but I have an issue with the sound.

Output of inxi -A is:

Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: sof-audio-pci 
           Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.7.0-3-MANJARO

In alsamixer I get HDA NVidia as the only named sound card. I select it and I get 6 rectangles containing 00, each of them: S/PDIF without any number and S/PDIF [ a number from 1 to 5 here].

I have 3 devices that should produce sound:

  • the actual laptop speakers (not working),
  • the Bluetooth headset (which works great!)
  • and the jack headset (not working)

I have the latest version of the kernel installed (5.7).

Thank you.

For this one see here

You should be able to switch audio tho.

I installed package sof-firmware, went again through alsamixer, and audio still does not come from the speakers of the laptop or from the wired headset.

$ lspci | grep Audio
01:00.1 Audio device: NVIDIA Corporation TU106 High Definition Audio Controller (rev a1)

and in alsamixer I have a new device sof-hda-dsp.

@bogdancovaciu I followed the instructions here and in the wired headset I can now hear the music but I cannot use it as microphone. In alsamixer everything seems to be normal. I installed Audacity and in it I tested all the input devices, the pulse Mic 1:1 device is recording sound from the music that plays in the browser but at a smaller volume but still with relative big quality of sound.

Also, this is the output of dmesg since a reboot.

Next, I think I will try to install pulseaudio-git as in the link above.

common problem with Intel Cannon Lake audio on laptops is that built-in microphone array
should be supported by new Sound Open Firmware, but it has not worked well on many laptops
bug reports for sof-firmware are being worked on but there are a lot still needing attention https://github.com/thesofproject/sof/issues

suggest disable internal microphone by adding this kernel option

echo 'options snd-intel-dspcfg dsp_driver=1' | sudo tee -a etc/modprobe.d/alsa-base.conf

that should allow the speakers and headset to be detected and work normally

2 Likes

@silviubogan - i was about to say that maybe Nik will pass by for the rescue :smiley:

@nikgnomic

Everything was working well after redoing the steps on the ArchLinux wiki page linked above, but then I ran your command and I think it replaced the contents of /etc/modprobe.d/alsa-base.conf... Where can I find the default content of that file?

Thx. :slight_smile:

There is none by default. Is added in some special cases, manually. This time was created when you run the command provided by Nik.
From the arch wiki you actually created a blacklist.conf file inside /etc/modprobe.d/

1 Like

I solved the issue temporarily by undoing and redoing the steps inside that page (section Audio) but after pulling the cable from the jack port it stopped working, the microphone of the wired headsets is not working. I restarted the laptop and the same problem as before - the microphone of the wired headsets is not working.

@bogdancovaciu @nikgnomic

How can I make sure that the line

options snd slots=snd_soc_skl_hda_dsp

from the file /etc/modprobe.d/sound.conf created by me and containing just that string above is correctly applied?

I see now that I have not undoed the code from @nikgnomic.

Sorry for this "spam".

After removing the code from @nikgnomic everything works except... well... that after recording a sound in a Telegram conversation (after reboot confirmed that it is a good recording), I click to play the recording and after a few seconds (maybe less than 5) the entire laptop is blocked, the mouse cursor does not move, no sound is hearable, and I think that the keyboard too is not utilizable. I forcefully reboot the laptop and everything works well then, until I click that play button again (but on a new recording, not on a previous one).

**Update: ** it seems that the laptop crash happens only sometimes, not always (I just did another recording and clicked the Play button). I hope it is not going to happen to me again.

I see that the laptop is blocked also sometimes when playing a YouTube video on Firefox, and after rebooting, the same YouTube video does not play... What could be the real issue? Sorry for this spam. Thanks for all the good intentions.

command i suggested used a tee command with option -a

$ tee --help
Usage: tee [OPTION]... [FILE]...
Copy standard input to each FILE, and also to standard output.

  -a, --append              append to the given FILEs, do not overwrite

(i had omitted the -a option in another discussion and command failed because there was no pre-existing file, so i made sure to include it on this post)

i am surprised that if /etc/modprobe.d/alsa-base.conf had already been created with modprobe options that no mention was made about it even after a suggestion to add another modprobe option

the dspcfg option comes from the old original Bugzilla #201515

dspcfg=1 is the usual option users need to continue using the legacy snd_hda_intel driver

if had known about snd_soc_skl_hda_dsp i could have suggested using option dspcfg=2 instead for loading an SOF driver instead of snd_hda_intel

check ALSA data with - alsa-info.sh
section titled !!Modprobe options (Sound related) will show any options added for 'snd'

2 Likes

More information is here: http://alsa-project.org/db/?f=e5e50d7b027893845c9d27c5893931412a4cd272

After upgrading the Manjaro installation I used dspcfg=1 and the output works with the headset.

Now I am trying to use dspcfg=2 to make the microphone work (it currently records just noise).

Thanks!

It does not work, but I am glad I can listen to music without the system crash.

Thanks!

user with same model laptop appears to have found this solution to close bug report

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by