AUR Vorta 0.6.22 fails to start with Python error


I have been using the vorta package (which uses borg behind the scenes) for my backups, and they have worked well until a couple days ago when I installed the latest set of Manjaro updates. vorta is based on Python and QT.

When I try to start vorta, it gives the following error:

qt5ct: using qt5ct plugin
Traceback (most recent call last):
  File "/usr/bin/vorta", line 11, in <module>
    load_entry_point('vorta==0.6.22', 'gui_scripts', 'vorta')()
  File "/usr/lib/python3.7/site-packages/vorta/", line 40, in main
    app = VortaApp(sys.argv, single_app=True)
  File "/usr/lib/python3.7/site-packages/vorta/", line 47, in __init__
    self.scheduler = VortaScheduler(self)
  File "/usr/lib/python3.7/site-packages/vorta/", line 20, in __init__
  File "/usr/lib/python3.7/site-packages/apscheduler/schedulers/", line 87, in __init__
    self.configure(gconfig, **options)
  File "/usr/lib/python3.7/site-packages/apscheduler/schedulers/", line 126, in configure
  File "/usr/lib/python3.7/site-packages/apscheduler/schedulers/", line 697, in _configure
    self.timezone = astimezone(config.pop('timezone', None)) or get_localzone()
  File "/usr/lib/python3.7/site-packages/tzlocal/", line 165, in get_localzone
    _cache_tz = _get_localzone()
  File "/usr/lib/python3.7/site-packages/tzlocal/", line 90, in _get_localzone
  File "/usr/lib/python3.7/site-packages/tzlocal/", line 38, in assert_tz_offset
    raise ValueError(msg)
ValueError: Timezone offset does not match system offset: 3600 != 28800. Please, check your config files.

What do these errors means and how might I start to troubleshoot this problem? I noticed that vorta seems to have a config file in ~/.local/share/Vorta/settings.db, but when I open it with a text editor it's mostly unreadable. What can I try? /Thanks!

[Edit, not this]

1 Like

AFAIK, it is not related to pip, I had the same problem when I tried Vorta a while ago (way before the pip changes).
It's a problem with how Vorta deals with time settings, changing my local time from UTC+1 to UTC allowed it to run (I had the exact same error Timezone offset does not match system offset)
I don't know if it's a bug with vorta or with how time is configured, and I didn't look for a proper solution since I wasn't intending to switch to borg as a backup solution.


Thank you @jonathon and @saedlar93.

Wait, so you had to change the time for the whole system to make vorta work? TBH I'd rather not have to do that. :slight_smile:

The last line of the error mentioned config files, which files might they be?

I don't use vorta, I changed the time just to investigate why it refused to start.
It's a problem with the module tzlocal (provided by python-tzlocal from the community repo)

1 Like

In case anyone is still following this thread, vorta's GUI started with no errors for me today following the latest set of updates (which came out yesterday?).


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by