[Available on stable] Adding AMD+NVIDIA hybrid support to mhwd

sudo pamac install https://mirror.easyname.at/manjaro/pool/overlay/mhwd-db-0.6.4-11-x86_64.pkg.tar.zst

What does it mean?

Mhwd-db nvidia configs have a lot of similar/identical code.

Nice!
Btw, i've noticed a minor inconvenience on my ASUS TUF Gaming FA506IV_FX506IV.
The screen sometimes starts flickering, when waking up from sleep mode or from the screen just turning off because of inactivity.
It goes away by simply restarting the laptop.
Not sure if this is related to the hybrid amd-nvidia driver setup or something else.
My DE is KDE.

I have the same laptop and I am on testing branch and have 5.6 and 5.7 kernels installed.

After installing new mhwd-db (thus, hybrid-amd-nvidia driver), if I try to boot 5.7 kernel, boot process gets stuck on Failed to start Load/Save *ness of backlight:acpi_video0 (switching to another tty works, though). If I reboot to 5.6 from this state, I have screen brightness working and no more flickering.

My guess is that the new kernel loads newer firmware for iGPU or something like that. But why does it fail starting GDM with PRIME Render Offload enabled?

UPD: Adding amdgpu to MODULES section in /etc/mkinitcpio.conf has fixed my issue. Flickering is still present (kernel 5.7.9-1).

For me the hybrid setup works on the 5.7 kernel without any issues (except the aforementioned flickering), though i am on the stable branch.

Can be now tried with 20.1-pre3 ISOs ...

2 Likes

By the way @TotallyNotElite,
Would it be possible to have mhwd autodetect hybrid amd-nvidia setups, since at the moment it seems that the mhwd package will need to be manually installed each time?

That's literally what the pull request did. We are currently waiting for it to reach stable and then to land in the latest ISOs.

Ok, though atm mhwd warns me that it doesn't detect hardware compatible with the driver config when i manually install it.
Maybe it's just some specificity with my laptop then.

Can you show me the exact logs + commands you ran?

Ok, actually it seems that it doesn't warn me about that anymore...
Seems like there's been an update since I switched to the testing branch.
Sorry to waste your time.

1 Like

I'm going to use my first post to say, thank you SO MUCH!

Worked perfectly on my Asus Zephyrus G14.

OpenGL renderer string: AMD RENOIR (DRM 3.37.0, 5.7.9-1-MANJARO, LLVM 10.0.0)
OpenGL renderer string: GeForce RTX 2060 with Max-Q Design/PCIe/SSE2

1 Like

You're welcome!

I've been using https://github.com/Hyper-KVM/optimus-manager 's solution for quite some time on my ryzen 7 nvidia 1660 Ti asus tuf 505du hybrid without issue for some time. Gnome and KDE both no issues. even the indicator works and is custimizable for intel/amd etc.. would really love to see this included as a hybrid options beside the prime choice as This option has allowed me the use of my dgpu's hdmi port so I can use an external monitor with the use of either my apu, dgpu or hybrid setup.. just mho

Hi!
That's the holy grail for us with amd/nvidia combo, we'll see if 450 nvidia drivers fix that problem

let me know if you have any issues. Please take a look at the readme as there are a few config files that need tweaking depending on your setup gnome vs kde etc. you also need to copy the main optimus-manager config to the default location once you've installed. after that ; optimus-manager --switch "hybrid" "nvidia" "igpu"

that's it. enter one of the three above commands and viola. You can edit the main config to automatically load nvidia if on ext power or igpu if on battery etc.
And the biggest thing for me is You have access to your hdmi port so yay for 2nd monitor while gaming etc..

Hi!
Thanks for the reply and the tips!

I think I am having some weird issue.

OpenGL renderer string: AMD RAVEN (DRM 3.35.0, 5.4.52-1-MANJARO, LLVM 10.0.0)
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40

I have installed it from mhwd
image

Hi, I don't think using another unofficial solution, just like bumblebee, is a good idea, especially because it is getting extensive support from DE's directly now. Gnome/KDE now have a context menu/desktop file entry that allow you to pick the GPU for example.

This issue is already fixed, I'm just waiting for the manjaro team to finally accept my merge request and add support for nvidia 450. This is the only advantage that I know of that optimus manager has, and it's already gone.

Hi, do these issues persist after a full reboot?

Forum kindly sponsored by