Ayuda!!! manjaro kde started tlp system startup/shutdow con video ati

me sale esa lista mhwd -liIMG_20190503_090935

aplique esto que me comentas
systemctl disable tlp.service
systemctl disable tlp-sleep.service
y reinicia, a ver si eso hace algo.
IMG_20190503_090935_1 IMG_20190503_092513

Se queda estancado en esa pantalla!

Que mal, tienes instalados los dos, los free y los non-free. Lo cual es un follón por que encima te habrá degradado de version los xorg y demás componentes esenciales.

Prueba con:
sudo mhwd -r pci video-catalyst
sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm -rf /etc/X11/mhwd.d/ati.conf
sudo rm "/etc/X11/xorg.conf"
sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video
sudo pacman -Sy xf86-video-ati "xorg-server>1.19"
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

Uno detrás de otro, reiniciar y cruza los dedos. Pero vamos, no te extrañe que te toque reinstalar.

Pude entrar como root y hacer ejecutar startx puedo ingresar con entorno grafico, no se si de ahi se pueda hacer algo mas, en realidad mas me interesa recuperar la sesion de usaurio donde tenia todos los archivos y programas, de todas maneras me arroja un eror de plasma , hice ping y tengo internet, peo firefox no levanta!

IMG_20190503_092659 IMG_20190503_100415 IMG_20190503_101130

Por que entras como root? No te deja entrar con tu usuario?

No uses startx, usa startkde

Por lo que veo en las capturas, no se han desinstalado los non-free por un problema de dependencias. Asegurate de usar todo los comandos que te puse. Es imprescindible que elimines todos los catalyst

sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video

y que instales xf86-video-ati y actualizar xorg-server a la ultima versión.

sudo pacman -Sy xf86-video-ati "xorg-server>1.19"

Sino, no vas a avanzar nada.

Amigo te cuento segui todo este proceso que me diste:
sudo mhwd -r pci video-catalyst
sudo rm -rf /etc/X11/xorg.conf.d/90-mhwd.conf
sudo rm -rf /etc/X11/mhwd.d/ati.conf
sudo rm "/etc/X11/xorg.conf"
sudo pacman -Rnc catalyst-input catalyst-server catalyst-utils catalyst-video
sudo pacman -Sy xf86-video-ati "xorg-server>1.19"
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
Y el quipo pasa del problema inicial que tenia,ahora entra a la consola , ingreso usuario y password, la unica forma de entrar al entorno grafico es con startx, startkde no me funciona?, ahora ya puedo ingresar a la sesion de mi usuario, salvo que entro por consola el login y debo colocar startx, no como antes que entraba al login grafico,y lo otro que no me toma el wifi, en realidad no me tomaba la ethernet ni wifi, pero logre seguir un procedimiento y me tomo la tarjeta por cable, el wifi no logro hacerlo funcionar, cambie kernel, desinstale drivers de la tarjeta broadcom wifi y nada, te agradezco mucho ya pude recuperar el escritorio, creo que ahora lo que falta ya no es nada al parecer,igualmente si me puedes indicar que hacer te agradezco ya que intente y no paso nada para recuperar el wifi!IMG_20190503_104637

Pero para que quieres hacer funcionar el wifi cuando el estado del sistema esta tan precario? No te renta mas guardar los datos que te interesen y reinstalar desde cero?

Las cosas de redes no son mi fuerte, pero si tu wifi es Broadcom, tienes que instalar el módulo correspondiente al kernel que uses. Osea linux50-broadcom-wl si usas el kernel 5.0, o linux419-broadcom-wl, etc...

Si con eso no te funciona, si entiendes inglés puedes probar a hacer esto siguiente, pero vamos, ya es un proceso mas complicado:

1 Like

Gracias por toda la orientacion, al final no pudo tomar la tarjeta wifi, lo intente varios dias y no hubo caso, inicie con usb para instalar manjaro de nuevo, particione el disco y comenze de 0, para no borrar la informacion y archivos mantube la particion anterior sin borrarla y pude recuperar todo, lo que si ahora al encender el notebook me aparecia un menu, donde podia seleccionar manjaro recien instalado y el anterior, note que el booteo demoraba mucho mas de lo normal , comparado cuando estaba sin particion y tenia un solo manjaro en el disco, buscando informacion pude modificar el grub y ahora parte directo sin menu , la particion antigua esta en sda1 y la nueva en sda3 la sda2 es swap, habra alguna forma de modificar el arranque para que sea mas rapido?
Mi equipo es un sony vaio: 8 GB de ram , disco solido de 1TB , creo que antes andaba mucho mas rapido el boteo,la verad estoy tratando de convencer a algunos amigo a que se animen a ussar manjaro, pero hoy hice un tiempo de boteo de un windows 10 en un i7 con 8 de ram y demoro 15 segundos y mi manjaro demoro casi 2 minutos 30 segundos!!! con este comando pude ver las caracteristicas, cualquier ayuda te agradezco!!!

CPU: Quad Core AMD A10-5745M APU with Radeon HD Graphics (-MCP-) speed/min/max: 2096/1100/2100 MHz
Kernel: 4.19.36-1-MANJARO x86_64 Up: 30m Mem: 1642.3/7166.4 MiB (22.9%) Storage: 953.87 GiB (11.2% used) Procs: 191
Shell: bash 5.0.3 inxi: 3.0.33

Como no hiciste instalación "limpia" de verdad, tiene pinta que tienes dos instalaciones a la vez y es muy posible que tengas un lío de montar particiones y sea eso lo que lo demore.

Necesitamos:

lsblk -f

cat /etc/fstab

cat /proc/cmdline

Copias y pegas aqui la salida de esos comandos de manera que se pueda ver bien por favor.

Esta es la salida de los comandos que me pides:

Screenshot_20190509_083325

Lo siento pero tengo un problema de visión y no veo bien las fotos, por eso te decía lo de cortar y pegar.

1 Like

Asi sirve?

[eespinoza2@eespinoza ~]$ lsblk -f
NAME FSTYPE LABEL UUID FSAVAIL FSUSE% MOUNTPOINT
sda
├─sda1 ext4 eeeeae2c-8027-4b7a-b0e0-e41e5fc9e4f7
├─sda2 swap 1e5dfdcb-62a9-459a-8a2e-02d60eba7738 [SWAP]
└─sda3 ext4 1382c0ed-e163-46bc-a6b2-cb4e5621f3bb 333,5G 23% /
sr0
[eespinoza2@eespinoza ~]$ cat /etc/fstab

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=1382c0ed-e163-46bc-a6b2-cb4e5621f3bb / ext4 defaults,noatime,discard 0 1
UUID=1e5dfdcb-62a9-459a-8a2e-02d60eba7738 swap swap defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
[eespinoza2@eespinoza ~]$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=1382c0ed-e163-46bc-a6b2-cb4e5621f3bb rw quiet resume=UUID=1e5dfdcb-62a9-459a-8a2e-02d60eba7738
[eespinoza2@eespinoza ~]$

Pues no veo nada raro la verdad. Las particiones están bien montadas. Lo único que la antigua sda1 no esta montada en el fstab, pero eso no debería ralentizar en un principio. Lo que no se es por que la pilla el grub.

Prueba a instalar haveged si no lo tienes ya, muchas veces eso hace que arranque mas rápido, sobre todo en KDE:

sudo pacman -S haveged --needed

systemctl enable haveged

Ah y a ver que dice esto sobre cuanto tarda cada cosa en arrancar:

systemd-analyze blame

Ok haveged lo instalo y quedo habilitado,al ingresar el comando systemd-analyze blame me arroja esto:
eespinoza2@eespinoza ~]$ systemd-analyze blame
1.276s lvm2-monitor.service
1.112s dev-sda3.device
1.009s systemd-logind.service
920ms udisks2.service
912ms mariadb.service
679ms systemd-udevd.service
638ms systemd-journald.service
449ms tlp.service
420ms ModemManager.service
412ms upower.service
250ms polkit.service
188ms systemd-journal-flush.service
155ms user@1000.service
137ms NetworkManager.service
123ms avahi-daemon.service
118ms systemd-udev-trigger.service
75ms systemd-tmpfiles-clean.service
72ms systemd-modules-load.service
47ms grub-boot-indeterminate.service
41ms org.cups.cupsd.service
39ms systemd-binfmt.service
35ms systemd-tmpfiles-setup.service
27ms user-runtime-dir@1000.service
26ms dev-hugepages.mount
25ms kmod-static-nodes.service
25ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
24ms sys-kernel-debug.mount
24ms systemd-remount-fs.service
23ms systemd-tmpfiles-setup-dev.service
21ms sys-fs-fuse-connections.mount
21ms wpa_supplicant.service
20ms bluetooth.service
18ms dev-mqueue.mount
18ms systemd-user-sessions.service
17ms systemd-backlight@backlight:radeon_bl0.service
lines 1-35...skipping...
1.276s lvm2-monitor.service
1.112s dev-sda3.device
1.009s systemd-logind.service
920ms udisks2.service
912ms mariadb.service
679ms systemd-udevd.service
638ms systemd-journald.service
449ms tlp.service
420ms ModemManager.service
412ms upower.service
250ms polkit.service
188ms systemd-journal-flush.service
155ms user@1000.service
137ms NetworkManager.service
123ms avahi-daemon.service
118ms systemd-udev-trigger.service
75ms systemd-tmpfiles-clean.service
72ms systemd-modules-load.service
47ms grub-boot-indeterminate.service
41ms org.cups.cupsd.service
39ms systemd-binfmt.service
35ms systemd-tmpfiles-setup.service
27ms user-runtime-dir@1000.service
26ms dev-hugepages.mount
25ms kmod-static-nodes.service
25ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
24ms sys-kernel-debug.mount
24ms systemd-remount-fs.service
23ms systemd-tmpfiles-setup-dev.service
21ms sys-fs-fuse-connections.mount
21ms wpa_supplicant.service
20ms bluetooth.service
18ms dev-mqueue.mount
18ms systemd-user-sessions.service
17ms systemd-backlight@backlight:radeon_bl0.service
17ms systemd-random-seed.service
17ms systemd-rfkill.service

Pues eso también se ve muy bien. Has reiniciado para ver si haveged ha echo algo?

Lo próximo que se me ocurre es que edites grub con:

sudo nano /etc/default/grub

Y quites quiet de GRUB_CMDLINE_LINUX_DEFAULT=

Guardar con Ctrl + O, salir con Ctrl + X y luego sudo update-grub.

Todo eso para que en el próximo arranque salgan todos los mensajes y te fijes donde se pueda quedar atascado.

Reinicie el equipo y demoro 25 segundos y me arroja esto con el comando,

[eespinoza2@eespinoza ~]$ systemd-analyze blame
1.206s lvm2-monitor.service
1.130s dev-sda3.device
1.050s systemd-logind.service
899ms mariadb.service
813ms udisks2.service
673ms systemd-udevd.service
624ms systemd-journald.service
569ms tlp.service
409ms upower.service
349ms ModemManager.service
278ms systemd-rfkill.service
212ms polkit.service
208ms systemd-journal-flush.service
133ms user@1000.service
121ms systemd-udev-trigger.service
115ms NetworkManager.service
84ms systemd-modules-load.service
83ms avahi-daemon.service
62ms systemd-binfmt.service
44ms org.cups.cupsd.service
41ms haveged.service
36ms systemd-tmpfiles-setup.service
30ms systemd-remount-fs.service
29ms dev-disk-by\x2duuid-1e5dfdcb\x2d62a9\x2d459a\x2d8a2e\x2d02d60eba7738.swap
27ms systemd-tmpfiles-setup-dev.service
25ms grub-boot-indeterminate.service
24ms sys-kernel-debug.mount
24ms wpa_supplicant.service
22ms dev-hugepages.mount
21ms proc-sys-fs-binfmt_misc.mount
20ms systemd-update-utmp.service
20ms bluetooth.service
20ms user-runtime-dir@1000.service
17ms systemd-random-seed.service
16ms rtkit-daemon.service
16ms kmod-static-nodes.service
15ms systemd-backlight@backlight:radeon_bl0.service
13ms systemd-user-sessions.service
12ms systemd-sysctl.service
10ms dev-mqueue.mount
10ms systemd-backlight@backlight:acpi_video0.service
10ms sys-kernel-config.mount
4ms tmp.mount

Pues ya esta no? 25 segundos esta muy bien, sobre todo si es un disco duro y no un SSD. En ese caso es un tiempo buenísimo, sobre todo para KDE que es lento arrancando.

Si pones systemd-analyze a secas, te dice el tiempo de arranque en segundos por partes.

Si mejoro mucho, pero creo reiniciaba mas rapido , no tome el cronometro antes, igual mi disco es solido es ssd!

ese es el grub.
GRUB_DEFAULT=saved
GRUB_TIMEOUT=0
#GRUB_TIMEOUT_STYLE=menu
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=1e5dfdcb-62a9-459a-8a2e-02d60eba7738"

If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.

GRUB_SAVEDEFAULT=true

Preload both GPT and MBR modules so that they are not missed

#GRUB_PRELOAD_MODULES="part_gpt part_msdos"

Uncomment to enable booting from LUKS encrypted devices

#GRUB_ENABLE_CRYPTODISK=y

Uncomment to use basic console

GRUB_TERMINAL_INPUT=console

Uncomment to disable graphical terminal

#GRUB_TERMINAL_OUTPUT=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command 'videoinfo'

GRUB_GFXMODE=auto

Uncomment to allow the kernel use the same resolution used by grub

GRUB_GFXPAYLOAD_LINUX=keep

Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

GRUB_DISABLE_RECOVERY=true

Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.

GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

Uncomment one of them for the gfx desired, a image background or a gfxtheme

#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

A mi me tarda sobre 20s también arrancando en frio en un SSD. 22 y pico el ultimo arranque. KDE siempre tarda un poco mas al arrancar, para luego ir mas suelto. Eso si, no uso grub.

Lo de GRUB_TIMEOUT=0 lo has cambiado tu? No digo que este mal, mas rápido irá, pero si tienes algún problema y necesitas que aparezca el menu de grub, no se si serás capaz de llamarlo.

Si eso lo cambie yo, tenia 5 segundos y tambien comente el menu!
Entonces como dices ya estaria bien en el boteo, hasta ahora reinstale todas las aplicaciones y funciona perfecto, hay alguna herramienta que pueda hacer una imagen del estado que esta hasta ahora y en caso de problemas solo cargarla y no tener que reinstalar todo nuevamente? La verdad que me encanto manjaro, esta cargado con todo lo que necesito para estudiar y pretendo que sea mi herramienta estable para eso y no depender de programas windows, hasta el momento me han funcionado todas las herramientas que necesito, lo unico que me ha dado problemas es la instalacion de oracle 12c pero eso es otro tema tendre que verlo luego!
Un abrazo y muchas gracias ya que estoy en pañales en manjaro y me ha servido mucho tu ayuda! Gracias!!!

Forum kindly sponsored by