B-Label startet nach perl Update nicht mehr

Wenn ich das richtig sehe, hat mein System am Wochenende ein perl Update bekommen. Nun erhalte ich beim Start von B-Label (Paket blabel in AUR) eine Fehlermeldung, die ich nicht aufzulösen weiß:

$ blabel
GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed at /usr/lib/perl5/5.32/core_perl/DynaLoader.pm line 210.
GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed at /usr/lib/perl5/5.32/core_perl/DynaLoader.pm line 210.
GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed at /usr/lib/perl5/5.32/core_perl/DynaLoader.pm line 210.
GLib-GObject-CRITICAL **: g_boxed_type_register_static: assertion 'g_type_from_name (name) == 0' failed at /usr/lib/perl5/5.32/core_perl/DynaLoader.pm line 210.
Can't locate Net/CUPS.pm in @INC (you may need to install the Net::CUPS module) (@INC contains: /usr/lib/perl5/5.32/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.32/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.32/core_perl /usr/share/perl5/core_perl) at /usr/bin/blabel line 14.
BEGIN failed--compilation aborted at /usr/bin/blabel line 14.

… wie lässt sich das wieder fixen bzw. wohin wende ich mich ggfs besser damit? (Mir ist nicht klar, ob perl, CUPS, blabel oder was den Fehler verursacht.)

(Manjaro gnome, alles up-to-date)

$ inxi -Frmxx
System:    Host: blue Kernel: 4.19.133-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 Console: tty 1 dm: GDM 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MICRO-STAR model: 770-C45 (MS-7599) v: 1.0 serial: N/A BIOS: American Megatrends v: 1.12 
           date: 08/04/2010 
Memory:    RAM: total: 11.73 GiB used: 2.32 GiB (19.8%) 
           Array-1: capacity: 16 GiB note: est. slots: 4 EC: None max module size: 4 GiB note: est. 
           Device-1: DIMM1 size: 4 GiB speed: 667 MT/s type: Other manufacturer: Corsair part-no: CMX8GX3M2A1333C9 
           Device-2: DIMM2 size: 2 GiB speed: 667 MT/s type: Other manufacturer: Corsair part-no: VS2GB1333D3 
           Device-3: DIMM3 size: 4 GiB speed: 667 MT/s type: Other manufacturer: Corsair part-no: CMX8GX3M2A1333C9 
           Device-4: DIMM4 size: 2 GiB speed: 667 MT/s type: Other manufacturer: Corsair part-no: VS2GB1333D3 
CPU:       Topology: Quad Core model: AMD Phenom II X4 955 bits: 64 type: MCP arch: K10 rev: 2 L1 cache: 512 KiB 
           L2 cache: 2048 KiB L3 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 25664 
           Speed: 3200 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 2100 2: 800 3: 3200 4: 800 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 430.64 bus ID: 01:00.0 chip ID: 10de:1c82 
           Display: server: X.org 1.20.8 driver: nvidia compositor: gnome-shell tty: 253x42 
           Message: Advanced graphics data unavailable in console for root. 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           bus ID: 00:14.2 chip ID: 1002:4383 
           Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0fb9 
           Device-3: C-Media CMI8738/CMI8768 PCI Audio vendor: TERRATEC Electronic Aureon 5.1 driver: snd_cmipci v: kernel 
           bus ID: 04:07.0 chip ID: 13f6:0111 
           Device-4: AKAI Professional M.I. type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-4.3:4 
           chip ID: 09e8:0045 
           Sound Server: ALSA v: k4.19.133-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8168 
           v: 8.048.03-NAPI port: d800 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 6c:62:6d:6e:4c:32 
Drives:    Local Storage: total: 8.41 TiB used: 1.59 TiB (18.9%) 
           ID-1: /dev/sda vendor: Western Digital model: WD30EZRZ-00GXCB0 size: 2.73 TiB speed: 3.0 Gb/s 
           serial: WD-WCC7K5YSYE31 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB speed: <unknown> serial: S3YJNX1K721753J 
           ID-3: /dev/sdc type: USB vendor: Western Digital model: WD Elements 25A1 size: 2.73 TiB 
           serial: 575832314437373748553845 
           ID-4: /dev/sdd type: USB vendor: Western Digital model: WD30EZRX-00D8PB0 size: 2.73 TiB serial: WD-WMC4N0E5EPXJ 
Partition: ID-1: / size: 143.18 GiB used: 48.75 GiB (34.0%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 23.44 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 43.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Repos:     Active pacman repo servers in: /etc/pacman.d/mirrorlist 
           1: https://mirror.23media.com/manjaro/stable/$repo/$arch
           2: https://manjaro.moson.eu/stable/$repo/$arch
           3: https://mirror.netcologne.de/manjaro/stable/$repo/$arch
           4: https://mirror.alpix.eu/manjaro/stable/$repo/$arch
           5: http://mirror.ragenetwork.de/manjaro/stable/$repo/$arch
           6: https://mirror.netzspielplatz.de/manjaro/packages/stable/$repo/$arch
           7: https://ftp.halifax.rwth-aachen.de/manjaro/stable/$repo/$arch
           8: https://mirror.philpot.de/manjaro/stable/$repo/$arch
Info:      Processes: 251 Uptime: 1h 24m Init: systemd v: 245 Compilers: gcc: 10.1.0 Shell: bash v: 5.0.18 running in: tty 1 
           inxi: 3.0.37

Hallo InBetweenDreams,
ich habe keine Ahnung, aber um es etwas einzugrenzen: Hast Du schon die vorgeschlagenen Lösungen probiert, z.B. perl-net-cups vom AUR installiert?
https://aur.archlinux.org/packages/blabel/

viele Grüße gosia

1 Like

Hallo @gosia,

ja, das Paket ist (immer noch) installiert:

#  pacman -Q|grep "perl.*cups"
perl-net-cups 0.64-1

… bzw die komplette Liste perl Pakete:

#  pacman -Q|grep "perl"
cairo-perl 1.107-2
glib-perl 1.329-4
gtk2-perl 1.24993-2
pango-perl 1.227-13
perl 5.32.0-1
perl-alien-build 2.26-3
perl-alien-libxml2 0.16-2
perl-cairo-gobject 1.004-10
perl-capture-tiny 0.48-4
perl-clone 0.45-2
perl-dbi 1.643-2
perl-encode-locale 1.05-7
perl-error 0.17029-2
perl-extutils-depends 0.8000-4
perl-extutils-pkgconfig 1.16-7
perl-ffi-checklib 0.27-2
perl-file-chdir 0.1011-4
perl-file-listing 6.04-8
perl-file-which 1.23-4
perl-gd 2.71-3
perl-glib-object-introspection 0.047-5
perl-gtk3 0.037-1
perl-html-parser 3.72-10
perl-html-tagset 3.20-10
perl-http-cookies 6.08-3
perl-http-daemon 6.06-2
perl-http-date 6.05-3
perl-http-message 6.25-1
perl-http-negotiate 6.01-8
perl-io-html 1.001-7
perl-lchown 1.01-12
perl-libwww 6.46-1
perl-lwp-mediatypes 6.02-8
perl-mailtools 2.21-4
perl-net-cups 0.64-1
perl-net-http 6.19-4
perl-path-tiny 0.112-2
perl-timedate 2.33-2
perl-try-tiny 0.30-5
perl-uri 1.76-4
perl-www-robotrules 6.02-8
perl-xml-libxml 2.0205-2
perl-xml-namespacesupport 1.12-4
perl-xml-parser 2.46-2
perl-xml-sax 1.02-1
perl-xml-sax-base 1.09-4
perl-xml-writer 0.625-6

Hast du schon versucht das AUR Paket neu zu installieren, bzw. alle davon abhängigen AUR Pakete. Dadurch wird es gegen das neue Perl kompiliert.

1 Like

Bei neuem perl musst du alle AUR perl Pakete neu bauen. Dies sollte eine Liste betroffener Pakete auf deinem System zeigen:

$ pacman -Qqo /usr/lib/perl5/5.30
1 Like

@xabbu & @freggel.doe — vielen Dank, darauf wäre ich nicht gekommen!

Ich habe nun blabel und perl-net-cups neu gebaut, schon druckt es wieder. :slightly_smiling_face:

Vielen Dank Euch! :+1:

# pacman -Qqo /usr/lib/perl5/5.30
error: No package owns /usr/lib/perl5/5.30

Thema erledigt

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by