Backlight config

I have been having problems with my ntb display brightness.
When any event related to chaning brightness is fired (brightness button, connection to power...) brightness is set to 0.
I tracked the problem down to the fact, that the system (not sure which part) uses scale 0..10 and clamps any higher value however intel-backlight expects 0..1500.

Setting via xbacklight or
brightnessctl works.
NTB: Acer F15
CPU: Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
GPU: Intel Corporation HD Graphics 620 + NVIDIA Corporation GM107M [GeForce GTX 950M]
Manjaro (kernels tried 5.2, 4.9, 4.19)
DE: i3 + kde plasma

It started few weeks ago. Probably after some update.

I went throught the archwiki and tried all the kernel flags suggested. No success.

Thanks for any suggestions

? Could you please explain ksy and more for non-native English people.
Start with

$ inxi -Fxxxza --no-host

Hello SGS, thanks for giving me the lead.
The sentence you asked about was just misspelled and I cannot recall what I meant but it was not important - I have removed it.

There is result of the command you asked for (I did not know this command, therefore I tried to provide basic info by hand):

>>> inxi -Fxxxa --no-host

System:    Kernel: 5.2.11-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.2-x86_64 root=UUID=69dcb16c-0a21-4ce9-a92f-ab38a1c41e08 rw 
           acpi_backlight=none quiet resume=UUID=3acc1f6f-6cc3-4a78-ac76-010e70b95903 pcie_asmp=force 
           Desktop: i3 4.17.1 info: xfce4-panel, vala-panel dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire F5-573G v: V1.27 serial: <root required> 
           Mobo: Acer model: Captain_SK v: V1.27 serial: <root required> UEFI: Insyde v: 1.27 date: 05/26/2017 
Battery:   ID-1: BAT1 charge: 36.8 Wh condition: 41.1/62.2 Wh (66%) volts: 12.8/11.1 model: PANASONIC AS16B5J 
           type: Li-ion serial: 6276 status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 8E (142) stepping: 9 microcode: B4 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21704 
           Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3100 2: 3100 3: 3100 4: 3100 
           Vulnerabilities: Type: l1tf 
           mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:5916 
           Device-2: NVIDIA GM107M [GeForce GTX 950M] vendor: Acer Incorporated ALI driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:139a 
           Display: x11 server: X.Org 1.20.5 driver: intel,nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa compositor: compton resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.1.5 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.2.11-1-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lite-On 
           driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0 chip ID: 168c:0042 
           IF: wlp3s0 state: up mac: 94:e9:79:c6:46:4b 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI 
           driver: r8168 v: 8.047.02-NAPI port: 3000 bus ID: 04:00.1 chip ID: 10ec:8168 
           IF: enp4s0f1 state: down mac: a8:1e:84:06:ee:ca 
Drives:    Local Storage: total: 1.03 TiB used: 251.75 GiB (24.0%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: Y67JPDENT rev: 5J scheme: GPT 
           ID-2: /dev/sdb vendor: Kingston model: RBUSNS8180S3128GI size: 119.24 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: 50026B7E74A2DBDE rev: 60B9 scheme: GPT 
Partition: ID-1: / raw size: 39.09 GiB size: 37.98 GiB (97.15%) used: 30.09 GiB (79.2%) fs: ext4 
           block size: 4096 B dev: /dev/sdb5 
           ID-2: swap-1 size: 15.63 GiB used: 5.2 MiB (0.0%) fs: swap swappiness: 60 (default) 
           cache pressure: 100 (default) dev: /dev/sda8 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: nouveau temp: 39 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 188 Uptime: 3d 17h 57m Memory: 15.53 GiB used: 3.34 GiB (21.5%) Init: systemd v: 242 
           Compilers: gcc: 9.1.0 clang: 8.0.1 Shell: zsh v: 5.7.1 running in: alacritty inxi: 3.0.36 

I tried find related records in journal, dmesg, and systemd status but I have found none (based on timestamp of occurence).

What else can I provide?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by