Backlight problem at startup

hallo/hey, i'm a linux newbie.

question under:

Blockquote
Operating System: Manjaro Linux
KDE Plasma Version: 5.14.5
Qt Version: 5.12.0
KDE Frameworks Version: 5.53.0
Kernel Version: 4.19.14-1-MANJARO
OS Type: 64-bit
Processors: 4 × AMD Ryzen 3 2200U with Radeon Vega Mobile Gfx
Memory: 6,8 GiB of RAM

when i start the system, command lines appear shortly and indicate the following error:

Blockquote
systemd-backlight@backlight:acpi_video1.service loaded failed failed Load/Save Screen Backlight Brightness of backlight:acpi_video1

my:

Blockquote
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f"

what can i do per sudo nano /etc/default/

or maybe a completely different approach?

Blockquote
NIT FILE                                   STATE   
org.cups.cupsd.path                         enabled
autovt@.service                             enabled
avahi-daemon.service                        enabled
bluetooth.service                           enabled
cronie.service                              enabled
dbus-org.bluez.service                      enabled
dbus-org.freedesktop.Avahi.service          enabled
dbus-org.freedesktop.ModemManager1.service  enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
display-manager.service                     enabled
getty@.service                              enabled
ModemManager.service                        enabled
NetworkManager-dispatcher.service           enabled
NetworkManager-wait-online.service          enabled
NetworkManager.service                      enabled
org.cups.cupsd.service                      enabled
sddm.service                                enabled

You can try ammending your kernel parameters with "noacpi" without the quotes. When you boot up and get to the grub screen, hit the Esc key and then hit the "e" key on your keyboard. Arrow down and over to the line you show above in Blockquote and add "noacpi with quotes between the words "quiet" and "resume" making sure there's one space in front and behind.

If that test works for you, then you can add "noacpi" permanently in your kernel parameter line of grub once you're logged back in. Don't forget to update grub after you do so.

whoa that's ryzen, you may try my kernel params :

GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=! acpi_osi='Windows 2009' acpi_backlight=vendor"

I think that's the win win solution. you got the same cpu as me

1 Like

thx greenmartian, but i will try the second (possible) solution from sagwascript at first. but i have a problem - where/how i can save my grub-settings? do i have to uncomment

GRUB_SAVEDEFAULT=true

to

#GRUB_SAVEDEFAULT=true

?

and what effects does this setting (quiet acpi_osi=! ..) have and what does it mean?

or - is it ^O ("write out") ? sry, before, i used manjoro in my language (german). but i remember it was ^O .. ?

  1. uncomment GRUB_SAVEDEFAULT=true if you don't need to save your last choice in GRUB menu, but overall doesn't affect anything other than that.

  2. for "acpi_osi=!", I don't know it for sure, but I knew it from someone in ubuntu forum with the same processor so I try it and all errors and warnings that come up on boot disappeared.

  3. I think it's ^O, sorry I rarely use nano, I prefer vim

yeah, it is ^O. after exit nano, do i have to do the following command:

sudo update-grub

?

sry, but i don't want to make any mistakes with the kernel (anymore :wink: ).

yes, that's the last step to apply your changes. just to make sure you had exactly the same parameters as mine before doing that, then proceed. chill out :slight_smile:

alarm!

i am writing from a live-usb session. after the changes i got a short error message at startup that "hilbernation" is not supported. when manjoro finished booting, i couldn't move my mouse pointer anymore. everything was frozen. what should i do now?

i can still start the terminal via keyboard. what settings should i set there, so that everything works again?

or are there other possibilities, because the system freezes completely after a while, so that the terminal can only be used for a few minutes.

mount your system partition to /mnt

sudo mount /dev/sdaX /mnt

change X (number) to your system partition
check it using

fdisk -l

then

sudo chroot /mnt

then you can revert your kernel params just like before
=================== easier solution ==============

  1. press 'e' when you are in GRUB menu, then edit the kernel parameter to the same before you change it, then boot

  2. when you enter the system, you can remove the kernel parameter in /etc/default/grub just like before. or you may try just remove this part

acpi_osi=! acpi_osi='Windows 2009'

and just left the

acpi_backlight=vendor
  1. save changes
  2. run sudo update-grub
  3. reboot

well I think the problem is the kernel, I also have bad experience using 4.19, I currently using 4.20 (and 4.18 before that), all good here

i couldn't read your last post anymore, but i remembered the one from greenmartian -> esc/e -> & this removed:

quiet acpi_osi=! acpi_osi='Windows 2009' acpi_backlight=vendor"

then i could start the system again and move the mouse pointer. afterwards i entered the old values in nano again via the terminal:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=0227c9e1-2b79-484b-9e4f-92afaefd161f"

but now, a new problem appears: every time i start or quit manjoro i see a screen with many command lines.

i think this has to do with the value after "resume". this value is usually variable (after every start). and now the value is "fixed" (i think). and this leads to these countless command lines and some error messages.

instead of this value, what am i supposed to do now by nano after:

GRUB_CMDLINE_LINUX_DEFAULT=

before i continue to experiment with the suggestions listed here?

that's the UUID of a partition to start system after hibernation, but I think you type it wrong, see your first post it written like this

GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f”

you can try to remove everything after quiet and see if the freezing happened again or not

Have you tried...

GRUB_CMDLINE_LINUX_DEFAULT=“quiet noapic acpi=off resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f”

Then updating grub, and a reboot?

@noemata you can try noapic but in my case, my laptop won't wake up after suspended

Right, that could be. But for now, it seems like noemata's first preference is the drive. Maybe advanced power features is a secondary concern atm.

GM

i'll try anything @sagwascript (what is noapic and where / how do insert it?) .. but first things first ..

right sag & martian, i forgot "UUID". current:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f”

is that correct now, as in the beginning? or have I made another mistake?

now the computer shuts down again without these command lines. but: if i restart the computer, i still have a screen with long command lines. it's not like before, where only the error message appeared.

Yes, you're back to original now. Make sure to update grub, and reboot.

If you read just above, I've offered you an alternative to try as well.

Also noemata,

Since you've mentioned that your a linux newbie, I'm wondering if you've also considered trying something like Kubuntu 18.04 LTS?

I'm not trying to push you away from Manjaro, but sometimes the fixed base (non-rolling) of an Ubuntu-based LTS distro can potentially be a less frustrating starting point to dive into Linux.

Even the flagship Ubuntu 18.04 LTS is a great starting point if you're ok with Gnome (which you can tweak to look like KDE/Windows/etc.

GM

sorry, it doesn't end. i just rebooted and the long command lines reappeared before the system was shut down. the same thing happens when i turn on the machine again. current settings:

i think it's wrong to enter an old value from an old session here (the string after UUID) .. i guess .. uff

ps: no nartian, i came from l. mint (after windows). manjaro is perfect, because i have no hardware-issues anymore (fan, temperature, ect.).

No, that original UUID is what you want there.

Is your machine booting and shutting down fine, but you're just seeing text syntax during both? If so, that's fairly normal with Arch-based distros. In the process, if you're briefly seeing a random error message, but you're system is 1) booting, 2) computing and 3) shutting down, then all is good.

Did you try...

GRUB_CMDLINE_LINUX_DEFAULT=“quiet noapic acpi=off resume=UUID=0227c9e1-2b79-484b-9e4f-92afaefd161f”

GM

Remember, Manjaro has a built-in kernel manager that you can find in the main menu. That will give you options to try other kernels. With an AMD chip, you should also experiment with those as support can vary per kernel. The kernel includes hardware drivers, etc and those kernels can vary a bit between the different distros.

Forum kindly sponsored by