Bad install, grub not loading properly on NVME? [KDE 17.0.2]


So I just finished putting together a new high end ryzen system and the first thing I proceeded to do was load up Manjaro 17.0.2. Everything was going fine, and I was admiring the new install all the way up until I got an error right before finishing. Here is what it gave me:

Installation Failed

Boost.Python error in job "boatloader".

<class 'subprocess.CalledProcessError'>
Command  'grub-mkconfig -o /boot/grub/grub.cfg' returned a non-zero exit status 1.

File "/usr/lib/calmares/modules/bootloader/", line 334, in run prepare_bootloader(fw_type)

File "/usr/lib/calmares/modules/bootloader/", line 305, in prepare_bootloaderinstall_grub(efi_directory, fw_type)

File "/usr/lib/calmares/modules/bootloader/", line 280, in install_grub "-o", libcalamares.job.configuration["grubCfg"]])

File "<string>", line 2, in <module>

Might this have something to do with the fact that I am trying to install this on an M.2 NVME SSD? (Samsung 960 Pro 512 GB)

To me it looks like a bug in Calamares. Can you try installing with manjaro-architect?
Your SSD should work, I have the 960 Evo.

Most likely you did not set mount point /boot/efi on a nvme partition.

Boot up livecd and provide

sudo parted -l
sudo blkid

Then provide Manjaro's installed partition info of Manjaro

@anon23612428 How do I install with that? I can't find it, and the manjaro hello just has a single button for calamares now, so...

@gohlip Pretty sure that's whwat you're after... It looks alright to me?

(Also, is there a problem with uploading images? I can't seem to do it, and am using other image hosting.)

Yes, correct. And it looks alright to me too.

Now, use this and see if you can boot to Manjaro installed OS in /dev/nvme0n1p2. If you get any error booting up, do the following at grub prompt in the livecd.

grub> search -f /boot/intel-ucode.img --set=root
grub> ls ($root)/boot/

Write down the kernel and initramfs, say vmlinuz-4.9-x86_64 and initramfs-4.9-86_64.img

grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.9-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.9-x86_64.img
grub> boot

After booting into Manjaro,

sudo pacman-mirrors -g
sudo pacman -Syyu
sudo pacman -S grub
sudo pacman grub-install
sudo update-grub

If you get any error (when doing grub-install) like efivar not found,

sudo pacman -S efibootmgr dosfstools efivar

and use this grub-install command

sudo grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --boot-directory=/boot --recheck --debug

Good luck.

ps: let us know what you have to do to get it fixed.
We'll know where the error comes from, it may be you originally installed (booted up live media) in bios-legacy mode and not uefi.

ps: try not to use screen shot (image), just use text and copy straight from your commands. If you use other languages, type "LANG=C" first so we can all read it.

You either download the architect ISO or install it in live mode with pacman -S manjaro-architect.

Alternatively, switch to legacy mode in BIOS instead of using fulll UEFI.

I don't think it's good to switch to legacy mode.
After all, he has /boot/efi and that would make it worse.

1 Like

Hi there,

I ran into the exact same problem and found that the issue already is known in 17.0.1:
Grub Install Fails Manjaro 17.0.1

However the option to select "CD/DVD/ISO" instead of "STICK/HDD" has been removed in version 17.0.2.

I tried to install the 17.0.1 version with the correct setting as CD/DVD/ISO, but calamares aborts with an error while creating the encrypted luks partition.
The next try is to upgrade the 17.0.1 live version before running the installer.


Hi everybody

So, I came back to the problem/my computer this weekend after my first week of college (which was both busy, and somewhat overwhelming)

So I found out what the problem was after some searching on the NVME drive I installed onto. I messed up when selecting the /boot/efi partition, and hit the wrong one, so it didn't mount there and mounted to an option below or above in the installer (oops). Anyway, I grabbed 17.0.3rc-1 (because I enjoy bleeding edge for some stupid reason) and made sure I installed it correctly, and now everything is working great.

I feel a little stupid, but oh well. Problem solved at least, right? :stuck_out_tongue:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by