Bad wifi speed

Hi I installed fresh manjaro kde and noticed it got very slow wifi speed.
I checked it on my desktop windows and download some game by torrent with avg download speed of 4mb/s.
Did the same with manjaro and got horrible download speed of 100 kb/s.
This is my system info:

System:    Host: sergey-x555uj Kernel: 4.19.126-1-MANJARO x86_64 bits: 64 compiler: gcc 
           v: 10.1.0 Desktop: KDE Plasma 5.18.5 tk: Qt 5.15.0 info: latte-dock 
           wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X555UJ v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X555UJ v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: X555UJ.302 date: 01/24/2019 
Battery:   ID-1: BAT0 charge: 19.6 Wh condition: 21.8/38.0 Wh (57%) volts: 7.5/7.5 
           model: ASUSTeK ASUS Battery type: Li-ion serial: <filter> status: Charging 
           cycles: 427 
CPU:       Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
           arch: Skylake rev: 3 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20736 
           Speed: 615 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 599 2: 600 3: 600 
           4: 600 
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915 
           v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
           Device-2: NVIDIA GK208BM [GeForce 920M] driver: N/A bus ID: 01:00.0 
           chip ID: 10de:1299 
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: intel 
           alternate: fbdev,vesa compositor: kwin_x11 resolution: 1600x900_60.00~60Hz 
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.0.7 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 00:1f.3 chip ID: 8086:9d70 
           Sound Server: ALSA v: k4.19.126-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
           chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lite-On 
           driver: rtl8723be v: kernel port: c000 bus ID: 03:00.0 chip ID: 10ec:b723 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 59.24 GiB (6.4%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
           speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 0001 scheme: GPT 
Partition: ID-1: / size: 906.94 GiB used: 57.07 GiB (6.3%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.80 GiB used: 2.18 GiB (24.7%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2600 
Info:      Processes: 213 Uptime: 9d 1h 03m Memory: 7.69 GiB used: 4.99 GiB (64.9%) 
           Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.0 Shell: bash v: 5.0.17 
           running in: konsole inxi: 3.0.37

That's actually a pretty bad way to measure wifi speed/performance:

  1. it's a download from the internet and not a data transfer from the local network
  2. to make matters even worse: it's a torrent

Try a (w)lan file transfer or iperf or some/such tool to measure local wifi speed.
Did you try another kernel?

First this:

(I took the liberty of editing OP because .. it was annoying to read before formatting)

Then ...

Is that your most recent available BIOS?


Try creating/editing /etc/modprobe.d/rtl8723be.conf with the following:

options rtl8723be ant_sel=1
options rtl8723be swenc=1
options rtl8723be ips=0
1 Like

I dont have this file but I created one and paste what you wrote there.
Is it right?

Yes. Then restart the system.
... or you could probably do the following:

sudo rmmod rtl8723be
sudo modprobe rtl8723be
#and maybe this one
systemctl restart NetworkManager
1 Like

Actually after restart my network cant find wifi anymore.

Mk switch the ant_sel=2, after that try 0.
(these ones have been reported to need to select the antenna - which is what thats doing)


I would try several things, disable MAC randomization and powersaving in Network Manager.

echo -e "[connection]\nwifi.powersave = 0" | sudo tee /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf && echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

Restart after running those commands.

1 Like


actually works for me, what do this options changed?

What consequences of this changes and what they do?
And how can I revert it if I got any problems?


The consequences are:

Disabling power saving for wifi marginally increases power consumption.

Disabling MAC Address randomization can allow you to be identified on networks where you repeatedly connect by your MAC Address.

You can reverse the changes by commenting out the lines in the files that were created, or by deleting the conf files that the commands created.

1 Like

So if,

fixed your speed issue, I'll mark @cscs's suggestion as the solution for you.

Glad things worked out for you.

Hi it was helpful but now I cant find any bluetooth devices.
Tried another kernels and installed blueman, the solution was to remove the .conf file I created.

...There were multiple options in that conf file.
And as already stated, all you need to do to disable an option is put a # in front of it.
That would have allowed you to check whether it was the ant_sel option or not.


What if I change the value to 0?

Its not the same as commenting out the option.
But you can try it and see.
The point was to find out if it was the antenna option or one of the others or ..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by