baloo_file_extractor high memory / shared menory usage.

bad Karma I would say

@Aragorn thank you for quickly responding to @linux-aarhus who should not have posted in this topic at all, their post is off-topic. @dagorret thanks for the quick post what if anything will disabling the service affect?

OK from info on that page there are two baloo's running. Both using just over 900 megs each.

I agree to a degree - because disabling baloo is an extreme measure too - if you want search functionality.

Yeah, it will only make everything worse.

1 Like

I have been in KDE for 2 days.

I don't know if file indexing affects any KDE subsystem.

Still I knew the problem before installing KDE. But it took a dozen minutes. And then, and so far, the Baloo is "acceptable."

[carlos@c55c ~]$ ps x -F |grep baloo
carlos      1156       1  0 67167205 24480 0 11:39 ?       SNl    0:00 /usr/bin/baloo_file
carlos      1391     997  0 67181676 42440 3 11:40 ?       Sl     0:00 /usr/lib/baloorunner
carlos      2100    1938  0  2206  2304   2 11:55 pts/3    S+     0:00 grep --colour=auto baloo

Edit: more info

[carlos@c55c ~]$ ps -o pid,user,%mem,command ax | grep baloo
   1156 carlos    0.3 /usr/bin/baloo_file
   1391 carlos    0.5 /usr/lib/baloorunner
   2208 carlos    0.0 grep --colour=auto baloo
[carlos@c55c ~]$

There are a couple of things that can help tame baloo without disabling it if that is your preference.

  • The way it should work is that there is painful initial index if you have a large amount of files and once that is done subsequent indexes should be fine. However, sometimes baloo decides to re-index, if this happens you should try to figure out why and stop that from happening.
  • If you don't need full test searching you can also tell it to only index filenames which makes it faster.

I had one machine that kept re-indexing and the only I found to stop it was to make ~/.config/baloofilerc immutable so it couldn't set the re-index flag.

@linux-aarhus & @eugen-b ok for now I have disabled the service temporally till a reboot. Any suggestion on how to get it to behave after the reboot?

No no no, don't use sudo. Baloo is not a system process. It runs with the UID of the user who's running Plasma. Just use...

balooctl disable
3 Likes

I have very little experience with KDE - I have to pass.

System Settings → Workspace → Search → Enable file search [ checkbox ]

1 Like

You're right baloo should only do the one indexing and update it as needed, not start a fresh index. Now if I'm using something like AngrySearch is baloo still necessary since you can manually update Angry's database?

No, lot's of people disable baloo. I keep it because Elisa uses it to index music. I could easily live without though.

Thanks anyway.

To clarify with Angry or say Catfist I don't need baloo?

If you disable baloo, you will lose baloo's functionality. For example, if you use krunner to search files, that won't work anymore. You will have to use something else to search files. So the question of "do you need it" is somewhat unique to the individual.

My advice would be to disable it and see if you lose anything important to you. If not, leave it disabled.

1 Like

OK perfect suggestion. Will do that. Was mainly worried cause of the word extractor. Was afraid it had to do with the engine for extracting files out of archives.

Edit I just searched from the desktop and the startpanel and those are still working just fine. Will do my restart and see what I get. Those two are the main places I search. If I get a popup box from a program to find a file / folder I just navigate to it rather than use the search that my be on the box.

OK just did my reboot and ran the system through it's paces and all seems good now. Thanks for the quick replies and help.

1 Like

2 posts were split to a new topic: Re: how to reduce memory to 100 mb on openbox

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by