Battery's capacity has changed

I am running Manjaro KDE in an year old Thinkpad X260 which comes with a good battery that lasts for almost 8hrs. A week back I noticed that the battery-panel indicator becomes red (when it is at 10% level) in shorter duration of time than usual. Its only when this happened repetitively, I thought something might be wrong with the battery. Regardin this situation, I have two questions:

1) What does this mean

After a 100% charge , when i checked the battery applet in the panel, it showed that around 4hrs remaining (which is half the usual).

Below are the outputs of few relevant commands

[varun@thinkpad ~]$ acpi -bi
Battery 0: Discharging, 88%, 02:57:19 remaining
Battery 0: design capacity 3953 mAh, last full capacity 2465 mAh = 62%

tlp stat output:


+++ Battery Status
/sys/class/power_supply/BAT1/manufacturer                   = SANYO
/sys/class/power_supply/BAT1/model_name                     = 45N1767
/sys/class/power_supply/BAT1/cycle_count                    = (not supported)
/sys/class/power_supply/BAT1/energy_full_design             =  47520 [mWh]
/sys/class/power_supply/BAT1/energy_full                    =  29640 [mWh]
/sys/class/power_supply/BAT1/energy_now                     =  25810 [mWh]
/sys/class/power_supply/BAT1/power_now                      =   6180 [mW]
/sys/class/power_supply/BAT1/status                         = Discharging

Charge                                                      =   87.1 [%]
Capacity                                                    =   62.4 [%]

Both of these show that the capacity of the batter is only 62%. Does this mean that one of the battery cells konked? (this post suggests so)

2. Unable to recalibrate

I thought of using tlp recalibrate command; but in order to run that I need to install tp-smapi-dkms and acpi-call-dkms. I tried to install them from community repo. But I am getting the following warning:

[2018-05-30 18:35] [ALPM-SCRIPTLET] ==> No kernel 4.14.44-1-MANJARO headers. You must install them to use DKMS!

I think both smpai and acpi are not installed properly. So, how to resolve No kernel headers problem? I already tried uninstalling and installing dkms.

Probably.

Batteries are consumable items and lose capacity over time, no matter what you do.

You need the kernel headers, in this case linux414-headers.

Or use the pre-compiled extramodules, linux414-tp_smapi and/or linux414-acpi_call (most stuff only needs acpi_call).

To me this indicates that one or more cells in the battery have died.
The charge is how much power it has in regards to its capacity.

Thanks for pointing these out. I will try my luck once with recalibration.

:disappointed_relieved: ....I was so happy with the battery duration time. I am gonna miss this part...

well when another cell dies, you could always replace the battery and get the full 8 hours back

Forum kindly sponsored by