BCM43142 not connecting to wifi

Hello everyone, first time Manjaro user here. I really want to switch to it, but given the problems I had in the past with this horrible BCM43142 I just made a small test partition next to my usual Ubuntu partition.

When I try to connect to any wireless network with the auto-installed broadcom-wl driver or with broadcom-wl-dkms, either it tries to connect to the network several times asking for the password before giving up, or it straight up gives up after about 20 seconds stuck on Setting network address.

I tried a lot of the solutions I found here and on the Arch wiki, but none of them worked and none of them seemed to describe the exact problem I had, I even tried different kernels.

Here's my lspci -k output for the network controller:

08:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
        DeviceName: Broadcom BCM43142 802.11bgn 1x1 WiFi Adapter + BT 4.0 combo adapter
        Subsystem: Hewlett-Packard Company BCM43142 802.11b/g/n
        Kernel driver in use: wl
        Kernel modules: wl

Worth checking the existing threads:


Essentially (unfortunately), they all come down to "buy a better card".

1 Like

Yeah, I've already checked every post regarding this problem, I have no idea what to do. I could use a USB dongle, but I have a limited number of ports on my laptop, and Ubuntu is working just fine, so maybe I should just stick with that... I could also try and change the card entirely, but I don't know if any other card would work.

Ok, so you did try from terminal:
sudo modprobe -r wl
and then
sudo modprobe wl
Check, just in case, this post too

Thanks, but unfortunately not even this solution seems to work.

i wonder if @tbg has been kidnapped? :scream:, not sure ive ever seen a networking thread last 10 minutes without him jumping on it. he's the resident wifi wizard.

can you post some system info.
inxi -Fxxxz
pacman -Qs broadcom
rfkill list all

I'd presume it's because he's answered the same question multiple times and it always has the same answer.

The card doesn't work in Manjaro, despite best efforts.


inxi -Fxxxz output:

System:    Host: marvin-manjaro Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           tk: Qt 5.12.0 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion 15 Notebook PC v: 0973120000405F10000620180 
           serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: Hewlett-Packard model: 2296 v: 78.21 serial: <filter> UEFI: Insyde v: F.42 date: 03/18/2015 
Battery:   ID-1: BAT0 charge: 29.8 Wh condition: 29.8/29.8 Wh (100%) volts: 16.8/14.8 model: Hewlett-Packard Primary 
           type: Li-ion serial: <filter> status: Full 
CPU:       Topology: Dual Core model: Intel Core i7-5500U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 4096 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19166 
           Speed: 799 MHz min/max: 500/3000 MHz Core speeds (MHz): 1: 798 2: 799 3: 798 4: 799 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:1616 
           Device-2: NVIDIA GM108M [GeForce 840M] driver: N/A bus ID: 0a:00.0 chip ID: 10de:1341 
           Display: x11 server: X.Org 1.20.3 driver: intel compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           chip ID: 8086:160c 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 chip ID: 8086:9ca0 
           Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM43142 802.11b/g/n vendor: Hewlett-Packard driver: wl v: kernel port: 6040 
           bus ID: 08:00.0 chip ID: 14e4:4365 
           IF: wlo1 state: dormant mac: <filter> 
           Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 
           bus ID: 09:00.0 chip ID: 10ec:8136 
           IF: eno1 state: down mac: <filter> 
           IF-ID-1: enp0s20u6 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 489.05 GiB used: 7.07 GiB (1.4%) 
           ID-1: /dev/sda vendor: Crucial model: CT525MX300SSD1 size: 489.05 GiB speed: 6.0 Gb/s serial: <filter> rev: R060 
           scheme: GPT 
Partition: ID-1: / size: 29.73 GiB used: 7.03 GiB (23.7%) fs: ext4 dev: /dev/sda7 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 172 Uptime: 2h 19m Memory: 15.59 GiB used: 1.51 GiB (9.7%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 4.4.23 running in: konsole inxi: 3.0.28

pacman -Qs broadcom output:

local/linux419-broadcom-wl (linux419-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.

rfkill list all output:

0: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no
4: phy3: Wireless LAN
        Soft blocked: no
        Hard blocked: no

Yeah, I'm slowly accepting my fate... Since I'll be upgrading to an M.2 SSD and a new battery next mont, I think I'll look into a new wlan module as well.

yeah, that does seem more likely :grin:.

@ecavicc as a last ditch attempt, have you tried this? uninstall the linux419-broadcom-wl first and try this. you'll also need an aur helper like yay for example, linux419-headers, base-devel.
sudo pacman -R linux419-broadcom-wl
sudo pacman -S linux419-headers base-devel yay

broadcom 43142 on archlinux no interface
Install the broadcom-wl-dkms package.

You can Install it from AUR using  yay :

yay -S  broadcom-wl-dkms
Unload conflicting modules.

rmmod b43
rmmod ssb
rmmod bcma
Load the wl module:

modprobe -r wl
modprobe wl

may also want to check this thread out. the title says bcm4359 but tbg addressed the difference at the beginning of the thread and searching "bcm43142 b43-firmware arch" on duck duck go returns solved threads that show b43-firmware or b43-firmware-classic as the solution like in this post:


Well, nothing worked, I've been defeated by Broadcom :upside_down_face:

I guess I should start looking into new wlan modules, I've found the list of the compatible ones with my laptop, and I'll make sure to buy one compatible with linux too.

Thanks anyway!


:man_shrugging: it was worth a shot. from the looks of it, even if you got it working it would probably perform poorly anyhow.

hopefully the ones listed on the whitelist for your laptop will work better, just be sure they are on the hp whitelist for your exact model, use the product/model service number, not just hp pavilion 15 in general. best of luck.

1 Like

Yes this adapter is a bit of a mess in Manjaro for support. If you already have the wl-broadcom drivers installed then testing kernel 4.20 may be worth a shot. The wl driver has been reported broken on kernel 4.19 with some Broadcom adapters recently.

This adapter is generally a real dud, but it also seems luck of the draw. Some people do get this adapter working satisfactorily, but that is by far the minority.

Good luck, but I'd start researching a USB adapter with good Linux support as a replacement.

PS. I'm on my cell as I'm out visiting and missed the thread without a computer handy.

You should also try changing the settings in Network Manager connection properties. Set connection to available for all users and save password unencrypted. Doubtful it will help with this adapter, but you never know.


Recently this adapter has been getting a little better supported. The key seems to be using one of the more recent kernels above 5.0 with the wl-dkms driver. The other key things is to make sure Mac Address randomization is disabled.

so not kidnapped then i take it :joy:

No not kidnapped, but as Jonathon already mentioned it is almost pointless attempting to fix this card. Pretty much the best solution is replacement, but every once in a blue moon someone actually gets this adapter working properly. Then you feel like an idiot if you recommend replacement right off the hop and they come back with "I got it working". :smile:

ya, im a sucker for lost causes. thought i'd try and maybe get lucky. :man_facepalming:

Sorry for disappearing, I forgot to turn on email notifications.
I've already tried with 4.20, no luck there. I asked on the HP forum about whitelisting and I was told there's none on this chipset, so I should be good to go on any card with the same form factor. I was also told that Intel modules work well with Linux but behave poorly with just one antenna (unfortunately there's just one installed. I could buy the two antennas set but it's not cheap and I don't want to risk messing up my display disassembling it), so they recommended the Atheros ar9485. Does anyone know anything about it? I mean, it's cheap, so even if it didn't work it wouldn't be that much of a waste, but the shipping takes long, so I just want to be sure.

I know nothing about that chipset. Which is probably a good sign, because all the problematic ones I see on the forum on a regular basis. Atheros has several chips that are real dogs and I see posts about them daily. That's not one of them that pops up regularly.

Search here for info on that chips Linux support:


1 Like

Apparently it's supported by the ath9k driver.
Well, I'm ordering it, I'll update you in two or three weeks when it arrives (I know, very fast shipping).

Thanks for all the help!

1 Like

If "lsmod" and b43 shows up, remove it with "modprobe -r b43", in the mean time check if "wl" is in the list, or activate it with "modprobe wl", I had the same issue, the thing is the mhwd installed the driver somewhere else other than "/lib/modules/" hence the system wasn't able to detect it.

Forum kindly sponsored by