BCM4360 - Wifi does not work: TP-Link AC1750 Archer T8E

Hi!
Tried to get help on the same problem i Feb 15, but then I didn't have Internet Access at all.

Link to earlier forum post: Wifi does not work: TP-Link AC1750 Archer T8E PCI Express Adapter

This time I got wired connection to internet, and I really want to give this a second try before purchasing a new wifi netword card.

Can some of you guide me through the process of fixing the drivers for my wifi network card or check if it is supported on Manjaro at all?

[user@user-pc Desktop]$ inxi -Fxz
System:
  Host: user-pc Kernel: 4.19.66-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.1.0 Desktop: Xfce 4.14.1git-23545d Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASUSTeK model: Z170 PRO GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 0231 date: 07/17/2015 
CPU:
  Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 64152 
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 802 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: NVIDIA GM204 [GeForce GTX 980] vendor: Gigabyte driver: nvidia 
  v: 430.40 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.5 driver: nvidia 
  resolution: 1920x1080~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: GeForce GTX 980/PCIe/SSE2 v: 4.6.0 NVIDIA 430.40 
  direct render: Yes 
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Device-2: NVIDIA GM204 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Sennheiser type: USB driver: hid-generic,snd-usb-audio,usbhid 
  bus ID: 3-1.2:4 
  Sound Server: ALSA v: k4.19.66-1-MANJARO 
Network:
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k 
  port: f000 bus ID: 00:1f.6 
  IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network 
  Adapter 
  driver: bcma-pci-bridge v: N/A port: e000 bus ID: 03:00.0 
Drives:
  Local Storage: total: 3.64 TiB used: 9.40 GiB (0.3%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  ID-2: /dev/sdb vendor: Seagate model: ST3000DM001-1ER166 size: 2.73 TiB 
  ID-3: /dev/sdc vendor: Crucial model: CT500MX200SSD1 size: 465.76 GiB 
Partition:
  ID-1: / size: 61.27 GiB used: 8.66 GiB (14.1%) fs: ext4 dev: /dev/sdc3 
  ID-2: /home size: 393.47 GiB used: 759.6 MiB (0.2%) fs: ext4 
  dev: /dev/sdc4 
  ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdc2 
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 39 C 
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 19% 
Info:
  Processes: 241 Uptime: 4m Memory: 31.34 GiB used: 1014.6 MiB (3.2%) 
  Init: systemd Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.35 

sudo pacman -S linux419-headers dkms broadcom-wl-dkms

reboot

3 Likes

There's like a million threads with this broadcom chip in it. :rofl:
Use the search young padawan. :smirk:

https://wiki.archlinux.org/index.php/Broadcom_wireless

2 Likes

Did what dglt suggested:

sudo pacman -S linux419-headers dkms broadcom-wl-dkms

and then I rebooted the system, everything works now.
Thank you so much guys!

1 Like

glad it worked out, in the future do a forum search (what @Sinister and myself did) and the solution was ready and waiting.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by