BCM43602 brcmfmac driver causes kernel panic in WPA2 networks

I just noticed that a known kernel bug is also affecting Manjaro:

When sporting a BCM43602 SoC WiFi & Bluetooth chip, which is present in WiFi cards labelled "Dell Wireless" like in the Dell XPS 9550 and some Apple MacBook Pros, the system freezes hard when there's heavy load on the WiFi.

It seems that it's occuring when connected to WPA2 Networks.

I tried installing wl-wireless, but this package doesn't support this chip. The only way around this panic seems to be swapping in an alterantive wifi card, unless there's another driver package suppoting this SoC.

Try the broadcom-wl-dkms driver. See the instructions for installing here:

I should have written that more clearly in my initial post: I installed broadcom-wl-dkmsand blacklisted brcmfmac, then ran modprobe wl and even rebooted after adding brcmfmac to a block list and adding wl to the module load list.

But to no avail: The driver didn't pickup my wireless card.

Did you install the Linux headers with the wl dkms driver?

Yes, for my current kernel, dkms reported failure due to missing headers for 4.14, but I'm running 4.18 as my day-to-day kernel.

The driver loads, lsmod shows wl as being loaded.

Do you think the failure of dkms with the 4.14 headers could affect running it with 4.18?

Post the output of

dkms staus

I'll do when I get back home :slightly_smiling_face:

1 Like

You need to install the headers for each kernel you are using when you are using the dkms driver version.

Example:

sudo pacman -S linux414-headers
sudo pacman -S linux418-headers

Both those packages need to be installed.

I would suggest installing and testing kernel 4.19 as well as kernel 4.14 with the appropriate headers. It is possible that the driver may only perform properly on a limited number of kernels so test out all three.

You may also want to consider disabling Bluetooth if you don't use it. Bluetooth can cause problems sometimes when on the same chip.

I've followed this approach, but no change.
I think broadcom-wl-dkms doesn't support my chip. It's not on the list of supported SoC:

  • Broadcom BCM4311 (PCI IDs 14e4:4311, 14e4:4312)
  • Broadcom BCM4312 (PCI ID 14e4:4315)
  • Broadcom BCM4313 (PCI ID 14e4:4727)
  • Broadcom BCM4321 (PCI IDs 14e4:4328, 14e4:4329, 14e4:432a)
  • Broadcom BCM4322 (PCI IDs 14e4:432b, 14e4:432c, 14e4:432d)
  • Broadcom BCM43224 (PCI IDs 14e4:0576, 14e4:4353)
  • Broadcom BCM43225 (PCI ID 14e4:4357)
  • Broadcom BCM43227 (PCI ID 14e4:4358)
  • Broadcom BCM43228 (PCI ID 14e4:4359)
  • Broadcom BCM43142 (PCI ID 14e4:4365)
  • Broadcom BCM4331 (PCI ID 14e4:4331)
  • Broadcom BCM4352 (PCI ID 14e4:43b1)
  • Broadcom BCM4360 (PCI IDs 14e4:43a0, 14e4:4360)

There's no 43ba listed, but according to lspci that's what I've got built-in.

lspci -vnn -d 14e4: 
02:00.0 Network controller [0280]: Broadcom Limited BCM43602 802.11ac Wireless LAN SoC [14e4:43ba] (rev 01)
	Subsystem: Dell BCM43602 802.11ac Wireless LAN SoC [1028:0020]

My apologies I believe you are correct. I keep extensive notes on the different Broadcom adapters at home with the driver compatablities listed for each card. Unfortunately I am not at home and was simply going by a Google search which listed the wl driver as compatible with your card.

After going to more authoritative sources online I see that the source I relied on was incorrect. After double checking I now see that the wl driver is not listed as supported for your card. I'm very sorry I relied on an Ubuntu post rather than going to one of the authoritative sources for my info. My bad, being on my cell is somewhat limiting.

The combo Bluetooth cards can have interference problems. If you are not using Bluetooth then perhaps disabling Bluetooth may improve your wifi. To disable Bluetooth do the following:

You can create a file:

/etc/modprobe.d/bluetooth.conf

Add the following line to the file.

install bluetooth /bin/false

That should totally disable all Bluetooth modules from starting.

Disabling the Bluetooth service is also a good idea.

sudo systemctl disable bluetooth.service

If you don't use Bluetooth this will save a little bit on resource usage and speed up your boot time. So, even if it doesn't improve your wifi, it's still a worthwhile tweak if your Bluetooth is unused.

You don't have to apologize for anything. I do appreciate you tried to help.
I need bt, so I cannot turn it off. I guess I need to avoid heavy loads on WPA2 networks :frowning:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by