Best way to virtualize manjaro?

I don't particularly like virtualization, therefore I'm not very good with it. Now I'm in a new situation, where I would like to run virtualized manjaro on Windows host for actual production work. I'm more familiar with virtualbox, but I also got a VMware workstation license from work.

So far both options have some issues:

VirtualBox:

  • VMSVGA doesn't work with the guest utils in the repos, they need to be compiled manually to resize display
  • shared clipboard doesn't work
  • hot corners don't wotk unless I disable mouse integration (makes sense)
  • performance can be spotty
  • multiple monitors are a pain to setup on every boot (windows host issue)

VMware:

  • cannot set the correct aspect ratio for my display. There is an option for it but it does not work I have to choose between wasting screen space with black bars and having stretched display
  • hot corners don't work and I haven't found a way to work around it
  • performance seems slightly better than with virtualbox

Does anyone have any opinions on virtualization or tips on improving the experience?

It should automatically resize to fit the size of the Window, you shouldn't need to set them manually. Do you have vmtoolsd.service enabled?

If so, try this fix: VMWare - Can't change screen resolution

That is interesting. It doesn't work for me either. It works on the sides but not the corners.

Depending on what you are doing, it can be significantly better.

I am a heavy VM user and vmware just works for me. At any given time I have 50 or so VMs on my workstation and usually 2-6 of them are running. vmware makes management of all that painless.

I have also played with QEMU but I couldn't get reasonable graphics performance on Windows without resorting to GPU passthrough. For Linux guests it worked fine though. It isn't something I would call simple though.

EDIT: I also have a series of VMs I test on virtualbox but I don't use them much. VB is just not reliable enough for me. I know, in theory, it should be more reliable but it isn't. It seems like ever since pieces of it were moved into the kernel it is more prone to breakage. It seems to work better on Windows hosts than Linux hosts though.

I use VirtualBox. Presently I have a Manjaro KDE guest (among others) on a Manjaro Xfce host. KDE has 4 CPU's dedicated. Display is VMSVGA, 128 MB (3D disabled)- no problems. guest-utils are installed without modification.

Here are some possibilities to consider (guest side):

D/T doesn't go full screen- Did you run guest additions and reboot?

Can't open sf_share- Are guest-utils installed? Is guest user in groups root, vboxusers, and vboxsf (and at least logout/login after)?

No sf_share- Is guest user in vboxsf group?

No USB or host camera- Is extension pack installed? Correct version?

Disk encryption problems- Is extension pack installed? Correct version?

It should. It does not. If it did I would not have tried to set it up manually. With Fedora it works, zorin and manjaro get wrong resolution options.

Thanks, I'll look into it!

For me, with VirtualBox on a Win10 host, VBoxSVGA Graphics Controller, re-sizing works automatically. I can re-size, move my Manjaro Guest window from one monitor to another, and use Full-screen mode without issues.

However, I just tested the shared clipboard, and Settings > General > Advanced tab > Enable your Shared Clipboard no longer works for me. I wonder when it stopped.

My only complaint is that I believe my organization's standard Win10 build has some kind of hardened systems security program which frequently complains about starting a VM, but if I keep trying, it eventually launches.

I somehow got vmware resolution problem sorted. Not sure how. Then, I tried to make system lighter by disabling tlp, modemmanager, cups, app armor and stuff like that. I also Removed app-armor related kernel parameters. On reboot the issue had returned. I have no idea how i caused it.

On Windows you have that Hyper-V. It is supposed to have the best performance.
Also here: https://wiki.archlinux.org/index.php/Hyper-V

Same for me with vmware, it feels like gambling. Sometimes it picks up the resolution and sometimes not. I usually reboot the vm so long until it works :crazy_face:

Did you override the service with this as described in the above link?

[Unit]
Description=Open Virtual Machine Tools (VMware Tools)
ConditionVirtualization=vmware
After=display-manager.service

[Service]
ExecStart=/usr/bin/vmtoolsd

[Install]
WantedBy=multi-user.target

Otherwise you can have a race condition where sometimes it will work and others not.

I did, it did not seem to have an effect. I'll try it again on a new VM. Although now it seems that virtualbox has currently better performance. It's just annoying that it crashes randomly.

Stick with VMWare. The problem with Manjaro in a vm is the amount of vgamem it has set as a default. In kvm you would virsh edit and then look under video and raise the vgamem=16384 and change it to vgamem=65536. You may need to add a modeline or a custom conf, but in the past this has worked for me. Exactly how to do this in VMWare is something I am sure I will have to figure out myself as it is what is available at work. On my personal machines I always run KVM and that is the root cause of the problem. Hope this helps.

So, I got the resolution issue fixed, but it still randomly spawned despite adding that line to the service. For some reason I also got the issue in both VMs, where windows frequently became unresponsive until the my lost and regained focus.

So, I chose Fedora. VMware seems cater to it especially, and everything just works. As an added bonus, most of our servers at work are centos, so there is much synergy there. It comes with stable and responsive vanilla gnome desktop, which is what I would use anyway. And while dnf is no pacman, it's the next best thing.

So, it seems that in my use case, the best way to virtualize Manjaro is to virtualize something else instead.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by