BIOS not accessible after installation of Manjaro GRUB

Hello everyone, I'm a complete newbie to Manjaro and Arch as a whole.

So I decided to install a version of Manjaro KDE to help with my Linux/UNIX programming skills. I have run into several problems doing so so far. I had to configure my Windows drivers and change the hard drive mode from RAID to AHCI. I had to make a secure boot exception.

My current BIOS is InsydeH2O running on an Acer laptop (the Predator Helios 300 2019 ver.) When I successfully installed Manjaro KDE on the laptop and reboot it, it just booted straight into Windows with no GRUB screen, no nothing.

Worse, when I tried to get into my BIOS I'm instead greeted by a black screen with a blinking cursor at the top left corner and nothing else. It was as if my BIOS was rendered completely useless and inaccessible.

So then I tried an alternative: rEFInd. I installed rEIFind through Windows and set the boot config through that, then restarted and voila! Secure boot fail, I had to open up my laptop to reset the CMOS since my BIOS is blocked for some reason.

However, I could use GRUB normally (not really, but I make a secure boot exception through the BIOS and I can boot into GRUB with my BIOS alive.) I decided to reinstall Manjaro because I screwed with some files and it was kinda broken. Then once again it blocked my BIOS, and I have no idea how this happened or how to solve it.

Is there any way to solve this problem without having to result to rEFInd?

FYI, when I accessed the EFI from cmd prompt to delete the grubx64.efi file, the BIOS magically worked again. But then I needed that file to boot directly into GRUB, so I'm still confused.

1 Like

You have to completely disable both Secure Boot and Fast Boot. Manjaro does not support those settings.

As far as I know InsydeH2O BIOS has no fastboot modification option. I tried disabling secure boot but it looks like that wasn't enough.

That's interesting. Never heard of it. Can you give more details on "how it's done"?

This is also interesting. Weird things happen on new hardware?

You might want to try booting to a Manjaro LiveISO and investigate
Boot OS with broken bootloader


From AgentS link, there is Acer Aspire E15 link that shows how to set manjaro efi file to Acer firmware. Not sure though if this can work for your Acer.

ps: if you delete manjaro grubx64.efi file, you have no file you can set path to in the bios.
but if you delete it and the bios work again, you may (I don't know) have a microsoft tied-in Acer.
And you will need, if you want to install non-shim linux OS's like manjaro, to go about this type of method to make it work.

From this link it is using the EasyBCD type method, which you are familiar with and I won't touch it.
You could through this method, using windows boot access manjaro boot.
You may want to see if you can help OP on this method. I don't and won't use this method.
If this machine is tied in to Windows, Microsoft owns this machine.

Oh.. it is UEFI and the method may differ from 'mbr' EasyBCD.


I installed rEFInd using this procedure:
It can be done by mounting the EFI partition using diskpart in command prompt.

It is weird indeed, and having to take apart a laptop to reset CMOS with warranty at risk wasn't a pleasant experience. The worst part is for some reasons Acer still opt for InsydeH2O on such a recent hardware.

1 Like

I'm having doubt about that, too. But there is something incredibly unusual going on since it worked just fine if I take my laptop apart to reset CMOS (BIOS hardware reset).

Great! Just confirm to us (when all is working fine, later) that you've got it working well.
Good to hear things like this.
Better if you can tell us you gave Microsoft a kick in the butt. Tell us how too, so others can have their 'kick' too. :rofl:



Thanks for the help :slight_smile: I also contacted Acer to ask more about the problem & will post if anything of interest comes up. I'm really looking forward to a more permanent solution, since I'd have to open my laptop to reset CMOS every time GRUB is reinstalled (which is annoying and risky).

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by