black colored lines appeared while playing videos/games

Hey everyone,
There's a problem related to screen fluctuations(i think) occur in manjaro 18.0.4 .. I mean that whenever I play vlc or maximize any window some black colored lines appears on the screen and i don't know why this problem arises.
can you please tell me that how can i tackle this problem?
Thank you.

some more info would be helpful. please post ( use the </> button so it's formatted).

inxi -Fxxxz
mhwd -li
ls -laR /etc/X11/
cat /etc/X11/xorg.conf.d/*.conf

also try changing compositor options in kde settings.


Moved from #general-discussion to #newbies as this is a request for help, not a discussion item

Great Sir, i've three compositer installed in my laptop i.e., OpenGL 3.1 , OpenGL 2.0, Xrender
and i'm using OpenGL 3.1 and way back i removed my workspace theme because of lagging problems and switch to breath(dark) and started using ShowFPS options for viewing fluctuations
After than, i downgrade my kernel from 5.0.5_rt3_1 to 5.0.1
i removed all heavy usage widgets and made my desktop more simple
okay what'd you think, is this a good idea?

IIRC the modules are built to be used with a certain kernel. i've never used an rt kernel but i dont think thats even considered a downgrade since 1 kernel is rt and the other is not. if your having issues using the 5.0 kernel, try the 4.19 or 4.20.

regardless, without further info it's all just a guessing game

The current version in the stable branch is 5.0.1 so you should make sure your system is fully up-to-date.

sudo pacman-mirrors -f5
sudo pacman -Syyu

correct, i also think that screen problem isn't related with downgrading the kernel but after all i half solved that problem of black colored lines appearing
Now while watching videos or playing games(gta,tekken,assains creed) no black color lines appeared but if user press any special button(like increasing sound/brightness, move 20sec. forward) than some lines appears otherwise no line appearing problem occur.

I just
replace my xrender compositor with OpenGL 3.1
change scale method from Accurate to smooth
change desktop effects to defaults
mhwd output ->

Installed PCI configs:
                NAME               VERSION          FREEDRIVER           TYPE
         video-linux            2018.05.04                true            PCI
       network-r8168            2016.04.20                true            PCI

ls -laR /etc/X11/ output ->

total 40
drwxr-xr-x  5 root root  4096 Aug 18  2018 .
drwxr-xr-x 99 root root 12288 Apr 13 00:14 ..
drwxr-xr-x  2 root root  4096 Aug  9  2018 mhwd.d
drwxr-xr-x  3 root root  4096 Mar 15 16:33 xinit
drwxr-xr-x  2 root root  4096 Sep 14  2018 xorg.conf.d

total 12
drwxr-xr-x 2 root root 4096 Aug  9  2018 .
drwxr-xr-x 5 root root 4096 Aug 18  2018 ..

total 28
drwxr-xr-x 3 root root 4096 Mar 15 16:33 .
drwxr-xr-x 5 root root 4096 Aug 18  2018 ..
-rw-r--r-- 1 root root  739 Mar  5 00:01 xinitrc
drwxr-xr-x 2 root root 4096 Mar 15 16:21 xinitrc.d
-rw-r--r-- 1 root root   45 Mar  5 00:01 xserverrc

total 20
drwxr-xr-x 2 root root 4096 Mar 15 16:21 .
drwxr-xr-x 3 root root 4096 Mar 15 16:33 ..
-rwxr-xr-x 1 root root  318 Nov 10 02:48
-rwxr-xr-x 1 root root  203 Mar 12 13:06

total 16
drwxr-xr-x 2 root root 4096 Sep 14  2018 .
drwxr-xr-x 5 root root 4096 Aug 18  2018 ..
-rw-r--r-- 1 root root  266 Sep 14  2018 00-keyboard.conf

cat /etc/X11/xorg.conf.d/*.conf output ->

# Read and parsed by systemd-localed. It's probably wise not to edit this file
# manually too freely.
Section "InputClass"
        Identifier "system-keyboard"
        MatchIsKeyboard "on"
        Option "XkbLayout" "us"
        Option "XkbModel" "pc105"

finally upgrading

i think that its not that kind of reliable information but maybe used whenever this kind of problem exist in manjaro kde.

Output of sudo pacman-mirrors -f5 ->

::INFO Downloading mirrors from
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  2.408 Germany        :
  1.213 Germany        :
  ..... Germany        :
  2.776 Georgia        :
  1.886 Georgia        :
  2.325 Netherlands    :
  1.275 Netherlands    :
  ..... Netherlands    :

::ERROR ftp error: timeout('timed out') ''

  ..... Taiwan         :
::INFO Writing mirror list
::Germany         :
::Georgia         :
::Germany         :
::Taiwan          :
::Netherlands     :
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist

did you run the full update after?
sudo pacman -Syyuu

not sure if uu is still needed currently but it also wont hurt either.

Yes full update and using -Syyu
but now if i do sudo pacman-mirrors -f5 ftp error: timeout not happened

reset you mirrorlist and run an -Syyuu update

sudo pacman-mirrors -c all -aP all
sudo pacman-mirrors -f8
sudo pacman -Syyuu            <------2 u's , not 1

answer yes to all


This sounds like a compositor problem with full screen applications, especially with Wine - the Kwin compositor sometimes works ( means disables itself ) but most of the time it doesn't. Disable it manually with Alt+Shift+F12 while playing games and re enable it afterwards the same way.


Yes right, its a compositor problem but not with full screen applications because when i run gta's it adjust itself in a low resolution with good graphics but still do problem for others(like desktop, apps, remain low screen resolution).

Well this leads to a few other questions...

  • Please provide the needed info about your hardware, GPU - Monitor(s) HDPI - 4K? - resolution.
    How to provide good information in your posts
  • What do you use to play this games? Steam, Lutris, Wine, POL, Crossover ...? You see it's a guess game.
  • In case of GTA V - Did you set it to Directx11 instead of 10 in the in-game options?
  • Also note that Windowed applications will always have performance issues when the compositor is enabled.

Do you mean the game sets your monitor to the game resolution and doesn't change it back?

did these mirrors increase the speed of package installing?

it resets your mirror list and -f8 sorts out the fastest 8 servers and makes them the mirrors used for updating, so yes it can make updating faster depending on the mirrors used.

though i think your problem is probably compositor related like @pux mentioned.

  1. hardware, GPU - Monitor(s) `HDPI - 4K?
System:    Host: Manjaro Kernel: 5.0.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 
           Desktop: KDE Plasma 5.15.3 tk: Qt 5.12.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Dell product: Vostro 14-3468 v: N/A serial: <filter> Chassis: type: 9 
           serial: <filter> 
           Mobo: Dell model: 0T1X3V v: A00 serial: <filter> UEFI: Dell v: 1.12.0 date: 07/10/2017 
Battery:   ID-1: BAT0 charge: 21.3 Wh condition: 37.8/41.4 Wh (91%) volts: 15.1/14.8 
           model: SMP DELL VN3N047 type: Li-ion serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i3-7100U bits: 64 type: MT MCP arch: Kaby Lake rev: 9 
           L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19204 
           Speed: 1295 MHz min/max: 400/2400 MHz Core speeds (MHz): 1: 1295 2: 917 3: 976 4: 1134 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin_x11 resolution: 1366x768~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.0.1 
           compat-v: 3.0 direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.0.5-1-MANJARO 
Network:   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 
           chip ID: 8086:3165 
           IF: wlp1s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 
           v: 8.045.08-NAPI port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 186.04 GiB (20.0%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB speed: 6.0 Gb/s 
           rotation: 5400 rpm serial: <filter> rev: 3D scheme: GPT 
Partition: ID-1: / size: 907.52 GiB used: 186.04 GiB (20.5%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.20 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 43.0 C mobo: 40.0 C 
           Fan Speeds (RPM): cpu: 3438 
Info:      Processes: 183 Uptime: 45m Memory: 3.72 GiB used: 1.89 GiB (50.7%) Init: systemd v: 241 
           Compilers: gcc: 8.2.1 clang: 8.0.0 Shell: bash v: 5.0.2 running in: yakuake inxi: 3.0.32

What do you use to play this games? Steam, Lutris, Wine, POL, Crossover ...? You see it's a guess game?

Answer: I've games installed on my machine. So, I use Wine, ppsspp/pcsx2 emulator to play

  1. There're several games installed i.e., tekken3, tekken7, GTA sanandreas/vice city/III, Asphalt Urban GT, Call of duty Finest Hour, pubg.
    So, some of them were iso files and some are .exe files. for running .iso files i used "ppsspp/pcsx2" and for .exe files i used "Wine".

Do you mean the game sets your monitor to the game resolution and doesn't change it back?

Yes correct, and to change it back(to original resolution) I need to re-arrange the size of the laptop screen in Display and Monitor settings.

yes sir, problem is with the compositor
I'll provide you the feedback after completely fixed all the problem.
btw thanks for your help :slightly_smiling_face: :slightly_smiling_face:

1 Like

To fix this for WINE run winecfg, go to graphics tab, check emulate virtual desktop, set the resolution to 1366x768 for full screen or what ever you like and hit apply.



Thank you, Sir it works perfectly ..
just because default parameters are set to 800 * 800 that's why low screen resolution problem occurs after using wine for games.

btw thanks a lot sir. :slightly_smiling_face: :slightly_smiling_face:


Forum kindly sponsored by