Black screen after installing video-nvidia-390xx

$ mhwd -li
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI


Warning: No installed USB configs!

$ mhwd -l
> 0000:01:00.0 (0302:10de:139b) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
          video-nvidia            2018.08.09               false            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI


> 0000:00:02.0 (0300:8086:191b) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI
video-hybrid-intel-nvidia-390xx-bumblebee            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

$ sudo systemctl status bumblebeed.service
● bumblebeed.service - Bumblebee C Daemon
   Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor preset: disabled)
   Active: active (running) since Sun 2018-09-16 12:16:41 CEST; 1h 34min left
 Main PID: 524 (bumblebeed)
    Tasks: 1 (limit: 4915)
   Memory: 1.3M
   CGroup: /system.slice/bumblebeed.service
           └─524 /usr/bin/bumblebeed --use-syslog

sep 16 12:16:41 german-pc systemd[1]: Started Bumblebee C Daemon.
sep 16 12:16:42 german-pc bumblebeed[524]: /usr/bin/bumblebeed 3.2.1-2017-02-27-Format:%h$ started

pacman -Qs acpi_call outputs nothing


$ pacman -Qs bbswitch
local/linux414-bbswitch 0.8-58 (linux414-extramodules)
    kernel module allowing to switch dedicated graphics card on Optimus laptops

can you check

optirun -b none nvidia-settings -c :8 

sudo journalctl -b 0 | grep 'acpi'
sudo journalctl -b 0 | grep 'bbswitch'
sudo journalctl -b 0 | grep 'nvidia'
sudo journalctl -b 0 | grep 'modeset'
sudo journalctl -b 0 | grep 'tainted'

The optirun command opens a GUI and the GPU is there.
Some of the other commands have some errors in there. See:

$ sudo journalctl -b 0 | grep 'acpi'
[sudo] password for german: 
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x01] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x02] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x03] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x04] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x05] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x06] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x07] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: ACPI: LAPIC_NMI (acpi_id[0x08] high edge lint[0x1])
sep 16 12:16:35 german-pc kernel: acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
sep 16 12:16:35 german-pc kernel: acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
sep 16 12:16:35 german-pc kernel: acpi PNP0A08:00: _OSC: OS now controls [PCIeHotplug PME AER PCIeCapability]
sep 16 12:16:35 german-pc kernel: acpi PNP0A08:00: FADT indicates ASPM is unsupported, using BIOS configuration
sep 16 12:16:35 german-pc kernel: acpi MSFT0101:00: platform device creation failed: -16
sep 16 12:16:35 german-pc kernel: clocksource: acpi_pm: mask: 0xffffff max_cycles: 0xffffff, max_idle_ns: 2085701024 ns
sep 16 12:16:37 german-pc kernel: Modules linked in: tpm_tis_core hp_accel(+) video lis3lv02d tpm input_polldev battery hp_wireless wmi button int3400_thermal led_class pcc_cpufreq acpi_thermal_rel acpi_pad ac sch_fq_codel ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 fscrypto hid_generic usbhid hid uas usb_storage sr_mod cdrom sd_mod rtsx_pci_sdmmc mmc_core serio_raw atkbd libps2 ahci libahci xhci_pci libata crc32c_intel xhci_hcd rtsx_pci scsi_mod usbcore usb_common i8042 serio
sep 16 12:16:37 german-pc kernel:  acpi_device_probe+0x48/0x110
sep 16 10:42:18 german-pc sudo[2846]:   german : TTY=pts/0 ; PWD=/home/german ; USER=root ; COMMAND=/usr/bin/pacman -Qs acpi_call
sep 16 10:49:47 german-pc bumblebeed[524]: [XORG] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)

$ sudo journalctl -b 0 | grep 'bbswitch'
sep 16 12:16:41 german-pc kernel: bbswitch: version 0.8
sep 16 12:16:41 german-pc kernel: bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
sep 16 12:16:41 german-pc kernel: bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
sep 16 12:16:41 german-pc kernel: bbswitch: detected an Optimus _DSM function
sep 16 12:16:41 german-pc kernel: bbswitch: disabling discrete graphics
sep 16 12:16:42 german-pc kernel: bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off
sep 16 10:42:32 german-pc sudo[2858]:   german : TTY=pts/0 ; PWD=/home/german ; USER=root ; COMMAND=/usr/bin/pacman -Qs bbswitch
sep 16 10:49:45 german-pc kernel: bbswitch: enabling discrete graphics

$ sudo journalctl -b 0 | grep 'nvidia'
sep 16 10:37:32 german-pc sudo[2673]:   german : TTY=pts/2 ; PWD=/home/german ; USER=root ; COMMAND=/usr/bin/nvidia-xconfig
sep 16 10:49:45 german-pc sudo[3006]:   german : TTY=pts/0 ; PWD=/home/german ; USER=root ; COMMAND=/usr/bin/optirun -b none nvidia-settings -c :8
sep 16 10:49:45 german-pc kernel: nvidia: module license 'NVIDIA' taints kernel.
sep 16 10:49:45 german-pc kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 240
sep 16 10:49:46 german-pc kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 16:16:14 PDT 2018

$ sudo journalctl -b 0 | grep 'modeset'
sep 16 10:49:46 german-pc kernel: nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 16:16:14 PDT 2018

$ sudo journalctl -b 0 | grep 'tainted'
sep 16 12:16:37 german-pc kernel: CPU: 5 PID: 294 Comm: systemd-udevd Not tainted 4.14.69-1-MANJARO #1

can you add

sudo pacman -S linux414-acpi_call

It asks me to install the package. Should I install it and try again?

yes , and also check option on boot ,
if Nvidia cards do not start with optirun

It didn't work. Still getting the black terminal screen :frowning:

give retur n

sudo journalctl -b0 | grep -i nvidia

grep -r blacklist /etc/modprobe.d/
grep -r blacklist /etc/modules-load.d/

sudo journalctl -b0 | grep -i nvidia outputs nothing.

$ grep -r blacklist /etc/modprobe.d/
/etc/modprobe.d/r8169_blacklist.conf:blacklist r8169
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nouveau
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-modeset
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-uvm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist ttm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm_kms_helper
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm
/etc/modprobe.d/nobeep.conf:blacklist pcspkr

grep -r blacklist /etc/modules-load.d/ outputs nothing either.

this topic can help you

reboot and check systemctl

optirun -b none nvidia-settings -c :8 
sudo systemctl status bumblebeed.service
sudo journalctl -b 0 | grep -i 'acpi'
sudo journalctl -b 0 | grep -i 'bbswitch'
sudo journalctl -b 0 | grep -i 'nvidia'
sudo journalctl -b 0 | grep -i 'modeset'
sudo journalctl -b 0 | grep -i 'tainted'

The blacklist was auto-generated by mhwd. When I install video-nvidia-390xx they are automatically removed (and get the black screen). They are there because I currently have video-hybrid-intel-nvidia-390xx, but the integrated GPU is running.

so reboot and check commands before

NO, config is FINE. Does not change it.

@germanfr share full dmesg.

dmesg > ~/dmesg

Paste it from home dir to pastebin.com

dmesg output: https://pastebin.com/sbiX6xfx

@stephane removing the blacklist items did nothing :frowning_face:

Follow this /etc/modprobe.d/mhwd-nvidia.conf

blacklist nouveau
blacklist nvidia
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist nvidia-drm
blacklist nvidiafb
blacklist rivafb
blacklist ttm
blacklist drm_kms_helper
blacklist drm

Remove ACPI_CALL package (kernel module). It is useless.

[   14.013664] acpi_call: Cannot get handle: Error: AE_NOT_FOUND
[   14.051895] acpi_call: Cannot get handle: Error: AE_NOT_FOUND

NVIDIA GPU should work out of box

[   10.811930] bbswitch: version 0.8
[   10.811934] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[   10.811938] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[   10.811947] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170728/nsarguments-100)
[   10.811992] bbswitch: detected an Optimus _DSM function
[   10.811998] pci 0000:01:00.0: enabling device (0006 -> 0007)
[   10.812103] bbswitch: disabling discrete graphics
[   10.853411] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off

Enable and start acpid daemon ONCE via command:

sudo pacman -S acpid --needed --noconfirm && \
sudo systemctl enable acpid; sudo systemctl start acpid

You have major issue driver:

[    6.214408] device returned spurious data
[    6.214417] ------------[ cut here ]------------
[    6.214423] WARNING: CPU: 5 PID: 283 at drivers/misc/lis3lv02d/lis3lv02d.c:239 lis3lv02d_get_pwron_wait.cold.8+0x13/0x1a [lis3lv02d]
[    6.214423] Modules linked in: fjes(-) fb_sys_fops hp_accel(+) lis3lv02d input_polldev idma64 tpm_crb led_class tpm_tis i2c_i801 processor_thermal_device mei_me video tpm_tis_core int340x_thermal_zone int3400_thermal intel_soc_dts_iosf intel_pch_thermal wmi hp_wireless acpi_thermal_rel shpchp mei tpm intel_lpss_pci intel_lpss battery button pcc_cpufreq acpi_pad ac sch_fq_codel acpi_call(O) ip_tables x_tables ext4 crc32c_generic crc16 mbcache jbd2 fscrypto hid_generic usbhid hid sr_mod cdrom sd_mod rtsx_pci_sdmmc mmc_core serio_raw atkbd libps2 ahci xhci_pci libahci xhci_hcd crc32c_intel libata rtsx_pci usbcore scsi_mod usb_common i8042 serio
[    6.214458] CPU: 5 PID: 283 Comm: systemd-udevd Tainted: G           O    4.14.69-1-MANJARO #1
[    6.214459] Hardware name: HP HP Pavilion Notebook/820F, BIOS F.25 12/12/2016
[    6.214460] task: ffff9a202f376900 task.stack: ffffb7644286c000
[    6.214463] RIP: 0010:lis3lv02d_get_pwron_wait.cold.8+0x13/0x1a [lis3lv02d]
[    6.214464] RSP: 0018:ffffb7644286fac8 EFLAGS: 00010246
[    6.214465] RAX: 000000000000001d RBX: 00000000fffffffa RCX: ffffffffbc0571c8
[    6.214466] RDX: 0000000000000000 RSI: 0000000000000096 RDI: 0000000000000283
[    6.214467] RBP: ffffffffc06b10c8 R08: 0000000000000008 R09: 00000000000002dc
[    6.214468] R10: ffff9a202cd4cc60 R11: 000000003161f9ae R12: 0000000000000000
[    6.214469] R13: ffff9a202f928800 R14: 0000000000000027 R15: ffffffffc06b1540
[    6.214471] FS:  00007f29c6a61d40(0000) GS:ffff9a203ed40000(0000) knlGS:0000000000000000
[    6.214472] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    6.214473] CR2: 00005581861dff80 CR3: 000000036f3a0001 CR4: 00000000003606e0
[    6.214474] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[    6.214475] DR3: 0000000000000000 DR6: 00000000fffe0ff0 DR7: 0000000000000400
[    6.214475] Call Trace:
[    6.214480]  lis3lv02d_poweron+0xc5/0x150 [lis3lv02d]
[    6.214483]  lis3lv02d_init_device.cold.9+0x230/0x974 [lis3lv02d]
[    6.214487]  lis3lv02d_add+0xe3/0x1ad [hp_accel]
[    6.214490]  acpi_device_probe+0x48/0x110
[    6.214493]  driver_probe_device+0x2c4/0x3f0
[    6.214495]  __driver_attach+0xb6/0xe0
[    6.214497]  ? driver_probe_device+0x3f0/0x3f0
[    6.214499]  bus_for_each_dev+0x7a/0xc0
[    6.214501]  bus_add_driver+0x152/0x230
[    6.214503]  driver_register+0x6b/0xb0
[    6.214505]  ? 0xffffffffc0489000
[    6.214507]  do_one_initcall+0x48/0x122
[    6.214510]  ? kmem_cache_alloc_trace+0xd4/0x1b0
[    6.214513]  do_init_module+0x5a/0x1f0
[    6.214516]  load_module+0x2098/0x2460
[    6.214519]  ? SYSC_init_module+0x131/0x180
[    6.214521]  SYSC_init_module+0x131/0x180
[    6.214524]  do_syscall_64+0x6e/0x100
[    6.214527]  entry_SYSCALL_64_after_hwframe+0x3d/0xa2
[    6.214528] RIP: 0033:0x7f29c9e8048e
[    6.214529] RSP: 002b:00007fffc81b40e8 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
[    6.214531] RAX: ffffffffffffffda RBX: 00005581860aefd0 RCX: 00007f29c9e8048e
[    6.214532] RDX: 00007f29c9917ecd RSI: 0000000000008538 RDI: 00005581861b9f70
[    6.214533] RBP: 00007f29c9917ecd R08: 0000000000000007 R09: 0000000000000006
[    6.214534] R10: 000055818607c010 R11: 0000000000000246 R12: 00005581861b9f70
[    6.214535] R13: 0000558186081830 R14: 0000000000020000 R15: 00005581860aefd0
[    6.214536] Code: 89 e2 48 8b 47 20 e8 9b c9 35 fb 85 c0 0f 88 1f 00 00 00 e9 56 00 00 00 48 c7 c7 d0 70 6a c0 c6 05 98 2c 00 00 01 e8 16 8b a3 fa <0f> 0b e9 ec eb ff ff c6 43 5a 00 31 f6 48 c7 c7 78 72 6a c0 41 
[    6.214567] ---[ end trace ca2106ec75c59f6f ]---

GRUB_CMDLINE_LINUX="acpi_osi=! acpi_osi="Windows 2009" acpi=force acpi_enforce_resources=lax"
Save changes In file. refresh grub:

sudo update-grub

Reboot

I am not sure if it is working now, because some things say GTX is running and others say Intel. What is the best reliable way to check?
Also, when you say it is supposed to work out f the box, you mean it should work with video-hybrid-nvidia-390xx-bumblebee? I am very confused.

4.14.69-MANJARO
Intel HD Graphics 530
GTX 960M

First:
install lastest stable kernel:

sudo mhwd-kernel -i linux418

Apply my recommended setup in GRUB. REBOOT. Boot from 4.18.x kernel.

Third check if works all fine:

optirun nvidia-smi
optirun glxinfo |grep Open
optirun glxgears

After running export new fresh dmesg results. No matter whats happen here. Just for sure. :slight_smile:

20180916125508-screenshot

Have you tried the "nomodeset" kernel parameter? Add it to /etc/default/grub like this

GRUB_CMDLINE_LINUX="nomodeset"

And update-grub after that.

For Intel GPU should be:

i915.modeset=0

:wink:

$ sudo optirun nvidia-smi
Sun Sep 16 19:35:17 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.87                 Driver Version: 390.87                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 960M    Off  | 00000000:01:00.0  On |                  N/A |
| N/A   34C    P0    N/A /  N/A |      8MiB /  2002MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1855      G   /usr/lib/Xorg                                  6MiB |
+-----------------------------------------------------------------------------+

$ sudo optirun glxinfo | grep Open
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.87
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.87
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

$ sudo optirun glxgears
314 frames in 5.0 seconds = 62.630 FPS
301 frames in 5.0 seconds = 60.012 FPS

dmesg: https://pastebin.com/SXCYx2Ad

Seems like it says things about the GTX, although the settings info gui still says my graphic card is intel blabla, so idk.

Forum kindly sponsored by