Black screen after installing video-nvidia-390xx

4.14.69-MANJARO
Intel HD Graphics 530
GTX 960M

First:
install lastest stable kernel:

sudo mhwd-kernel -i linux418

Apply my recommended setup in GRUB. REBOOT. Boot from 4.18.x kernel.

Third check if works all fine:

optirun nvidia-smi
optirun glxinfo |grep Open
optirun glxgears

After running export new fresh dmesg results. No matter whats happen here. Just for sure. :slight_smile:

20180916125508-screenshot

Have you tried the "nomodeset" kernel parameter? Add it to /etc/default/grub like this

GRUB_CMDLINE_LINUX="nomodeset"

And update-grub after that.

For Intel GPU should be:

i915.modeset=0

:wink:

$ sudo optirun nvidia-smi
Sun Sep 16 19:35:17 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 390.87                 Driver Version: 390.87                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 960M    Off  | 00000000:01:00.0  On |                  N/A |
| N/A   34C    P0    N/A /  N/A |      8MiB /  2002MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1855      G   /usr/lib/Xorg                                  6MiB |
+-----------------------------------------------------------------------------+

$ sudo optirun glxinfo | grep Open
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 960M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.87
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6.0 NVIDIA 390.87
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

$ sudo optirun glxgears
314 frames in 5.0 seconds = 62.630 FPS
301 frames in 5.0 seconds = 60.012 FPS

dmesg: https://pastebin.com/SXCYx2Ad

Seems like it says things about the GTX, although the settings info gui still says my graphic card is intel blabla, so idk.

Where I wrote about using SUDO?????? :man_facepalming:

IN DEFAULT Manjaro and Windoze too (!) using iGPU (INTEL GPU - part of CPU)
If you want using NVIDIA GPU U need call optirun command for this (or primusrun for some).

[  114.462820] bbswitch: disabling discrete graphics
[  114.480456] pci 0000:01:00.0: Refused to change power state, currently in D0
[  155.762309] bbswitch: enabling discrete graphics
[  155.945526] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  155.945802] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.87  Tue Aug 21 12:33:05 PDT 2018 (using threaded interrupts)
[  156.198722] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 16:16:14 PDT 2018
[  156.951759] nvidia-modeset: Unloading
[  156.965353] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  157.001754] bbswitch: disabling discrete graphics
[  157.020497] pci 0000:01:00.0: Refused to change power state, currently in D0
[  193.404728] bbswitch: enabling discrete graphics
[  193.566554] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  193.566944] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.87  Tue Aug 21 12:33:05 PDT 2018 (using threaded interrupts)
[  193.833232] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 16:16:14 PDT 2018
[  194.927691] nvidia-modeset: Unloading
[  194.947105] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  195.001831] bbswitch: disabling discrete graphics
[  195.020512] pci 0000:01:00.0: Refused to change power state, currently in D0
[  219.648393] bbswitch: enabling discrete graphics
[  219.831832] nvidia-nvlink: Nvlink Core is being initialized, major device number 237
[  219.832153] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  390.87  Tue Aug 21 12:33:05 PDT 2018 (using threaded interrupts)
[  220.096744] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  390.87  Tue Aug 21 16:16:14 PDT 2018
[  280.594983] nvidia-modeset: Unloading
[  280.627126] nvidia-nvlink: Unregistered the Nvlink Core, major device number 237
[  280.709487] bbswitch: disabling discrete graphics
[  280.727150] pci 0000:01:00.0: Refused to change power state, currently in D0

it is FINE.

For future:

RUN optirun and primusrun WITHOUT sudo.

This is what I got when I run it without sudo:

$ optirun nvidia-smi
[ 3921.924122] [ERROR]You've no permission to communicate with the Bumblebee daemon. Try adding yourself to the 'bumblebee' group
[ 3921.924193] [ERROR]Could not connect to bumblebee daemon - is it running?

Does that mean that the desktop environment (and any program in general) is not using the Nvidia GPU if I don't run it with optirun?

simplement

sudo gpasswd -a *user* bumblebee
groups ( for check )

there is always errors on last dmesg

[    6.214459] Hardware name: HP HP Pavilion Notebook/820F, BIOS F.25 12/12/2016
[    6.214460] task: ffff9a202f376900 task.stack: ffffb7644286c000
[    6.214463] RIP: 0010:lis3lv02d_get_pwron_wait.cold.8+0x13/0x1a [lis3lv02d]
...
[    8.462924] thermal thermal_zone4: failed to read out thermal zone (-61)
...

maybe after upgrade bios version

1 Like

Hey, thank you for the tip. But unfortunately it doesn't work. I added myself to the bumblebee group but I still get the same message. I can't run programs with optirun without sudo :(
EDIT: It works after a reboot. A log-out wasn't enough. Thank you very much everyone that helped! :blush:

@FadeMind

2 questions

  1. when mhwd install intel-nvidia-bumblebee ,
    why there is no add for acpid ?
  2. any skylake version appears in 2015 and after , with start of windows 10
    why use "acpi_osi=! acpi_osi=“Windows 2009” , it should be
    "acpi_osi=! acpi_osi=“Windows 2015”

"acpi_osi=! acpi_osi=“Windows 2009” ( windows 7 )
"acpi_osi=! acpi_osi=“Windows 2013” ( windows 8 )
"acpi_osi=! acpi_osi=“Windows 2015” ( windows 10 )

1 Like
  1. Acpid is not crucial, so it seems the user have to enable it. The devs may have more to say.
  2. If there was a whitepaper to clarify when we should use each of them I would appreciate to know.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by