Black screen at boot, no TTY

I switched from Ubuntu to Manjaro at the beginning of March. One of the problems that has happened since I changed distro is that, sometimes, seemingly randomly, Manjaro simply fails to boot.

The Laptop is a MSi GF63 8RC, no dual boot, just manjaro.

I turn the pc on and, 1 out of 5 times, I end up at a black screen.
System is completely unresponsive, I get no tty if I use CTRL-ALT-number, I don't get anything interesting with CTRL-ALT-DEL, clicking the power button, or any other input I could think of. I can only force a shutdown by pressing the power button for a couple seconds.

Sometimes I get unlucky and I have to try 2 or 3 times, but I can always press F8 early on and get the menu with the advanced options before the complete lockdown, if I act quickly enough.

My first try was to try with refind instead of grub, but I got the same result: I get to the boot menu, whichever I used at the moment, and it fails later down the boot process.

Some extra data:

  • I have extra boot options to fix another issue I had since I bought this laptop: pci=noaer and intel_iommu=igfx_off(removing them doesn't fix anything, I tried already)
  • The video driver config I'm using is video-hybrid-intel-nvidia-435xx-prime, but I got the same result with 440xx.
  • The kernels I tried are 5.4.31-1, 5.5.16-1 and the one I'm currently using, 5.6.3-2, no change in behaviour here.

I also have a few journalctl logs:
Failed boot
Successful boot for reference

I also have versions without timestamps for ease of diff, but I'm limited to 2 links per post.

$ inxi -Fxzc0

System:    Host: simone-pc Kernel: 5.6.3-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: KDE Plasma 5.18.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Micro-Star product: GF63 8RC v: REV:1.0 serial: <filter> 
           Mobo: Micro-Star model: MS-16R1 v: REV:1.0 serial: <filter> UEFI: American Megatrends v: E16R1IMS.10C 
           date: 05/22/2019 
Battery:   ID-1: BAT1 charge: 43.7 Wh condition: 47.8/51.3 Wh (93%) model: MSI Corp. MS-16R1 status: Unknown 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 52815 
           Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 901 3: 900 4: 901 5: 901 6: 901 7: 900 8: 900 
           9: 900 10: 900 11: 900 12: 900 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Micro-Star MSI driver: nvidia v: 435.21 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia tty: N/A 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.4 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k5.6.3-2-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Qualcomm Atheros QCA8171 Gigabit Ethernet vendor: Micro-Star MSI driver: alx v: kernel port: 3000 
           bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
           IF-ID-2: virbr0-nic state: down mac: <filter> 
Drives:    Local Storage: total: 1.03 TiB used: 190.94 GiB (18.2%) 
           ID-1: /dev/sda vendor: Kingston model: RBUSNS8180S3128GJ size: 119.24 GiB 
           ID-2: /dev/sdb vendor: Western Digital model: WD10SPZX-17Z10T1 size: 931.51 GiB 
Partition: ID-1: / size: 85.08 GiB used: 28.90 GiB (34.0%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 915.89 GiB used: 162.03 GiB (17.7%) fs: ext4 dev: /dev/sdb1 
           ID-3: swap-1 size: 32.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 44.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 286 Uptime: 35m Memory: 15.48 GiB used: 2.40 GiB (15.5%) Init: systemd Compilers: gcc: 9.3.0 Shell: zsh 
           v: 5.8 inxi: 3.0.37

I would recommend you to limit the jounald logfiles by editing the corresponding conf file (instead of nano you could certainly also use another editor):

nano /etc/systemd/journald.conf

Make sure the following two lines are set exactly as shown here (without starting #), otherwise change it and safe the file:

SystemMaxUse=250M
SystemMaxFileSize=50M

In your system there is a folder named

/var/log/journal

Inside of this folder you find another folder with a long crytical number which is different from system to system. Inside of this folder with the long crypical number remove all files which are older than 2 days and finally reboot.

Is it like a known issue with journal size that blocks boot or is this a good-practice/off-topic advice? Thanks anyways, I've done it.

1 Like

I just saw in your logs that they got too large (4GiB), so that's why. It's definitely worth trying. The settings I gave you are pretty standard advice, anyway.

1 Like

Anyone has any idea about this problem? I'm getting kinda desperate

hi, Try this:

  1. boot live CD/old kernel which works
  2. manjaro-chroot -a
  3. in chroot: pacman -S linux-firmware && update-grub && shutdown -rf now

Firmwares have updated lately.

I had the same problem

I can boot into my system 4 out of 5 times. It's up to date already

I decided to remove the quiet boot option and see what the log came up with. I'm not sure where this log is stored (if at all), so all I've got is this picture I got from my phone. Any help is really appreciated.
dmesg_faulty
Obviously this picture shows one of those hangs. Hard reset is the only way I can continue.
The iwlwifi warnings are normal, the two lines that stood out for me were:

Bluetooth: hci0: Failed to send firmware data (-38)

and

nvidia 0000:01:00.0: can't change power state from D3cold to D0 (config space inaccessible)

Update in case someone finds this in the future: I seem to have solved the issue by setting the pcie_aspm=off boot option (power management stuff). It also fixed the dGPU not wanting to load a GL context at random. I'm not sure if this will have consequences on power usage or not, I'll test for a few days and mark this as solved in that case.

Edit: nope, both problems persist

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by