Black screen on boot after grub on fresh install

Try manjaro-chroot or mhwd-chroot from live usb (search in forum).
Post output
inxi -Fxxxz

  Host: manjaro Kernel: 4.19.23-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN tk: Gtk 3.24.3 info: xfce4-panel 
  wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux 
  Type: Desktop System: Dell product: Precision T1500 v: 00 serial: <filter> 
  Chassis: type: 3 serial: <filter> 
  Mobo: Dell model: 0XC7MM v: A01 serial: <filter> BIOS: Dell v: 2.2.0 
  date: 07/06/2010 
  Topology: Quad Core model: Intel Core i7 870 bits: 64 type: MT MCP 
  arch: Nehalem rev: 5 L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 46827 
  Speed: 1197 MHz min/max: 1200/2934 MHz boost: enabled Core speeds (MHz): 
  1: 1197 2: 1197 3: 1197 4: 1197 5: 1197 6: 1197 7: 1197 8: 1197 
  Device-1: AMD Oland PRO [Radeon R7 240/340] vendor: PC Partner Limited 
  driver: radeon v: kernel bus ID: 01:00.0 chip ID: 1002:6613 
  Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: modesetting 
  alternate: fbdev,vesa resolution: 1680x1050~60Hz 
  OpenGL: renderer: AMD OLAND (DRM 2.50.0 4.19.23-1-MANJARO LLVM 7.0.1) 
  v: 4.5 Mesa 18.3.3 direct render: Yes 
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:3b56 
  Device-2: AMD Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series] 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aab0 
  Device-3: C-Media CM106 Like Sound Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 2-1.6:5 
  chip ID: 0d8c:0102 
  Sound Server: ALSA v: k4.19.23-1-MANJARO 
  Device-1: Broadcom and subsidiaries NetLink BCM57780 Gigabit Ethernet PCIe 
  vendor: Dell driver: tg3 v: 3.137 port: e000 bus ID: 02:00.0 
  chip ID: 14e4:1692 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.85 TiB used: 75.8 MiB (0.0%) 
  ID-1: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB 
  speed: 3.0 Gb/s serial: <filter> rev: BBF1 scheme: MBR 
  ID-2: /dev/sdb vendor: Western Digital model: WD10EARS-00Y5B1 
  size: 931.51 GiB speed: 3.0 Gb/s serial: <filter> rev: 0A80 scheme: MBR 
  ID-3: /dev/sdc vendor: Hitachi model: HDS723020BLA642 size: 1.82 TiB 
  speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: A5Q0 scheme: MBR 
  ID-4: /dev/sdd type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 14.44 GiB serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / size: 11.72 GiB used: 75.8 MiB (0.6%) fs: overlay source: ERR-102 
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: radeon temp: 35 C 
  Fan Speeds (RPM): cpu: 1504 mobo: 1172 
  Processes: 216 Uptime: 2m Memory: 15.62 GiB used: 1.12 GiB (7.2%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: xfce4-terminal inxi: 3.0.30 

If i understand correctly, manjaro-chroot is for fixing grub. I think grub is fine since i can boot into other linux distros on my hdd. Same thing happens if i reinstall grub from other distro - boot into other distros works fine, but manjaro stuck on starting jobs.

Anyway, attempting to chroot getting

[manjaro manjaro]# mount /dev/sdb3 /mnt
mount: /mnt: unknown filesystem type 'ext4'.

and mhwd-chroot ends with

No Linux system found !

Please post info

inxi -puo
1 Like

With this you can also install missing drivers, an update or finish OS install but petsam has a lot more knowledge than me. :slight_smile:

inxi -puo
  ID-1: / size: 11.72 GiB used: 69.6 MiB (0.6%) fs: overlay source: ERR-102 
  uuid: N/A 
  ID-2: /run/miso/bootmnt raw size: 1.91 GiB size: <root required> 
  used: <root required> fs: iso9660 dev: /dev/sdd1 
  uuid: 2019-02-19-12-49-03-00 
  ID-3: /run/miso/sfs/desktopfs raw size: 1.04 GiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop2 uuid: N/A 
  ID-4: /run/miso/sfs/livefs raw size: 76.5 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop0 uuid: N/A 
  ID-5: /run/miso/sfs/mhwdfs raw size: 276.4 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop1 uuid: N/A 
  ID-6: /run/miso/sfs/rootfs raw size: 475.4 MiB size: <root required> 
  used: <root required> fs: squashfs dev: /dev/loop3 uuid: N/A 
  ID-1: /dev/sda1 size: 60.00 GiB fs: ntfs label: w10 uuid: CE4E7B084E7AE91B 
  ID-2: /dev/sda2 size: 30.00 GiB fs: ext4 label: mint 
  uuid: 4d4ab997-c96f-4fef-8c96-92cb9e97b133 
  ID-3: /dev/sda3 size: 10.00 GiB fs: ext4 label: serbian 
  uuid: 1c33aff6-9f2c-487b-94d4-c622698e08f4 
  ID-4: /dev/sda4 size: 1 KiB fs: <root required> label: N/A uuid: N/A 
  ID-5: /dev/sda5 size: 10.00 GiB fs: ext4 label: elementary 
  uuid: c2d310b8-15d1-46aa-aa96-e45cfea85483 
  ID-6: /dev/sda6 size: 1.79 GiB fs: swap label: N/A 
  uuid: 454cf4a6-a0c9-414c-91ea-1c3c810b6f08 
  ID-7: /dev/sdb1 size: 50.00 GiB fs: ntfs label: w7 uuid: CE7612AF76129873 
  ID-8: /dev/sdb10 size: 30.00 GiB fs: ext4 label: sdb10 
  uuid: 45ce2284-acca-46d3-b729-fb8d0009fdfd 
  ID-9: /dev/sdb11 size: 700.00 GiB fs: ntfs label: wd 
  uuid: 7234121A1B5C0515 
  ID-10: /dev/sdb2 size: 25.00 GiB fs: ext4 label: fedora 
  uuid: ed22565e-1ee7-4b5a-913b-411428747907 
  ID-11: /dev/sdb3 size: 25.00 GiB fs: ext4 label: N/A 
  uuid: 109537a0-de35-48f3-86db-acf332988150 
  ID-12: /dev/sdb4 size: 1 KiB fs: <root required> label: N/A uuid: N/A 
  ID-13: /dev/sdb5 size: 1.51 GiB fs: swap label: N/A 
  uuid: 84ae3fbc-a040-4233-8d9b-c70146f8d90b 
  ID-14: /dev/sdb6 size: 25.00 GiB fs: ext4 label: solus 
  uuid: dd0ed7db-4387-442a-a6af-ae1cb81f8b58 
  ID-15: /dev/sdb7 size: 25.00 GiB fs: ext4 label: sdb7 
  uuid: c587e87a-830c-47aa-8831-66e999bfd2aa 
  ID-16: /dev/sdb8 size: 25.00 GiB fs: ext4 label: sdb8 
  uuid: 576e0939-2c7f-44cc-aac4-887c131eefe3 
  ID-17: /dev/sdb9 size: 25.00 GiB fs: ext4 label: sdb9 
  uuid: e934ebb6-9d19-41b7-ba9e-c3881a95e88f 
  ID-18: /dev/sdc1 size: 10.00 GiB fs: ntfs label: xp uuid: 38208A61208A264A 
  ID-19: /dev/sdc2 size: 20.00 GiB fs: ext4 label: ubnt 
  uuid: 159cdb69-4290-435f-bf7f-afb9d08b9723 
  ID-20: /dev/sdc3 size: 15.00 GiB fs: ext4 label: kali 
  uuid: 2d6d59e8-9d8f-4eda-a23e-0201977dcf3a 
  ID-21: /dev/sdc4 size: 1 KiB fs: <root required> label: N/A uuid: N/A 
  ID-22: /dev/sdc5 size: 20.00 GiB fs: ext4 label: serb 
  uuid: 59240e1d-4df2-44e0-8c30-bea6b6bd7701 
  ID-23: /dev/sdc6 size: 20.00 GiB fs: ext4 label: linux 
  uuid: e8b898c3-20fa-42e5-ace0-3192c3099680 
  ID-24: /dev/sdc7 size: 4.01 GiB fs: swap label: N/A 
  uuid: e140a78c-c7b3-4fa0-bd91-a0d00731509e 
  ID-25: /dev/sdc8 size: 750.00 GiB fs: ntfs label: hitachi 
  uuid: 6864AAC47EFA0462 
  ID-26: /dev/sdc9 size: 1024.00 GiB fs: ntfs label: 1T 
  uuid: 29BF50452249AB8D 
  ID-27: /dev/sdd2 size: 4.0 MiB fs: vfat label: MISO_EFI uuid: 9CC5-4605 

That ext4 problem was after i did a pacman update on live session which was needed for installing mhwd-chroot. I did managed to chroot without pacman updating in live session, and then pacman updated in chrooted system, but update-grub froze during

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img

so i had to reboot. Booting after that went further than previously (again with nomodeset), but stucked on starting different jobs than last time.

I just tried to update in chrooted system on fresh install budgie version, same as before

:: Running post-transaction hooks...
( 1/28) Updating linux419 module dependencies...
( 2/28) Updating linux419 initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.24-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
cannot open file sr-latin
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback'
  -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> Starting build: 4.19.24-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
cannot open file sr-latin
  -> Running build hook: [resume]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
( 3/28) Updating Grub-Bootmenu
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img

Sorry, my mistake, it wasnt frozen, it just took a long time to finish, about half an hour. It finished updating, but on the next boot (again with nomodeset), same black screen displaying “A start job is running for Light Display Manager” alternately with “A start job is running for TLP system startup/shutdown” now with another one "A start job is running for Clean up modules from old kernels" on top row.

Do you use Manjaro grub on MBR? I mean if you installed grub on your drive or using a GRUB from another installed Linux.

Since you use MSDOS/MBR disks, I suggest you have each drive with different GRUB, for example have installed grub from Mint on /dev/sda and grub from Manjaro on /dev/sdb. This way you can choose from BIOS (quick/main) menu to boot to each on subsequent boots.

  • Boot to Manjaro TTY using any grub using the "Advanced/fallback" entry, editing menu (add 3 at the end of the linux line).
  • In TTY, login and do again update packages, update kernel images
sudo pacman -Syu
sudo mkinitcpio -P
  • Check your actual partitions names (important) with
lsblk -f

and install grub on your drive containing Manjaro (for example if /dev/sdb

sudo grub-install /dev/sdb
  • Boot to that drive (select from BIOS) to Manjaro, to main/first option

If after the above, you get errors on black screen, go to TTY (Ctrl+Alt+F3 and troubleshoot for possible graphics drivers issues as this tutorial and post errors and relevant info

For bootloader issues, read this tutorial for help

1 Like

I do use Manjaro grub on sdb disk, i set it up that way from the start. Disks sda and sdc have other grubs. Adding 3 on the end of linux boot line on fallback entry gets me nowhere, even with nomodeset, completely black screen, cant get into TTY.

lsblk -f
NAME    FSTYPE   LABEL      UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0   squashfs                                                       0   100% /run/miso/sfs/livefs
loop1   squashfs                                                       0   100% /run/miso/sfs/mhwdfs
loop2   squashfs                                                       0   100% /run/miso/sfs/desktopfs
loop3   squashfs                                                       0   100% /run/miso/sfs/rootfs
├─sda1  ntfs     w10        CE4E7B084E7AE91B                                    
├─sda2  ext4     mint       4d4ab997-c96f-4fef-8c96-92cb9e97b133                
├─sda3  ext4     serbian    1c33aff6-9f2c-487b-94d4-c622698e08f4                
├─sda5  ext4     elementary c2d310b8-15d1-46aa-aa96-e45cfea85483                
└─sda6  swap                454cf4a6-a0c9-414c-91ea-1c3c810b6f08                
├─sdb1  ntfs     w7         CE7612AF76129873                                    
├─sdb2  ext4     fedora     ed22565e-1ee7-4b5a-913b-411428747907                
├─sdb3  ext4                3b874a87-1a89-4db8-86c6-3fca86bdd3f4                
├─sdb5  swap                84ae3fbc-a040-4233-8d9b-c70146f8d90b                
├─sdb6  ext4     solus      dd0ed7db-4387-442a-a6af-ae1cb81f8b58                
├─sdb7  ext4     sdb7       c587e87a-830c-47aa-8831-66e999bfd2aa                
├─sdb8  ext4     sdb8       576e0939-2c7f-44cc-aac4-887c131eefe3                
├─sdb9  ext4     sdb9       e934ebb6-9d19-41b7-ba9e-c3881a95e88f                
├─sdb10 ext4     sdb10      45ce2284-acca-46d3-b729-fb8d0009fdfd                
└─sdb11 ntfs     wd         7234121A1B5C0515                                    
├─sdc1  ntfs     xp         38208A61208A264A                                    
├─sdc2  ext4     ubnt       159cdb69-4290-435f-bf7f-afb9d08b9723                
├─sdc3  ext4     kali       2d6d59e8-9d8f-4eda-a23e-0201977dcf3a                
├─sdc5  ext4     serb       59240e1d-4df2-44e0-8c30-bea6b6bd7701                
├─sdc6  ext4     linux      e8b898c3-20fa-42e5-ace0-3192c3099680                
├─sdc7  swap                e140a78c-c7b3-4fa0-bd91-a0d00731509e                
├─sdc8  ntfs     hitachi    6864AAC47EFA0462                                    
└─sdc9  ntfs     1T         29BF50452249AB8D                                    
sdd     iso9660  MJRO1801   2018-12-22-23-56-31-00                              
├─sdd1  iso9660  MJRO1801   2018-12-22-23-56-31-00                     0   100% /run/miso/bootmnt
└─sdd2  vfat     MISO_EFI   AA2D-678B                                           

Instead of 3 use
It is unusual that you cannot get to TTY this way. Which GRUB are you using? Which drive, which distro installed it, was the installation done with --recheck?

1 Like

Ill try that now. Grub was instaled on sdb (Manjaro is on sdb3) using Manjaro budgie on USB, and it was done with -- recheck

EDIT: (again only with nomodeset) gets me to same starting jobs cycle. Ctrl+Alt+F3 display something like starting Getty on tty3 and ends with blinking cursor in top left corner. I can type, but there is no prompt and no response on enter.

Try another TTY, like Ctrl+Alt+F4.

If it still doesn't give, reboot to Live installer and get your "dead" Manjaro log after mounting the root partition (for example of mount point /mnt/myinst):

journalctl -D /mnt/myinst/var/log/journal -xe

If you can do it, post on a web pastebin service and share the link.

1 Like

Work out with petsam first, then if you have a break or a pause, try the following. Good night.

From any grub (livecd, mint, elementary, fedora, solus, ubuntu, kali), go to grub prompt 'grub>' (press 'c').

grub> search.file /etc/manjaro-release

Any output? Do you have 2 output? (budgie and xfce)
If yes, choose the correct one you want to fix with the next command by selecting the right root.

grub> set root=(hdx,y)
grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw 3
grub> initrd /boot/initramfs-4.19-x86_64-fallback.img
grub> boot

If booted to prompt, at terminal,

sudo pacman-mirrors -f5
sudo pacman -Syyuu
sudo mkinitcpio -P


findmnt /

If output gives sdax, do 'sudo grub-install /dev/sda'
If output gives sdbx, do 'sudo grub-install /dev/sdb'
If output gives sdcx, do 'sudo grub-install /dev/sdc'
If output gives sddx, do 'sudo grub-install /dev/sdd'

And then do 'sudo update-grub'

Of course, since you want to do it your way where you have each grub set to its own drive, when you want to boot Manjaro, choose the right device at bios to boot up.

ps: I won't do it your way and have each grub to each 'mbr', but it's okay. As long as you boot up the right drive at the bios and know which drive has which grub. And don't mind going to bios each time to boot. Also check that your grub.cfg for every grub has uuid's instead of /dev/sdxy



I didnt had to go to bios with debain based distros, every grub on every drive could boot into all of the listed distros no matter which drive it is located. I went to bios and other grub only when needed to fix grub or something like that. For regular use bios could boot either one of drives and from grub i could boot into any distro, (linux or win). Manjaro is the first distro that wont comply :slight_smile: To be honest, i never tried any arch based distro before.

It's late here, but I think you're wrong.
I won't explain now (late here) but you must use Manjaro's grub to boot Manjaro.
Other OS grub will not boot Manjaro.
This is important. Actually, I don't wish to explain, not because I'm rude or lazy but I'm jaded.
Not your fault and I apologize for not explaining. If others care to, go ahead.

And... Cheers!

1 Like

Then we have a language problem..

If you always booted from another non-Manjaro grub/drive, then just select sdb (choose the correct name) from BIOS quick boot.

The journal had nothing..


And don't use nomodset on booting, until you know you need it.

gave some console output like in booting system, but ended with blinking cursor, nonresponsive to Ctrl+Alt+F3

I see that. I worked on Debian based distros so far and had no problem booting like i described.

No, Im always booting from manjaro grub on manjaro drive. I tried few times with another grubs, but without success.

Without nomodeset its only black screen, only with nomodeset i get some output

Check your fstab. Uncomment out unnecessary stuff like ntfs drives, recheck uuid's for swap, etc.
even for root. Provide fstab and blkid if unsure (but I think you know). If corrected, try again with the grub from prompt (not from grub.cfg). And since you have many drives, make sure fstab is only uuid's not device mapping (/dev/sdxy).

But if you are certain, reinstall.
{But you have tried with 2 installs? xfce and budgie?}.

Okay, see (talk) you tomorrow. Good luck.

One pretty noob question: how is it determined which drive is hd1,2,3?

In grub prompt

gives me hd0,msdos3 as manjaro destination, but in manjaro /boot/grub/grub.cfg hd1,msdos3 is set as root.
My primary drive is SSD and its sda in every distro. Manjaro drive is sdb and im booting that drive from bios during all this time while trying to boot manjaro

The bios determines it. And that changes with every boot. Usually the primary drive remains as sda, the drive with the primary sata0 or ide drive with master jumpers. The rest changes. Grub takes what the bios tells it.

When booted, most OS will consider that OS to be in sda; again not always, just mostly.
But to be sure, check with 'findmnt /' and careful when doing grub-install. Is that to /dev/sda? or /dev/sdb or....

There is a line in grub 'root=(hdx,y)' but if proceeded by a search line in uuid, that's okay because the second line takes over. Precisely why your fstab and grub search line must be UUID's, never /dev/sdxy.

Most people think having multiple disks for multiple OS's is better. It is not.

1 Like

You have not made a case until now, so keep complaining..:stuck_out_tongue_winking_eye:
Proper usage is always a requirement with every methodology.
Human error is the most probable, even on this case..
Misunderstanding and misconception.. :man_shrugging:

On topic:

This is a sign of a possibility that you installed grub from another installation, or using another installation's grub. You insist that you select correctly your sequence of commands, but since you still have something in question on booting from BIOS and GRUBs..

It could be the weather to blame.. :smile:

1 Like

Forum kindly sponsored by