Black screen with blinking cursor before grub

I am quite new to linux and I set up a dual-boot with Manjaro KDE Plasma and Windows 10 few days ago.
The first days, everything worked fine, but now I get a black screen with blinking cursor when booting.
Pressing Shift while booting just adds a GRUB to the blinking cursor, so I am not able to get into the grub menu.

I have 2 disks: a SSD with Windows 10 and a HDD with Manjaro and grub.
I can still boot Windows if I boot the SSD.

Any ideas on what I can try to fix grub?

:+1: Welcome to Manjaro! :+1:

That means you've separated the boot between the 2 OSes in the UEFI firmware (aka "BIOS") so boot a Manjaro USB and then read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you're using, which CPU/GPU you have, ...

Kind of, I still could choose between both using grub.

Okay here we go:

sh-5.0# inxi -Fxxxza --no-host
12System:    12Kernel 5.4.23-1-MANJARO x86_64 12bits 64 12compiler gcc 12v 9.2.1 
           12parameters BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC driver=free 
           nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 misobasedir=manjaro 
           misolabel=MANJARO_KDEM_1902 quiet systemd.show_status=1 apparmor=1 security=apparmor 
           12Console N/A 12dm N/A 12Distro Manjaro Linux 
12Machine:   12Type Laptop 12System LENOVO 12product 80TV 12v Lenovo ideapad 310-15IKB 12serial <filter> 
           12Chassis 12type 10 12v Lenovo ideapad 310-15IKB 12serial <filter> 
           12Mobo LENOVO 12model Torronto 5C2 12v SDK0J40709 WIN 12serial <filter> 12UEFI [Legacy] LENOVO 
           12v 3JCN19WW 12date 08/10/2016 
12Battery:   12ID-1 BAT0 12charge 20.6 Wh 12condition 20.9/28.5 Wh (73%) 12volts 8.1/7.3 
           12model SANYO L15S2TB0 12type Li-poly 12serial <filter> 12status Unknown 
12CPU:       12Topology Dual Core 12model Intel Core i5-7200U 12bits 64 12type MT MCP 12arch Amber Lake 
           12family 6 12model-id 8E (142) 12stepping 9 12microcode CA 12L1 cache 128 KiB 12L2 cache 3072 KiB 
           12L3 cache 3072 KiB 
           12flags avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 12bogomips 21607 
           12Speed 606 MHz 12min/max 400/3100 MHz 12Core speeds (MHz) 121 600 122 600 123 600 124 601 
           12Vulnerabilities 12Type itlb_multihit 12status KVM: Split huge pages 
           12Type l1tf 12mitigation PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           12Type mds 12mitigation Clear CPU buffers; SMT vulnerable 
           12Type meltdown 12mitigation PTI 
           12Type spec_store_bypass 
           12mitigation Speculative Store Bypass disabled via prctl and seccomp 
           12Type spectre_v1 12mitigation usercopy/swapgs barriers and __user pointer sanitization 
           12Type spectre_v2 12mitigation Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           12Type tsx_async_abort 12status Not affected 
12Graphics:  12Device-1 Intel HD Graphics 620 12vendor Lenovo 12driver i915 12v kernel 12bus ID 00:02.0 
           12chip ID 8086:5916 
           12Display 12server X.org 1.20.8 12driver intel 12unloaded modesetting 12alternate fbdev,vesa 
           12tty N/A 
           12Message Advanced graphics data unavailable for root. 
12Audio:     12Device-1 Intel Sunrise Point-LP HD Audio 12vendor Lenovo 12driver snd_hda_intel 12v kernel 
           12bus ID 00:1f.3 12chip ID 8086:9d71 
           12Sound Server ALSA 12v k5.4.23-1-MANJARO 
12Network:   12Device-1 Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 12vendor Lenovo 
           12driver r8169 12v kernel 12port 3000 12bus ID 01:00.0 12chip ID 10ec:8168 
           12IF enp1s0 12state down 12mac <filter> 
           12Device-2 Intel Dual Band Wireless-AC 3165 Plus Bluetooth 12driver iwlwifi 12v kernel 
           12port 3000 12bus ID 02:00.0 12chip ID 8086:3166 
           12IF wlp2s0 12state up 12mac <filter> 
12Drives:    12Local Storage 12total 1.06 TiB 12used 12.15 GiB (1.1%) 
           12ID-1 /dev/sda 12vendor Samsung 12model MZYTY128HDHP-000L2 12size 119.24 GiB 12block size 
           12physical 512 B 12logical 512 B 12speed 6.0 Gb/s 12serial <filter> 12rev 1L1Q 
           12ID-2 /dev/sdb 12vendor Toshiba 12model MQ02ABF100 12size 931.51 GiB 12block size 
           12physical 4096 B 12logical 512 B 12speed 6.0 Gb/s 12serial <filter> 12rev 1E 
           12ID-3 /dev/sdc 12type USB 12vendor Intenso 12model Ultra Line 12size 29.82 GiB 12block size 
           12physical 512 B 12logical 512 B 12serial <filter> 12rev 1100 
12Partition: 12ID-1 / 12raw size 40.00 GiB 12size 39.12 GiB (97.81%) 12used 12.10 GiB (30.9%) 12fs ext4 
           12block size 4096 B 12dev /dev/sdb5 
           12ID-2 /boot 12raw size 512.0 MiB 12size 511.0 MiB (99.80%) 12used 54.3 MiB (10.6%) 12fs vfat 
           12block size 512 B 12dev /dev/sdb3 
12Sensors:   12System Temperatures 12cpu 49.0 C 12mobo N/A 
           12Fan Speeds (RPM) N/A 
12Info:      12Processes 5 12Uptime 4h 53m 12Memory 7.68 GiB 12used 1.84 GiB (24.0%) 12Init N/A 12v N/A 
           12Compilers 12gcc 9.3.0 12Client shell wrapper 12v 5.0.16-release 12inxi 3.0.37 

The screen during boot is mainly looking like this.
I can not enter anything.

Cursor-Blinking-Screen

I have \home mounted on an encrypted partition.
Here some information on my partions:

lsblk -f
NAME   FSTYPE      FSVER            LABEL     FSAVAIL FSUSE% MOUNTPOINT
loop0  squashfs    4.0                                                                           0   100% /run/miso/sfs/livefs
loop1  squashfs    4.0                                                                           0   100% /run/miso/sfs/mhwdfs
loop2  squashfs    4.0                                                                           0   100% /run/miso/sfs/desktopfs
loop3  squashfs    4.0                                                                           0   100% /run/miso/sfs/rootfs
sda                                                                                                       
├─sda1 ntfs                         System-reserviert                                     
├─sda2 ntfs                         Windows                                               
└─sda3 ntfs                                                                               
sdb                                                                                                       
├─sdb1                                                                                                    
├─sdb2 ntfs                         Data                                                  
├─sdb3 vfat        FAT32                                                           456.7M    11% /mnt/mnt/boot
├─sdb4 swap        1                                                  
├─sdb5 ext4        1.0                                   25.1G    31% /mnt/mnt
└─sdb6 crypto_LUKS 1                                                  
sdc    iso9660     Joliet Extension MANJARO_KDEM_1902                     0   100% /run/miso/bootmnt
├─sdc1 iso9660     Joliet Extension MANJARO_KDEM_1902                              
└─sdc2 vfat        FAT12            MISO_EFI          33D6-2BC4    

journalctl delivers the following:

journalctl -p3 -b -1
-- Logs begin at Sun 2020-04-26 13:40:46 CEST, end at Thu 2020-04-30 16:15:01 CEST. --
Apr 29 12:47:06 lenovo-lap kernel: platform MSFT0101:00: failed to claim resource 1: [mem 0xfed40000-0xfed40fff]
Apr 29 12:47:06 lenovo-lap kernel: acpi MSFT0101:00: platform device creation failed: -16
Apr 29 12:47:11 lenovo-lap systemd-cryptsetup[457]: Failed to open key file.
Apr 29 12:47:11 lenovo-lap systemd-cryptsetup[457]: Failed to activate with key file '/crypto_keyfile.bin'. (Key file missing?)
Apr 29 12:47:15 lenovo-lap kernel: Bluetooth: hci0: unexpected event for opcode 0xfc2f
Apr 29 10:48:33 lenovo-lap bluetoothd[753]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Apr 29 10:48:33 lenovo-lap bluetoothd[753]: RFCOMM server failed for :1.130/Profile/HSPHS/00001108-0000-1000-8000-00805F9B34FB: rfcomm_bind: Address already in use (98)
Apr 29 11:47:00 lenovo-lap kernel: iwlwifi 0000:02:00.0: No beacon heard and the time event is over already...
Apr 29 12:01:22 lenovo-lap systemd-cryptsetup[4041]: Device luks-6dd298e8-40f8-4042-9c7a-e3d6071e7608 is still in use.
Apr 29 12:01:22 lenovo-lap systemd-cryptsetup[4041]: Failed to deactivate: Device or resource busy
Apr 29 12:01:22 lenovo-lap kernel: watchdog: watchdog0: watchdog did not stop!

It looks like you've installed Windows in BIOS mode (7?) and Manjaro in UEFI mode.

  • If that's correct, did you change anything in the UEFI firmware between Day 0 and Day 1

What are you trying to accomplish at this point as you've only been running the system for 1 day? Do you have data that you need recovering or can you wipe Manjaro?

What authentication type did you choose to decrypt the partition?

Why is '12' plastered over the inxi output?

That's output from the USB boot as he can't boot his system and thus OK...

Password

I had the system running for more than a week. Some data would be nice to have, but not essential.
I think I try to reinstall.

If that would be the case, why did it work? I think the thing that changed is the update to Manjaro 20.0. Maybe this caused any trouble?
I think I try to reinstall manjaro.

Nevertheless I was trying to reinstall grub and I am a little confused about the partitioning.
Do I need an extra partition on which I mount /boot? ( I think this is what I did first, but now i think this is unnecessary and I can just give the / the boot flag?)
And do I have to create a partition for grub? (with bios-grub flag?)

Yeah I am booting with USB and chroot into my installed manjaro.

It does work! As long as you don't change anything in the UEFI/BIOS settings and then: :exploding_head:

2 possibilities:

  1. UEFI
  2. BIOS

As your Windows seems the be installed in BIOS mode, better more consistent / easier to diagnose problems to do Manjaro in BIOS mode too:

  • Go to your firmware and:
    • enable BIOS mode / CSM mode / Legacy boot... whatever it's called
    • Turn secure boot mode off
  • In Windows:
    • Turn off fast boot
    • Turn off hybrid hibernation

and don't do encrypted /home until you're more familiar with Linux: do this for your next install and read LUKS encryption manuals (by that time LUKS2) and especially how to recover LUKS-encrypted volumes...

2 Likes

I actually have set up grub again, deleted /boot and configured grub simpler.
Now grub seems to work again, but manjaro got stuck st TLP system Startup/shutdown.

From journalctl I get the following error:

May 05 15:56:49 lenovo-lap sddm[925]: Display server failed to start. Exiting
May 05 15:56:50 lenovo-lap systemd-coredump[937]: Process 925 (sddm) of user 0 dumped core.
                                                  
                                                  Stack trace of thread 925:
                                                  #0  0x00007faf662f8ce5 raise (libc.so.6 + 0x3bce5)
                                                  #1  0x00007faf662e2857 abort (libc.so.6 + 0x25857)
                                                  #2  0x00007faf66716938 _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5 + 0x8e938)
                                                  #3  0x0000559d5025cfff n/a (sddm + 0x28fff)
                                                  #4  0x0000559d502a14df _ZN4SDDM4Seat13createDisplayEi (sddm + 0x6d4df)
                                                  #5  0x0000559d502a16f1 _ZN4SDDM4SeatC2ERK7QStringP7QObject (sddm + 0x6d6f1)
                                                  #6  0x0000559d502a3451 _ZN4SDDM11SeatManager10createSeatERK7QString (sddm + 0x6f451)
                                                  #7  0x0000559d502a42b3 n/a (sddm + 0x702b3)
                                                  #8  0x00007faf66962cde n/a (libQt5Core.so.5 + 0x2dacde)
                                                  #9  0x0000559d502a24f0 _ZN4SDDM10LogindSeat19canGraphicalChangedEb (sddm + 0x6e4f0)
                                                  #10 0x0000559d502a27ff n/a (sddm + 0x6e7ff)
                                                  #11 0x00007faf66962cde n/a (libQt5Core.so.5 + 0x2dacde)
                                                  #12 0x00007faf6731ede0 _ZN23QDBusPendingCallWatcher8finishedEPS_ (libQt5DBus.so.5 + 0x79de0)
                                                  #13 0x00007faf6731eee1 n/a (libQt5DBus.so.5 + 0x79ee1)
                                                  #14 0x00007faf6695aada _ZN7QObject5eventEP6QEvent (libQt5Core.so.5 + 0x2d2ada)
                                                  #15 0x00007faf6692d4d0 _ZN16QCoreApplication15notifyInternal2EP7QObjectP6QEvent (libQt5Core.so.5 + 0x2a54d0)
                                                  #16 0x00007faf6692fd56 _ZN23QCoreApplicationPrivate16sendPostedEventsEP7QObjectiP11QThreadData (libQt5Core.so.5 + 0x2a7d56)
                                                  #17 0x00007faf66986244 n/a (libQt5Core.so.5 + 0x2fe244)
                                                  #18 0x00007faf654df6be g_main_context_dispatch (libglib-2.0.so.0 + 0x6b6be)
                                                  #19 0x00007faf654e1531 n/a (libglib-2.0.so.0 + 0x6d531)
                                                  #20 0x00007faf654e1571 g_main_context_iteration (libglib-2.0.so.0 + 0x6d571)
                                                  #21 0x00007faf66985890 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2fd890)
                                                  #22 0x00007faf6692c05c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2a405c)
                                                  #23 0x00007faf66934066 _ZN16QCoreApplication4execEv (libQt5Core.so.5 + 0x2ac066)
                                                  #24 0x0000559d502607e1 main (sddm + 0x2c7e1)
                                                  #25 0x00007faf662e4023 __libc_start_main (libc.so.6 + 0x27023)
                                                  #26 0x0000559d50260aee _start (sddm + 0x2caee)
                                                  
                                                  Stack trace of thread 926:
                                                  #0  0x00007faf663b1abf __poll (libc.so.6 + 0xf4abf)
                                                  #1  0x00007faf654e14a0 n/a (libglib-2.0.so.0 + 0x6d4a0)
                                                  #2  0x00007faf654e1571 g_main_context_iteration (libglib-2.0.so.0 + 0x6d571)
                                                  #3  0x00007faf66985890 _ZN20QEventDispatcherGlib13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2fd890)
                                                  #4  0x00007faf6692c05c _ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE (libQt5Core.so.5 + 0x2a405c)
                                                  #5  0x00007faf66750c62 _ZN7QThread4execEv (libQt5Core.so.5 + 0xc8c62)
                                                  #6  0x00007faf672bab28 n/a (libQt5DBus.so.5 + 0x15b28)
                                                  #7  0x00007faf66751dd6 n/a (libQt5Core.so.5 + 0xc9dd6)
                                                  #8  0x00007faf662a446f start_thread (libpthread.so.0 + 0x946f)
                                                  #9  0x00007faf663bc3d3 __clone (libc.so.6 + 0xff3d3)
May 05 15:56:52 lenovo-lap sddm[943]: Failed to read display number from pipe
May 05 15:56:52 lenovo-lap sddm[943]: Display server failed to start. Exiting

Coredump (=crash) on your Simple Desktop Display Manager and why you can't see anything.

Is this on a fresh re-install? (I.E. What are you doing exactly?)

:thinking:

No, still on my old install.
Reinstalling sddm solved this.
Now I can boot again, the visualization is still kind of buggy, so I think the whole problem is somehow related to some graphic card/driver isssues..

So mainly what I did:
Deleted /boot and reinstalled linux kernel
(kind of follwed this: https://medium.com/@correspond.shashank/broke-my-arch-linux-again-heres-how-i-fixed-it-5db2db040b14)
Reinstalled grub and reconfigured it (nomodeset, simple terminal..)
-> then grub worked again
Then I reinstalled the sddm to make manjaro boot again.

Thanks for your help!! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by