Blackscreen on boot after removing bumblebee from systemctl

Long story short I messed up after stopping and removing bumblee from systemctl because I was experimenting with Optimus Manager.

Now Manjaro KDE wont boot. It gives me black screen. How do I undo this without being able to boot to my system? I think I just need to put bumblebee back to systemctl and i'm good.

Well this guide may help you

Thanks but once ive done that, do you know the commands to type to put bumblee back to systemctl?

optimus-manager needs to be removed a certain way so that it removes the configurations set by it.

If you want to disable optimus-manager completely, then first disable the SystemD service :

# systemctl stop optimus-manager.service
# systemctl disable optimus-manager.service

Then run optimus-manager --cleanup as root to remove any leftover autogenerated configuration file. Make sure to do this step before uninstalling the program.

i could never get optimus-manager working properly myself either, or only partially at best. if you want an optimus setup that allows switching, i made one recently that works differently than optimus-manager, only needs video-nvidia installed and also has an install script to set it up. does not use bbswitch or nouveau for switching and so far has been working great.

or if not, i can help you with bumblebee but im assuming you tried optimus-manager because bumblebee wasnt working that great. up to you.

remove optimus-manager the way i mentioned above, decide which you want to do and please post output of these after removing optimus-manager, do not reboot yet until another setup is in place.

inxi -Fxxxz
mhwd -li
pacman -Qs bbswitch
grep -v /etc/X11/xorg.conf.d/*.conf
grep -v /etc/X11/mhwd.d/*.conf
grep -v /etc/modprobe.d/*

if any have no output, please say so.

3 Likes

Thank you. I was able to reenable bumblebee but it did not fix the problem. Installing optimus manager in the TTY terminal solved the issue. Turns out that I did not properly uninstalled it. So this time I did and now I can boot to Manjaro again. Now another problem arises. When I reboot, I get stuck in a black screen. I have to pull the plug to my laptop to make it shutdown and so I could boot again.

Host: ----pc Kernel: 4.19.24-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.15.1 tk: Qt 5.12.1 info: latte-dock 
  wm: kwin_x11 dm: LightDM 1.28.0, SDDM Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 2441A75 v: ThinkPad W530 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 2441A75 serial: <filter> UEFI: LENOVO v: G5ETB0WW (2.70 ) 
  date: 03/08/2018 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 serial: <filter> charge: 90% 
  rechargeable: yes status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 6144 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 41512 
  Speed: 2433 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 2433 2: 3162 
  3: 1799 4: 1741 5: 2867 6: 1532 7: 1785 8: 1874 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK107GLM [Quadro K1000M] driver: N/A bus ID: 01:00.0 
  chip ID: 10de:0ffc 
  Display: x11 server: X.Org 1.20.3 driver: intel compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.3.3 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1e20 
  Sound Server: ALSA v: k4.19.24-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e 
  v: 3.2.6-k port: 7080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi 
  v: kernel port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 655.85 GiB used: 335.37 GiB (51.1%) 
  ID-1: /dev/mmcblk0 model: UD128 size: 119.28 GiB serial: <filter> scheme: MBR 
  ID-2: /dev/sda model: SPCC Solid State Disk size: 238.47 GiB speed: 6.0 Gb/s 
  serial: <filter> rev: 2A0 scheme: GPT 
  ID-3: /dev/sdb vendor: HGST (Hitachi) model: HTS725032A7E630 size: 298.09 GiB 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: B550 scheme: MBR 
Partition:
  ID-1: / size: 35.31 GiB used: 18.49 GiB (52.4%) fs: ext4 dev: /dev/sda8 
  ID-2: /home size: 14.70 GiB used: 3.77 GiB (25.7%) fs: ext4 dev: /dev/sda7 
  ID-3: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 1964 
Info:
  Processes: 248 Uptime: 3m Memory: 7.61 GiB used: 1.21 GiB (15.9%) 
  Init: systemd v: 241 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 
  running in: konsole inxi: 3.0.30 
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI


Warning: No installed USB configs!

Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection
 
[----@----pc ~]$ clear
[----@----pc ~]$ grep -v /etc/X11/xorg.conf.d/*.conf
##
## Generated by mhwd - Manjaro Hardware Detection
##
 
 
Section "Device"
    Identifier  "Device0"
    Driver      "intel"
    BusID       "PCI:0:2:0"
    Option      "AccelMethod" "sna"
        Option      "DRI"    "true"
EndSection
 
 
Section "DRI"
        Group  "video"
        Mode   0666
EndSection
 
 
Section "Extensions"
    Option "Composite" "Enable"
    Option "RENDER"    "Enable"
EndSection
 
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

I get no output with grep -v /etc/X11/mhwd.d/*.conf 
rather it just freezes.
/etc/modprobe.d/mhwd-nvidia.conf:##
/etc/modprobe.d/mhwd-nvidia.conf:## Generated by mhwd - Manjaro Hardware Detection
/etc/modprobe.d/mhwd-nvidia.conf:##
/etc/modprobe.d/mhwd-nvidia.conf: 
/etc/modprobe.d/mhwd-nvidia.conf: 
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nouveau
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-modeset
/etc/modprobe.d/mhwd-nvidia.conf:blacklist nvidia-uvm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist ttm
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm_kms_helper
/etc/modprobe.d/mhwd-nvidia.conf:blacklist drm
/etc/modprobe.d/nvdimm-security.conf:install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS

                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
video-hybrid-intel-nvidia-bumblebee            2018.08.09               false            PCI

if your using optimus-manager, please read the optimus manager tutorial. the bumblebee can go and is likely causing issues because the service is running.
sudo systemctl disable bumblebeed
sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee

i dont think you need video-linux either because with optimus-manager, nouveau gets installed via pacman, same as for the nvidia drivers IIRC.

this has to go
sudo rm -rf /etc/modprobe.d/mhwd-nvidia.conf

double check the tutorial and make sure thats everything, and that the service for it is running.

then issue the command to set your default boot mode and reboot. any further than that, i dont think i can be of any help seeing as how im not able to get optimus-manager working properly on my own system.

2 Likes

Thanks a lot. Removing those made me reboot without issue again. I should've read the tutorial. So thank you so much. I am going to try your script now.

oh and last question, how do I know that nvidia prime is active? I succesfully done all the steps. I rebooted. Is there a command that lets you know that you are using nvidia?

inxi -Gxxxz
glxinfo | grep -i vendor

~ >>> inxi -Gxxxz                                                                                                    
Graphics:  Device-1: Intel HD Graphics 530 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:191b 
           Device-2: NVIDIA GM107M [GeForce GTX 960M] vendor: Dell driver: nvidia v: 418.43 bus ID: 02:00.0 
           chip ID: 10de:139b 
           Display: x11 server: X.Org 1.20.4 driver: modesetting,nvidia compositor: compton tty: N/A 
           OpenGL: renderer: GeForce GTX 960M/PCIe/SSE2 v: 4.6.0 NVIDIA 418.43 direct render: Yes 
~ >>> glxinfo | grep -i vendor                                                                                       
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation
~ >>> 

glixinfo will show mesa when your using the intel mode

1 Like

nice, glxinfo | grep -i vendor shows

glxinfo | grep -i vendor    
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation

It's weird that playing Civ6 it still says that I'm using intel gpu. But i guess it's just the game.

1 Like

is the game slow like it's using the intel gpu?

Not really. But I could hear my fans loud as if I am using the nvidia gpu.

BTW. Follow up question. Is this the same process for EGPU? I installed an egpu setup on my laptop.

typing inxi -Gxxxzshows this

Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:0166 
  Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nvidia 
  v: 415.27 bus ID: 01:00.0 chip ID: 10de:0ffc 
  Device-3: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: ASUSTeK driver: nvidia 
  v: 415.27 bus ID: 04:00.0 chip ID: 10de:1c82 
  Display: x11 server: X.Org 1.20.3 driver: nvidia FAILED: modesetting 
  compositor: kwin_x11 resolution: 1920x1080~60Hz 
  OpenGL: renderer: Quadro K1000M/PCI

How could I tell that my external gpu is being used instead of my dgpu? They're both nvidia in the end.

im not sure of how to make the egpu as default, i've never used one. i know there were a few threads here on the forum discussing it and that user figured it out and IIRC, made a tutorial thats linked in the thread. do some searching and im sure you'll find it

You need to allow external GPUs in Xorg conf for the eGPU to be seen and used.

just add it as a second device entry in xorg conf, enable dual gpu, but not enable SLI?

AFAIK SLI is for two identical GPUs that work together as one, while eGPU is on an external hardware.

1 Like

it's recognized by the system in inxi info so something simple like

sudo nvidia-xconfig -c /etc/X11/xorg.conf.d/nvidia.conf -o /etc/X11/xorg.conf.d/nvidia.conf --enable-all-gpus

#edit "nvidia.conf" to match your existing nvidia xorg configuration file
#backup the original just in case (although i think xconfig does it for you)

this should just take his existing setup and add the second card to it. simple enough.

1 Like

inxi/lspci are not the same as Xorg.
I hope it works the easy way.. :wink:

2 Likes

May you please assist in me in how to do this? I've been looking for a tutorial on how to add my 1050 ti and I fail to find one.

1 Like

Forum kindly sponsored by