Blank Screen after login in gaming laptop with Nvidia GPU

Just got the Acer Predator Helios 300 with the Nvidia GeForce GTX GPU. It is a gaming laptop that came preloaded with Windows 10. Keeping in mind my future use with the laptop, I decided to wipe out Windows and put in Manjaro Linux instead.

I made sure I selected 'driver:nonfree' during the installation and completed setting up GNOME DE . When I restart the system post installation, I run into a blank screen , and it gets stuck there.

I did try reinstalling with 'free driver' and get the same blank screen issue.

Ran the commands in https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup , yet my drivers arent assigned.

This popped up during the reboots:37%20PM

Wish there was a clear solution for Nvidia . Any sort of help is appreciated.

Worth reading:

Everyone does... :cry:

2 Likes

if that doesnt work out for you, have a look at alternative options and see which one fits you best. if your planning on doing any gaming that involves vulkan/dxvk then bumblebee or nouveau wont cover that.

if you have the option in bios to disable the iGPU, that would be your best/easiest option since it avoids any of the optimus related issues and would use the regular nvidia drivers. if not i would recommend prime or optimus-switch

4 Likes

Finally!
I followed this:
Don’t forget to add acpi_osi=! acpi_osi=\"Windows 2009\" to your GRUB_CMDLINE_LINUX_DEFAULT in the file /etc/default/grub
And then at the terminal run
sudo update-grub

and then continued with what was pointed out in the article:

My Nvidia drivers are setup and all good.

Only downfall, my precision touchpad stopped working. In the process of finding the fix for that now. The wireless mouse is what I am using temporarily.

EDITED: I removed the video that I had referred to earlier. @dglt points out why it wasn't completely right to follow it in the comments thread.

wtf, this video again :face_with_symbols_over_mouth::bomb::gun::hear_no_evil::see_no_evil:
i thought this was gone a long time ago but i guess not. i just left a nice friendly comment on the video's comment section and flagged it. i also left links for the correct info.

@JoshithaR , please edit post and remove the video before someone else see's it and follows it. that video has you install GDM, SDDM, and LightDM at the same time and follow the instructions for each. last year when he started spamming it in every optimus related thread here on the forum he was told to take it down by a number of people and the video's were scrubbed from the forum. the fact that over 13.000 people watched that video is just plain scary. and likely contributed to the count of people who say "manjaro broke my computer" when really the issue is a PEBCAK issue.

it's not your fault, dont take this as directed toward you. it's the person who created it and then left it up for others to follow after being corrected and asked to remove it.

did you follow every step of that video? (hope not)

the acpi_osi=! parameter can sometimes break the touchpad, it's fairly common. there are other parameters you can try instead or try removing only that parameter and see if your still able to boot. you can do this right from the grub menu.

  • move selector to manjaro, dont hit enter and instead hit "E"
  • find acpi_osi=! and delete it.
  • then CTRL+X to boot.

you can do this to try other parameters as well, these edits are only for that boot and are not persistent if they dont work, you would just reboot and your changes get reset to the way they are in /etc/default/grub

you can also try removing both parameters and try this one

acpi_rev_override=1

also try 2,3,4,5 separately instead of 1 if it does not work. if it does, edit /etc/default/grub accordingly and sudo update-grub so the changes become persistent.

btw, i usually tell people to just reinstall manjaro after following that video if the install is new anyhow. and if not, at least undo somee of what the video instructs to do.

3 Likes

@dglt , Thanks for letting me know about this.

Yes, I was such a noob and installed all three DMs and their dependencies following that video.

Since my install is new, I'm going to take your advice and reinstall Manjaro.

Mine is the GNOME DE , so I'll have to do the PRIME or Optimus-switch only for GDM is it??

Basically, I'll have to just install only GDM?

no, you dont have to install any DM, it's already installed. follow the written directions for prime or optimus-switch and you'll be fine.

if you run into any issues just ask, someone is always around.

I tried to undo what was done in the video instead of reinstalling Manjaro.

In step 5 of this article,

The video sets up all three DMs.

Since mine is GNOME, I followed this :

Create a new file, /usr/local/share/optimus.desktop

And pasted the given code in the editor.

I commented out the lines I had typed in /usr/share/sddm/scripts/Xsetup ( SDDM part for KDE edition) and made sure I did not load the file /usr/local/bin/optimus.sh in LightDM’s startup sequence (LightDM part for XFCE edition)

I did not remove anything that was installed using Octopi.

Hope this is the right fix to my mistake.Or do I have to do the reinstallation all over again??

EDIT:

Precision touchpad is absolutely fine after I tried

you can also try removing both parameters and try this one
acpi_rev_override=1
if it does, edit /etc/default/grub accordingly and sudo update-grub so the changes become persistent.

Also : Screenshot%20from%202019-06-27%2012-53-29

Does this mean my Nvidia driver has been set up properly?

1 Like

Yes. 

it's probably fine, i only mentioned reinstalling because explaining how to walk back everything for some users would take longer than just reinstalling the freshly installed manjaro where nothing would be lost by doing so. but theres no reason it cant fix be fixed without reinstalling. if everything works, your good. theres really no reason to keep gdm and lightdm installed but making sure they are disabled should be enough.

sudo systemctl disable sddm
sudo systemctl disable lightdm

glad to hear everything worked out in the end. :+1:

1 Like

Disabled Lightdm and Sddm.
Yes everything is fine (for now :sweat_smile:)

Thanks for your help @dglt and @jonathon

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by