Blank screen on boot when trying to install

Trying to install the newest manjaro XFCE onto a new Acer Aspire E15 which came with windows 10. I got rid of secure boot, popped in the USB stick, and rebooted. I got nothing but a blank screen.

Then I disabled UEFI and set it to legacy boot. I again popped in the usb key and got a familiar screen with a few options (start manjaro linux, start manjaro (non-free drivers), etc.). I have tired Start Manjaro Linux and also Start (non-free drivers). I get a progress bar which says "loading linux kernel" which goes up to 100%, there is a blinking cursor in the upper left corner for about 1 second, but then I get a blank screen. Waiting did nothing. I had to reboot.

There is a line that says "Boot Options" below, and if I type anything it goes in there, so I typed in "nomodeset" (tried with and without quotations). That did not solve the problem.

I also tried the Hardware detection tool. That loaded OK, and I got a look at the PCI devices (seemed like the most likely candidate). There are two devices labeled as "unknown". One of them is the sound card, the other is the network controller. Neither of them seem like likely candidates for what is casuing this, but here's the details on both:

Vendor: Intel Corporation
Product: unknown
Class: Audio device
Location: 00:03.0
PCI ID: 886:0a0c[1025:0987]
IRQ: 7
Latency: 0
Module: unknown

Vendor: Atheros Communications Inc.
Product: unknown
Class: Network controller
Location: 03:00.0
PCI ID: 168c:0042[11ad:0806]
IRQ: 10
Latency: 0
Module: unknown

I also know that a blank screen on bootup was a not uncommon problem a few years ago, and it was usually caused by the graphics card. The hardware detection tool does recognize the graphics card, and here is what it has to say about it:

Vendor: Intel Corporation
Product: Haswell-ULT Integrated Graphics Controller
Class: VGA compatible controller
Location: 00:02.0
PCI ID: 8086:0a06[1025:0987]
IRQ: 7
Latency: 0
Module: unknown

This computer is infected by about 20 gigs or so of a strange virus called "windows". Please help me remove it!

why? just stay with UEFI, only disable secure boot.

if this still happens in UEFI try this:
in the Manjaro-UEFI boot menu, press "e"
go to the end of the line and write in
xdriver=intel
i dont know if intel will work without modesettings, so dont try to disable this.

of you can start a terminal please do a
inxi -F
and
cat /var/log/Xorg.0.log
so we can see whats (maybe) missing.

Tried with UEFI enabled first. It did not work so I tried disabling it to see if it would help. I have now re-enabled UEFI.

I have tried "e" at the boot menu and added xdriver=intel, nomodeset, and both. They do not make any difference. I found several modeset commands inside of the boot options with "e" and removed those to see if that made any difference. Still no dice.

After posting this last night I tried to start a terminal using the Legacy Boot. I did not get a terminal, but did not get a blank screen either; just a flashing cursor in the upper left hand corner of the screen. I thought this might mean it was doing something, but after about 10 minutes it stayed the same.

The UEFI bootloader is not the same as the legacy bootloader and I don't know how to get a terminal from it. There are two things called UEFI Shell x86_64 one of them labeled v1 and the other v2. I tried to get some info out of these but I don't have the slightest idea how they work: They do not seem to recognize POSIX commands.

Unfortunately it seems like I am not giving you any useful information here, but I am trying my best.

have you tried another USB Stick? Seems like its the same for you like i have with my Sandisk Stick. also please try to unplug every usb device you dont need (also mouse) for the boot. Seems that it wont eben loads the init system.

just to make it clear:
you're already using 16.06.1<-?

OK, will try another USB stick. I'll be back with results in a bit. Never had any USB device plugged in aside from the USB stick itself. The version I am trying to install is indeed 16.06-1. I downloaded it yesterday and tried to install immediately.

OK, new USB stick. No change. Everything behaves exactly the same.

not good :confused:
please try adding this to the bootcommand line
init=/usr/lib/systemd/systemd verbose
maybe we'll get some output this way

Nope. Still a blank screen. You think it might be a systemd problem? Maybe I should see if I can install Debian or something (If I remember correctly Debian still doesn't use systemd)

(I still want manjaro, mind you. This is just something to try.)

How do you know:
A. Your ISO d/l was good?
B. Your ISO burn to USB was good?

2 different USB keys so far, so I doubt it is the burn. I guess the download might be busted. I can see if I can boot a different machine with it. Let's give that a shot, back in a bit.

Nope. Boots just fine on a different machine. Slow as hell, but it is a pretty busted machine, and not the fault of the USB stick.

OK, I thought it might be a good idea to try to boot something other than manjaro just to see what happened. I had a SolydX iso lying around, I put that onto a USB stick and tried to boot it. It doesn't work at all with UEFI, booting into windows instead, but in Legacy boot I got something: It does not work, but it doesn't give me a blank screen either. I get:

[0.004169] ACPI: Unable to load the System Description Tables

Then on the next line there is a blinking cursor.

As I said previously, I still want Manjaro. This was just a test. Does this give anyone any new ideas?

hrm, may have to go with one of the buntus if secure boot is causing an issue.
I had to do that for one of the secure boot machines I had, I wanted it to have manjaro but it would only take ubuntu

Well, that is awful, but I will try xubuntu and see what happens.

OK, tried Xubuntu. No dice. gives me a bootloader but none of the options actually gives me anything other than a blank screen.

OK, I waited for Ellada to come out hoping for some progress. Tried just straight up manjaro net this time. No progress. I get the bootloader and when I select any option to continue I just get a blank screen.

It's pretty urgent now because my old computer died and I am pretty much stuck with windows until this is fixed. Being stuck with windows is worse for me than most people because I don't actually know how to use this thing. It took me for EVER just to get it to run a python script for my work . . .

Can you boot Windows with Secure Boot disabled? If so, you should have no problem with Manjaro...

Regards

This problem has been solved. I had to update the BIOS on this computer. This was a difficult issue to find.

Previous claims that there are no problems with manjaro if you can boot windows without secure boot are simply false, as are claims that this problem does not exist.

I now have installed the net edition of Manjaro and I am writing from it. Still have to add a user because the CLI installer did not give me the option of adding one myself, so I am logged in as root. I will figure this out eventually.

Does anyone know if one can get around this problem without updating the BIOS? I no expert when it comes to computers. So the risk is high I'll break something. I cannot afford it. This computer is used for home and work. It will cost me about 200 USD to replace if things go wrong. Almost half my monthly Salary! (I'm not American so costs can get quite bad)

Forum kindly sponsored by