Blender will not Launch

Hi everyone,

I'm new to the Manjaro community, and I would like to just say I am really happy to be here. I got here through the Foss community, by using Blender.
I was wondering if anyone was having trouble launching Blender. I seem to be able to download and install the featured version from Manjaro, but every time I try to launch it, it simply does not happen.
If someone has any ideas on how to solve this, or point a humble beginner in the right direction, please do.
I have no problem running other programs such as PyCharm or Arduino. If it helps, or makes sense, when I click on my Nvidia Driver App, it says the following.

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run nvidia-xconfig as root), and restart the X server.

I hope everyone is well and healthy!
Cheers from Los Angeles

Hey there.

Not trying to RTFM you - but its good to start with a snapshot of system info (inxi). see here:

Aside from that - can you try launching it from terminal ? What is the output?

Hi, I was just going to post a topic with the same title so maybe we can both be helped. (or maybe the OP has a completely different problem)

My system:

System:    Host: pc2019 Kernel: 4.19.113-1-MANJARO x86_64 bits: 64 Desktop: Xfce 4.14.2 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG MAXIMUS XI HERO (WI-FI) v: Rev 1.xx serial: <root required> 
           UEFI: American Megatrends v: 0602 date: 10/19/2018 
CPU:       Topology: 8-Core model: Intel Core i9-9900KF bits: 64 type: MT MCP L2 cache: 16.0 MiB 
           Speed: 800 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 
           8: 800 9: 799 10: 800 11: 800 12: 799 13: 801 14: 800 15: 800 16: 800 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2070] driver: nvidia v: 440.64 
           Display: x11 server: X.Org 1.20.7 driver: nvidia resolution: 2560x1440~60Hz 
           OpenGL: renderer: GeForce RTX 2070/PCIe/SSE2 v: 4.6.0 NVIDIA 440.64

Blender has worked fine for me in the past.

Now, I'm getting:
$ blender
blender: error while loading shared libraries: cannot open shared object file: No such file or directory

So thats something to go off of.
That seems like the package and libraries arent matched up.
Can you verify you are synced/updated?

sudo pacman-mirrors -f && sudo pacman -Syyu

( is provided by pkg boost-libs which is on version 72 on all branches)

It is in the process of updating a bunch of stuff...

Ah well .. not updated or partial-updated would be easy reasons for this :wink:
(I hope you were ready for your updates then ... maybe check update announcements you missed)

One thing I don't understand (and I've been using Manjaro about a year now) is why my panel icon says my system is up to date (when obviously its not). I always do updates when it tells me there are updates. How did my system get out of sync?


Probably your mirror.
If you never ranked it, or if for some reason the mirror you were using is out of sync or something .. then it would need what we did above.
I assume you are talking about pamac GUI .. and I do think you have some mirror options there too.

Yes, the pamac GUI.

Now I get a different error:

$ blender
Error! Unsupported graphics card or driver.
A graphics card and driver with support for OpenGL 3.3 or higher is required.
The program will now close.

I'll be back after a reboot.

Everything works fine after the reboot. I hope the OP figures out their issue.

thanks again!!

yes, modules and kernels and things should be followed by a reboot.
glad it worked out.
cheers :slight_smile:

No offense taken! This is all very new for me, but I am an enthusiastic learner. It will take me some time to figure out how to do this as I am a completely new user. I will try launching from the terminal and providing the data as specified above. Thank you for your reply!

I had a question actually, so when you do a system update, is it not necessarily complete? (like there is updates some where else in the pacman). Im glad you figured it out!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by