Bluetooth controller not found by Manjaro but works fine on Ubuntu (Intel 7265)

I have installed Manjaro on a new computer and discovered that the bluetooth is not working. I tested a live Ubuntu and it worked out of the box!

Here are some details about the system:

~ >>> sudo systemctl status bluetooth -l

ā— bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Tue 2020-07-21 18:00:16 CEST; 4min 46s ago
       Docs: man:bluetoothd(8)
   Main PID: 910 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 9309)
     Memory: 2.5M
     CGroup: /system.slice/bluetooth.service
             ā””ā”€910 /usr/lib/bluetooth/bluetoothd

Jul 21 18:00:16 ooeagle systemd[1]: Starting Bluetooth service...
Jul 21 18:00:16 ooeagle bluetoothd[910]: Bluetooth daemon 5.54
Jul 21 18:00:16 ooeagle systemd[1]: Started Bluetooth service.
Jul 21 18:00:16 ooeagle bluetoothd[910]: Starting SDP server
Jul 21 18:00:16 ooeagle bluetoothd[910]: Bluetooth management interface 1.15 initialized

~ >>> sudo lsmod | grep bluetooth

bluetooth             696320  14 btrtl,btintel,btbcm,bnep,btusb,rfcomm
ecdh_generic           16384  1 bluetooth
rfkill                 28672  10 bluetooth,cfg80211
crc16                  16384  2 bluetooth,ext4

~ >>> sudo dmesg | grep Blue

[    5.005078] Bluetooth: Core ver 2.22
[    5.005151] Bluetooth: HCI device and connection manager initialized
[    5.005156] Bluetooth: HCI socket layer initialized
[    5.005160] Bluetooth: L2CAP socket layer initialized
[    5.005165] Bluetooth: SCO socket layer initialized
[    5.077584] Bluetooth: hci0: read Intel version: 370810225019140f34
[    5.077587] Bluetooth: hci0: Intel device is already patched. patch num: 34
[    6.501291] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    6.501294] Bluetooth: BNEP filters: protocol multicast
[    6.501300] Bluetooth: BNEP socket layer initialized
[   69.155618] Bluetooth: hci0: read Intel version: 370810225019140f00
[   69.184203] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-22.50.19.14.f.bseq
[   69.573940] Bluetooth: hci0: Intel firmware patch completed and activated
[   69.663866] Bluetooth: RFCOMM TTY layer initialized
[   69.663874] Bluetooth: RFCOMM socket layer initialized
[   69.663881] Bluetooth: RFCOMM ver 1.11
[   92.058635] Bluetooth: hci0: read Intel version: 370810225019140f00
[   92.058704] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-22.50.19.14.f.bseq
[   92.447947] Bluetooth: hci0: Intel firmware patch completed and activated
[  140.058651] Bluetooth: hci0: read Intel version: 370810225019140f00
[  140.058732] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-22.50.19.14.f.bseq
[  140.441801] Bluetooth: hci0: Intel firmware patch completed and activated
[  151.653616] Bluetooth: hci0: read Intel version: 370810225019140f00
[  151.653684] Bluetooth: hci0: Intel Bluetooth firmware file: intel/ibt-hw-37.8.10-fw-22.50.19.14.f.bseq
[  152.044840] Bluetooth: hci0: Intel firmware patch completed and activated

~ >>> bluetoothctl

Agent registered
[bluetooth]# scan on
No default controller available
[bluetooth]#

inxi -Fxxxza --no-host
mhwd -l

Also my first guess is that Ubuntu is using an older kernel .. might try switching those.

1 Like

~ >>> inxi -Fxxxza --no-host

System:
  Kernel: 5.6.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.6-x86_64 
  root=UUID=bab63d04-1da0-4576-a7d1-ebe74ff9e06f rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Gnome 3.36.4 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux 
Machine:
  Type: Desktop System: $(DEFAULT_STRING) product: $(DEFAULT_STRING) 
  v: $(DEFAULT_STRING) serial: <filter> 
  Mobo: $(DEFAULT_STRING) model: $(DEFAULT_STRING) v: $(DEFAULT_STRING) 
  serial: <filter> UEFI: American Megatrends v: 5.13 date: 05/28/2020 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M705 serial: <filter> 
  charge: 65% rechargeable: yes status: Discharging 
CPU:
  Topology: Quad Core model: Intel Celeron J4125 bits: 64 type: MCP 
  arch: Goldmont Plus family: 6 model-id: 7A (122) stepping: 8 microcode: 16 
  L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 15980 
  Speed: 1352 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 995 2: 997 
  3: 998 4: 996 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 605 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:3185 
  Display: x11 server: X.org 1.20.8 driver: i915 compositor: gnome-shell 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 20.1.3 
  direct render: Yes 
Audio:
  Device-1: Intel driver: snd_hda_intel v: kernel bus ID: 00:0e.0 
  chip ID: 8086:3198 
  Sound Server: ALSA v: k5.6.19-2-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 v: kernel port: e000 bus ID: 03:00.0 chip ID: 10ec:8168 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: e000 
  bus ID: 04:00.0 chip ID: 8086:095a 
  IF: wlp4s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 51.35 GiB (4.9%) 
  ID-1: /dev/mmcblk0 model: DF4128 size: 116.48 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: 0x8 scheme: GPT 
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-00Z10T0 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 1A01 
  ID-3: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade 
  size: 3.73 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1.26 scheme: MBR 
Partition:
  ID-1: / raw size: 48.83 GiB size: 47.81 GiB (97.92%) 
  used: 10.64 GiB (22.2%) fs: ext4 dev: /dev/mmcblk0p5 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 276 Uptime: 2m Memory: 7.59 GiB used: 1.48 GiB (19.5%) 
  Init: systemd v: 245 Compilers: gcc: N/A Shell: zsh v: 5.8 
  running in: gnome-terminal inxi: 3.0.37 

~ >>> mhwd -l

0000:03:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI


0000:00:02.0 (0300:8086:3185) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

I have tried to switch to 5.4 (I believe that's what Ubuntu 20.04 uses, will double check), problem is still there.

I am sorry .. I meant to follow that up with mhwd -li

This card work flawless on Manjaro.

Bluetooth works on Manjaro. Do your system have a switch a key combo to turn on and off wireless?

As bluetooth is an integrated part of the wifi card - enabling disabling this will also toggle bluetooth.

You can check status with rfkill command. If it is softblocked it is easy to unblock - if it is hardblocked it is hardware switch.

Also bluetooth is always powered off on boot - a security feature I think - if you want it to be power up you need to configure the system to do it.

The following article on Arch Wiki is good read

I have tested again on Ubuntu (and also another Manjaro install on a stick not updated since last April) and found that the bluetooth worked well but the wifi connection was very slow. Then I found this issue and checked:

~ >>> iw reg get

global
country 00: DFS-UNSET
	(2402 - 2472 @ 40), (N/A, 20), (N/A)
	(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
	(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
	(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
	(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
	(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
	(57240 - 63720 @ 2160), (N/A, 0), (N/A)

phy#0 (self-managed)
country DE: DFS-UNSET
	(2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
	(2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
	(2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
	(5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5250 - 5270 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5270 - 5290 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5290 - 5310 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5310 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5490 - 5510 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5510 - 5530 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5530 - 5550 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5550 - 5570 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5570 - 5590 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5590 - 5610 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5610 - 5630 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5630 - 5650 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
	(5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
	(5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ, PASSIVE-SCAN

So it seems to be a similar issue. I just installed kernel 4.19 and will reboot to check.
EDIT: issue persists even with 4.19...

~ >>> rfkill list

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

There is no hardware switch.

I have a dual boot with Windows, where the bluetooth (and wifi) both work fine. The fast boot of Windows is disabled.

There is also the possibility the firmware has changed and is now incompatible with your system. You could see if there is newer linux-firmware for your system at Intel, or downgrade the linux-firmware package to a date before the issue occurred.

Search is your friend. Lots of candidates you could test a downgrade on. Look on the live disks for the package versions in use that were working.

I have tried all linux-firmware back to January (20200102.1eb2408-1) without success.
Ubuntu is using version 1.187, I don't know how which Manjaro version it matches...

Sorry I missed your earlier posts output regarding your country code. Be sure your regulatory domain is set properly.

Also if you are dual booting with Windows try warm booting from Windows into Manjaro. It also sometimes helps to reset your bios to the factory default.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by