Bluetooth does not stay paired after lock screen or boot

Right, troubleshooting bluetooth, my favorite... not.

I am moving from a Thinkpad X260 to a Thinkpad T450 because of the bigger screen. I am using a Thinkpad Bluetooth Laser Mouse.

On the X260 I run Manjaro Cinnamon and bluetooth works impeccably with this mouse. When I get back to the desktop from the lockscreen, suspend or boot I just need to wiggle my bluetooth mouse for a bit and it reconnects.

On the T450 I installed Manjaro Cinnamon fresh with Manjaro Architect. I see the following behavior:

  • after lockscreen, suspend or boot the bluetooth mouse is not paired and will not automatically reconnect
  • I have to manually push the pairing mode button on the mouse, open the bluetooth manager and re-pair the mouse. When this is done, the mouse works fine.
  • after boot I see the bluetooth icon in the tray flicker a couple of times when I wiggle my mouse and if I put the pointer on the icon, I can see the mouse is connecting/disconnecting rapidly
  • after maybe 30 seconds or so this connecting/disconnecting stops and it is no longer trying to connect to the mouse

What I have done so far:

  • been up and down the Arch wiki, forums and googled a lot
  • I have disabled bluetooth co-existence
  • I have trusted the mouse in bluetoothctl after it was paired
  • I have added the mouse-definition and a default pincode of 0000 to /usr/share/gnome-bluetooth/pin-code-database.xml
  • I have set AutoConnectTimeout=0 and AutoEnable=true in /etc/bluetooth/main.conf

That pretty much exhausted my bluetooth knowledge.

dmesg is showing a Bluetooth error: "Bluetooth: hci0: last event is not cmd complete (0x0f)". This is already being discussed on and I can find some references to it in Ubuntu mailinglists and bugtracker, but it would appear that this bug does not cause any of the behavior I mentioned.

I'd be very happy if someone knows a trick to get my mouse working :slight_smile:

I just updated my other laptop (X260) and the same problem was introduced. So it would seem this was introduced by the 2018-04-28 stable update.

It affects both kernels 4.14 and 4.16 and the only Bluetooth related update I see (at first glance) is bluez-qt.

Hi @philm and @oberon,

I have been testing this issue and it is reproducible.

Tested with: Lenovo T450, X260 and Acer C720 Chromebook with librefied bios and Thinkpad Bluetooth Laser Mouse.
Tested with: Manjaro Cinnamon iso 17.1.6, 17.1.7, 17.1.8 (default iso kernels).

When I boot the 17.1.6 or 17.1.7 live environment the bluetooth mouse keeps on working AFTER suspend.

When I boot the 17.1.8 live environment the bluetooth mouse is not paired and not working AFTER suspend.

What I mean with "paired" is in the screenshot:

Up to 17.1.7 the bluetooth manager lists the bluetooth device as paired after boot or suspend. It "remembers" the device across sessions.

From 17.1.8 the bluetooth manager always lists the bluetooth device as NOT paired after boot or suspend. The device is "forgotten".

Once the device is forgotten, you have to manually pair it again. Once you have paired it, it works fine.

The bluetooth device is also forgotten after a longer lockscreen, but I assume that is because of usb autosuspend settings.

So, something broke between 17.1.7 and 17.1.8, either in kernel or in bluetooth driver (or possibly in powermanagement/suspend).

I don't see any obvious errors in the systemlog or bluetooth log. I also can't find any related posts on the net (although there are a lot of bluetooth problems around).

Okay, I have solved this issue, but the resolution leaves me deeply unsatisfied.

I had Blueman-manager installed. I used the Blueman-manager gui to untrust and remove my mouse, and then clicked discovery, added and trusted my mouse.

Apparently this fixed some configuration thingy somewhere and now my mouse stays paired and reconnects after suspend and reboot again. Amazing!

However, I had untrusted/removed and added/trusted the mouse many times both through the default Cinnamon Bluetooth device manager and through bluetoothctl on the command line and that didn't fix my problems.

So, while my problem has gone away now, it is not fixed (and that's what I can't stand!).

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by