Bluetooth headphones connect but are not shown as output devices.

That is it. At the beggining they worked just fine, but one day around a month ago they simply stoped doing so. They connect but sound doesn't come from them and are not shown in the list of sound devices.
I have seen some people had this problem but with GNOME, and my computer has Manjaro KDE. Besides, they worked fine before, which was not the case for this users.

1 Like

:+1: Welcome to Manjaro! :+1:

Please read this:


and post some more information so we can see what's really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies...

:innocent:

Ok, thank you for the advice!

My hardware and software information:

System:    Kernel: 5.4.34-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=00c5a4a1-de67-45e8-8753-0ceaf3a09b1d rw 
           nouveau.modeset=0 quiet apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: KDE Plasma 5.18.4 tk: Qt 5.14.2 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Eluktronics product: Mech-15 G2Rx v: Standard serial: <filter> 
           Mobo: Eluktronics model: Mech-15 G2Rx v: Standard serial: <filter> UEFI: American Megatrends v: N.1.52 
           date: 04/18/2019 
Battery:   ID-1: BAT0 charge: 46.7 Wh condition: 46.7/46.7 Wh (100%) volts: 12.8/11.4 model: standard 
           type: Li-ion serial: <filter> status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 
           model-id: 9E (158) stepping: A (10) microcode: CA L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 807 2: 805 3: 800 4: 849 5: 802 6: 801 
           7: 807 8: 804 9: 801 10: 827 11: 801 12: 833 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Tongfang Hongkong Limited driver: i915 v: kernel 
           bus ID: 00:02.0 chip ID: 8086:3e9b 
           Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile] vendor: Tongfang Hongkong Limited driver: nvidia 
           v: 440.82 bus ID: 01:00.0 chip ID: 10de:1f11 
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia compositor: kwin_x11 tty: N/A 
           OpenGL: renderer: GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 440.82 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Tongfang Hongkong Limited driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:10f9 
           Sound Server: ALSA v: k5.4.34-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 7000 bus ID: 00:14.3 
           chip ID: 8086:a370 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Tongfang Hongkong Limited 
           driver: r8169 v: kernel port: 3000 bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 215.05 GiB (45.1%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 002C scheme: GPT 
Partition: ID-1: / raw size: 356.34 GiB size: 349.75 GiB (98.15%) used: 162.97 GiB (46.6%) fs: ext4 
           dev: /dev/nvme0n1p5 
Sensors:   System Temperatures: cpu: 45.0 C mobo: 45.0 C gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 358 Uptime: 2m Memory: 15.50 GiB used: 3.72 GiB (24.0%) Init: systemd v: 244 Compilers: 
           gcc: 9.3.0 Shell: bash v: 5.0.16 running in: yakuake inxi: 3.0.37 

this is what I found related to the device with journalclt:

abr 23 14:57:18 Laptop systemd[1214]: Reached target Bluetooth.
abr 23 14:57:19 Laptop kernel: input: JBL Free (AVRCP) as /devices/virtual/input/input30
abr 23 14:57:19 Laptop systemd-logind[848]: Watching system buttons on /dev/input/event28 (JBL Free (AVRCP))
abr 23 14:57:21 Laptop kwin_x11[1306]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 21913, resource id: 29360329, major code: 15 (QueryTree), minor code: 0
abr 23 14:57:25 Laptop kwin_x11[1306]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 27129, resource id: 31510809, major code: 3 (GetWindowAttributes), minor code: 0

This is the output of dmesg for Bluetooth:

[    5.069157] Bluetooth: Core ver 2.22
[    5.069185] Bluetooth: HCI device and connection manager initialized
[    5.069187] Bluetooth: HCI socket layer initialized
[    5.069189] Bluetooth: L2CAP socket layer initialized
[    5.069191] Bluetooth: SCO socket layer initialized
[    5.081814] Bluetooth: hci0: Firmware revision 0.1 build 26 week 11 2020
[    5.110650] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    5.110651] Bluetooth: BNEP filters: protocol multicast
[    5.110654] Bluetooth: BNEP socket layer initialized
[    9.518550] Bluetooth: RFCOMM TTY layer initialized
[    9.518555] Bluetooth: RFCOMM socket layer initialized
[    9.518559] Bluetooth: RFCOMM ver 1.11

I hope this is useful :slightly_smiling_face:.

Nah, nothing there... :sob:

So have you tried deleting them and pairing them again? (If that does the trick, we'll blame it on a cosmic ray)

:grin:

Hi! I tried unpairing them and restarting the PC and got this error:
Screenshot_20200428_154017
And then I checked with journalctl and found:

abr 28 15:38:11 Laptop bluetoothd[1087]: Hands-Free Voice gateway replied with an error: org.freedesktop.DBus.Error.UnknownMethod, Method "NewConnection" with an error: org.freedesktop.DBus.Error.UnknownMethod, Method "NewConnection" with signature "oha{sv}" on interface "org.bluez.Profile1" doesn't exist

I looked for it on the forum and found this thread, but they also do not have the solution.
Using systemctl restart bluetooth as it says on the thread let me pair the device once, but it could not connect. After I unpaired it and tried to pair it again, I got the same error from the beginning.

Can you pair these headphones with another device? (E.G. Your phone?) because it looks like they're broken.

If you still can, have you tried any different kernels? If it's recent, it might be a kernel upgrade regression error. 4.19, 5.6-RT and 5.7 RC2 would be high on my list:

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux419
    sudo mhwd-kernel --install linux56-rt
    sudo mhwd-kernel --install linux57
    sudo reboot
    
  • Choose these kernels one by one in the advanced options of grub.

2 Likes

Thanks! now it works.
Just one question, how does downloading the different kernels affect my computer?

Erm, because the Linux kernel is what makes the computer's hardware work just like the Windows HAL is...

Manjaro itself is about packaging all the other stuff like utilities, applications, ... together in one easy-to-install ISO.

Yes I know, but what I was trying to mean is what changes will I experience.

:grin:

That's an even more difficult question to answer, but this is what changed between 5.6.7 and 5.6.8. No one has done a diff between 5.4 and 5.6 but I'm sure it'll take you weeks to read it all!

IOW: You should ask Linus Torvalds himself and I'm pretty sure even he doesn't know all of the details any more...

:wink: :innocent:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by