Bluetooth headset stopped working for voice with some recent update

Hi all,

I'm relatively new to Manjaro, been using Ubuntu with i3wm in the past few years, so forgive me if I may be missing something important here.
But about 10 days ago (on Apr 01 according to journalctl), my Bluetooth headset stopped working for voice calls, and even though I spent many hours trying to debug it, I'm out of ideas by now.
I started getting this in journalctl:

Apr 01 10:58:55 laptop bluetoothd[1079]: Unable to get io data for Hands-Free Voice gateway: getpeername: Transport endpoint is not connected (107)

And in pavucontrol I see "Headset Head Unit (HSP/HFP) (unavailable)".
I also see in journalctl:

Apr 11 13:57:18 laptop bluetoothd[1096]: avrcp-controller profile connect failed for 0C:E0:E4:64:1E:CD: Operation already in progress

The A2DP profile works, BTW.

Among the things I tried:

  • Scan for multiple instances of pulseaudio (it's being run through systemctl but I also tried disabling it and running manually).
  • Follow the entire "Bluetooth headset" guide in the Arch wiki.
  • Install blueberry as suggested in a similar post here: Bluetooth headset: HSP/HPF profile not available
  • Install pulseaudio-modules-bt-git as suggested in a similar post here: [Updated] Bluetooth Speakers Connected But Device Not Displaying In Menu and No Audio Playing From Speakers
  • Pair a different headset, which works with my phone, just to make sure it's not the headset that failed. When doing so I also a new error in journalctl: bluetoothd[1096]: Hands-Free Voice gateway replied with an error: org.freedesktop.DBus.Error.UnknownMethod, Method "NewConnection" with signature "oha{sv}" on interface "org.bluez.Profile1" doesn't exist
  • Install pulseaudio-git (and delete ~/.config/pulse just in case)

In all the above I always tried to unpair the headset and re-pair it, just in case.

I'd really appreciate some help, I don't know what to do anymore.

Here are the general details for my system:

System:    Host: laptop Kernel: 5.4.31-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.3.0
           Desktop: i3 4.18 info: i3bar dm: GDM 3.34.1 Distro: Manjaro Linux
Machine:   Type: Laptop System: Dell product: XPS 15 7590 v: N/A serial: <filter> Chassis: type: 10
           serial: <filter>
           Mobo: Dell model: 0VYV0G v: A00 serial: <filter> UEFI: Dell v: 1.5.0 date: 12/25/2019
Battery:   ID-1: BAT0 charge: 95.9 Wh condition: 95.9/97.0 Wh (99%) volts: 12.8/11.4
           model: LGC-LGC8.33 DELL 5XJ289B type: Li-ion serial: <filter> status: Full
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A
           L2 cache: 12.0 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62431
           Speed: 901 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 5: 900
           6: 900 7: 901 8: 900 9: 900 10: 900 11: 900 12: 900
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0
           chip ID: 8086:3e9b
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: N/A bus ID: 01:00.0
           chip ID: 10de:1f91
           Display: x11 server: X.org 1.20.8 driver: intel resolution: <xdpyinfo missing>
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.0.4
           direct render: Yes
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3 chip ID: 8086:a348
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo
           bus ID: 1-5.4:12 chip ID: 046d:082d serial: <filter>
           Device-3: Realtek USB2137B type: USB driver: snd-usb-audio bus ID: 1-5.5:8
           chip ID: 0bda:4014 serial: <filter>
           Device-4: HTMicro Goodix Fingerprint Device type: USB
           driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5.7:10 chip ID: 2708:0002
           Sound Server: ALSA v: k5.4.31-1-MANJARO
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Bigfoot Networks driver: iwlwifi v: kernel port: efa0
           bus ID: 3b:00.0 chip ID: 8086:2723
           IF: wlp59s0 state: up mac: <filter>
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus ID: 4-1.2:3
           chip ID: 0bda:8153 serial: <filter>
           IF: ens20u1u2 state: down mac: <filter>
           IF-ID-1: br-060914d0f675 state: down mac: <filter>
           IF-ID-2: br-72602a75cea3 state: up speed: N/A duplex: N/A mac: <filter>
           IF-ID-3: docker0 state: down mac: <filter>
           IF-ID-4: veth1959d75 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-5: veth1c154ab state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-6: veth943e2f5 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-7: veth9743ae7 state: up speed: 10000 Mbps duplex: full mac: <filter>
           IF-ID-8: vetha4be98c state: up speed: 10000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 476.94 GiB used: 219.78 GiB (46.1%)
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC601 NVMe 512GB size: 476.94 GiB
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 80002111 scheme: GPT
Partition: ID-1: / size: 459.50 GiB used: 219.74 GiB (47.8%) fs: ext4 dev: /dev/dm-0
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1
Sensors:   System Temperatures: cpu: 46.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 359 Uptime: 32m Memory: 31.01 GiB used: 3.63 GiB (11.7%) Init: systemd v: 244
           Compilers: gcc: 9.3.0 clang: 9.0.1 Shell: zsh v: 5.8 running in: server inxi: 3.0.37
4 Likes

Digging through the pulseaudio repo, I found this: https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/742
Don't know what to make of it, there are comments (and also official PA documentation) saying HSP in PA will only work with oFono, but HSP/HFP worked for me for years with multiple Linux distros till just 2 weeks ago... What's going on?

Exactly the same problem here with manjaro gnome edition. All my Bluetooth headsets doesn't work since last big update around 23. March.

Please help

I have exactly the same problem.

Same here probably. Bluetooth headset stopped working after recent big update on HP Omen 15 laptop with KDE. I got it running once after multiple restarts but it was gone after reboot. The Bluetooth icon in the lower-right of the screen says the headset is connected but there is no associated device in the audio settings.

Got it working in my case. It seams something goes wrong with bluetooth upon boot and it needs to be reloaded with systemctl restart bluetooth

For an automated solution, this worked for me: Bluetooth headset not properly connecting on boot

1 Like

Wish I could get it work this way. After I restart bluetooth the HFP/HSP profile doesn't show "unavailable" and I can choose it in pavucontrol, but when I switch to it I get in the journal -

Apr 19 21:20:14 laptop bluetoothd[8658]: Unable to get io data for Headset Voice gateway: getpeername: Transport endpoint is not connected (107)

And no audio is played or recorded in the headset.

for me it's happening too. so weird this bug I think. Is there any news about it?

Hello,

same for me. Most recent Manjaro KDE version, stable branch. No HSP/HFP profile available for my bluetooth headsets.

Any news here? Confirmed as a bug by the devs, or anything?

1 Like

it happen since a few months I think, it something that it hasn't been answered yet from manjaro developpers.

Same issue on my Omen 15 running KDE. I never had any audio problem before now I feel like it's messed up.

Currently running openSUSE Leap 15.2 and Tumbleweed latest. HSP/HFP works beautifully on Leap with its slightly older packages, but not on Tumbleweed. Here are a few key package differences:

Tumbleweed:
bluez 5.54
kernel-firmware-bluetooth 20200519
libbluetooth3 5.54
libgnome-bluetooth13 3.34.1
pulseaudio 13.0
alsa 1.2.3
alsa-firmware 1.2.1

Leap 15.2:
bluez 5.48
kernel-firmware-bluetooth (package doesn't exist)
libbluetooth3 5.48
libgnome-bluetooth13 3.34.0
pulseaudio 13.0
alsa 1.1.5
alsa-firmware 1.0.29

I also tested Ubuntu 20.04. It was the total opposite, both of my bluetooth devices only connected via HSP/HFP, and the only way I could switch to A2DP was manually via bluetoothctl.

I use a Bose Q35C here on a daily basis and also had some issues, for me the fix was:
The issues seem related to the default ControllerMode setting in /etc/bluetooth/main.conf . Setting it to bredr did fix my issue.

51:# Possible values: “dual”, “bredr”, “le”
52:ControllerMode = bredr

My case might be a different issue but I think you may try it.

My packages:
bluez 5.54-2
libbluetooth3 not listed
libgnome-bluetooth13 not listed
pulseaudio
alsa-firmware 1.2.1-2

Thanks a lot for the tip.
So it looks like in my case the problem is my integrated Bluetooth controller in my Thinkpad T530. With a USB Bluetooth dongle, HSP/HFP appears to work fine with the default configuration. The integrated Bluetooth has always been kind of junky, so I guess that's the real problem.

if you restart the bluetooth service isn't it fixed?

I don't know why but the developpers of manjaro doen's count this like a problem. Someone knows if there is a report site or something like this for filling it??
Since months ago if you don't restart bluetooth systemd service it's not working as it should.. I don't know why.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by