Bluetooth Issues on Khadas VIM2 Max v1.2 on Fresh Manjaro ARM (both SD and EMMC)

I'm having some Bluetooth issues:

On a fresh install of Manjaro-ARM 20.07 for my Khadas VIM2 Max (v1.2)
I installed bluez-utils from Package Manger
I then proceeded to use bluetoothctl from Terminal
I was able to issue the commands:
power off
power on
but on scan on, I'm getting: Failed to start dicovery: org.bluez.Error.NotReady

I can't do "scan on" as advised in the procedures for my particular bluetooth logitech Anywhere MX 2 mouse from:

https://wiki.archlinux.org/index.php/Bluetooth_mouse#Problems_with_the_Logitech_BLE_mouse_(M557,_M590,_anywhere_mouse_2,_etc)

without the Failed to start dicovery: org.bluez.Error.NotReady error

In terminal rfkill list shows nothing blocked for hci0, hci1, or phy0 ... what am I missing?

So I did systemctl start bluetooth.service then systemclt status bluetooth.service and while it shows Active: active (running) there shows... Jul 18 15:42:40 Khadas-VIM2 bluetoothhd[643]: Failed to set mode: Failed (0x03) ... is this a bug?

I managed to add my bluetooth keyboard (ARTECK HB030B) and bluetooth mouse (Logitech MX Anywhere 2) and even got them to start on boot, however after a brief bit of time they seize up. My bluetooth seems to work for a while but then seizes up completely, when I go to check the Bluetooth Devices the window opens but nothing is responsive; I can't highlight different devices, the menu is unresponsive, the buttons are unresponsive, the only thing I can do is move the window, minimize, close and maximize. What's going on and how can I fix / resolve these issues?

I'm providing a link to my dmesg via termbin below:
https://termbin.com/z44v

Device: Khadas VIM 2 Max v1.2
OS: Manjaro-ARM 20.07
Kernel: aarch64 Linux 5.7.6-1-MANJARO-ARM
DE: Xfce4
CPU: ARMv8 rev 4 (v81) @ 8x 1.512GHz
Bluetooth Keyboard in Question: ARTECK HB030B
Bluetooth Mouse in Question: logitech MX Anywhere 2

Hello,

I will try to recreate similar issue by trying to use the bluetooth on Vim2 with my HP bluetooth Mouse and get back to you.

Thanks for reporting.

Hello,
I just tried connecting my Bluetooth Mouse over Vim2 basic and it worked fine, I suspect that Max have a different wifi/bt chip so maybe that is the reason.
Here is the screenshot of me using my HP Bluetooth Mouse over vim2Screenshot_2020-06-24_15-39-28

My Mouse is very old device and it worked fine in my test.
HP Bluetooth Wireless Optical Mouse HSTNC-002W

While I appreciate you testing and checking, I don't know if you fully understand the scope of my problem.

@spikerguy How long did it stay working for you? Because like I said, I can get it working, it just doesn't work for more than like 3 minutes before it seizes up and the bluetooth works no more and before the bluetooth settings window becomes completely unresponsive to any input.

Also, according to https://www.khadas.com/vim2 they both use AP6398S, 2X2 MIMO with RSDB [3] and Bluetooth V5

And I guess it's considered a non issue when only 1 person isn't able to reproduce the issue? It works for you so there is no issue? Cause if that's the attitude then nothing is going to get resolved and I'm better off spending my time elsewhere.

I did use it for more than 5 mins. I can try it again but just to inform you again we both have different wireless chipset so I might not be able to recreate the same issue like yours.

Hello,
Yes that's correct vim2 max have AP6398S chip and I only have VIM2 basic which does not have that chip so I cannot recreate the issue you're facing.

All I can say it try a different Bluetooth device and see if that helps, if not then there may be a need for improved Bluetooth driver for AP6398S as it is very new in the market.

Yes that's right I would suggest you to look for better AP6398S firmware online and help me with updating it to Manjaro Arm.
That will be very helpful of you :slight_smile:

Thanks in advance for the contribution.

These same bluetooth devices work fine everywhere else even on the Raspberry Pi with Raspbian, just not on Manjaro-ARM

Also if something were wrong with the devices they wouldn't have worked the part of the time that they did and from the beginning.

No it's not, I've already had this device for almost 2 years!

https://github.com/rockchip-linux/rkwifibt/tree/master/firmware/broadcom/AP6398S
https://github.com/rockchip-linux/rkwifibt/tree/master/firmware/broadcom/AP6398S/bt
(First Google result)
@spikerguy Can you tell me how to apply these better AP6398S firmware? How do I download them and where do I place them?

https://forum.khadas.com/t/wifi-ap6398s-mainline-kernel/4929/48

@spikerguy I've noticed that the VIM2 Max and VIM3 have the same WiFi/Bluetooth Chip, I also noticed that there is a VIM3 Bluetooth Fix Package in the Software Manager, would it be advisable to use that package? Also can you tell me what that fix is and what it's for and why it was included as an additional package? @Strit or perhaps you can?

@spikerguy if you have a VIM3, could you maybe test bluetooth on it (over 5 minutes) since it has the same bluetooth chip as the VIM2 Max ?

UPDATE:
I tried the new firmware, from help from steev on #armlinux and it still seizes up after some time of use.

I'm still waiting to hear back from @spikerguy and/or @Strit regarding the VIM3 Bluetooth fix package in the Repo and a VIM3 bluetooth test.

I have no idea what that package is. I can't find any references in our gitlab to a vim3 bluetooth fix package.
Can you tell me the exact package name?
If you talk about bluetooth-vim3, then that's a service needed to even get the bluetooth running.
So install that, and then enable the service with: sudo systemctl enable bluetooth-khadas.service and reboot.

Yeah it was bluetooth-vim2 1-1 it says: "Bluetooth fix for Khadas Vim 3" in the description. I did as you said and tryed: sudo systemctl enable bluetooth-khadas.service and reboot. But still the same thing... it works for a little while and then simply seizes up and doesn't respond to mouse movement or keyboard key presses. My regular USB keyboard and mouse still continue to be responsive, just not the bluetooth ones.

Ah okay. Well, it was the only suggestion I have. Sorry.

no worries, thank you for at least the suggestion :slight_smile:

Update: I just installed and checked xinput https://termbin.com/b2ft and it's showing my bluetooth mouse as a bluetooth keyboard, I also notice this in dmesg https://termbin.com/sso3

[ 47.766637] input: MX Anywhere 2 Keyboard as /devices/virtual/misc/uhid/0005:046D:B018.0006/input/input15
[ 88.257457] hid-generic 0005:046D:B018.0007: input,hidraw5: BLUETOOTH HID v0.09 Keyboard [MX Anywhere 2] on ac:83:f3:d4:65:93

It's supposed to be a MX Anywhere 2 Mouse not Keyboard

Forum kindly sponsored by