Bluetooth Mouse Lag

I installed and ran evhz and my mouse is sitting at a "smooth" 20hz :joy:

Am I being stupid to ask, how would I fix this?

post

hwinfo --mouse
  [Created at input.249]
  Unique ID: AH6Q.wJ5XlLsA+Z6
  Hardware Class: mouse
  Model: "MX Master 2S Mouse"
  Vendor: 0x046d 
  Device: 0xb019 "MX Master 2S Mouse"
  Compatible to: int 0x0210 0x0048
  Device File: /dev/input/mice (/dev/input/mouse2)
  Device Files: /dev/input/mice, /dev/input/mouse2, /dev/input/event23
  Device Number: char 13:63 (char 13:34)
  Driver Info #0:
    Buttons: 8
    Wheels: 4
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown
1 Like

btw, your not the only one
https://bbs.archlinux.org/viewtopic.php?id=248185

Should've done my research before getting this mouse

open a terminal and run these 4 commands

su
echo 0 > /sys/kernel/debug/bluetooth/hci0/conn_latency
echo 6 > /sys/kernel/debug/bluetooth/hci0/conn_min_interval
echo 7 > /sys/kernel/debug/bluetooth/hci0/conn_max_interval

  • reconnect mouse
  • does the latency improve?

EDIT: as an updated solution, here's how to make this persistent through reboots

5 Likes

bash: /sys/kernel/debug/bluetooth/hci0/conn_latency: Permission denied

My bad I accidentally a command. I did the 4 and it didn't seem to change anything, do I need to set a min and max interval?

try reconnecting the mouse now, maybe a reconnect is needed to notice a change.

my reference for those is here:
https://bbs.archlinux.org/viewtopic.php?pid=1857256#p1857256

1 Like

Personally, I would remove the file /etc/modprobe.d/btlag.conf if it has not helped.

good point. @evillord77, a little research and hopefully you get it figured out. i'm off for the night but best of luck, i hope it works out

1 Like

Thanks a lot for all your help!

1 Like

Those commands plus a reconnect did the trick. I really appreciate it. Hope you have a good night. You've made my day

done. Thanks so much for your help mate

1 Like

oh good, though you need to set those to either run at boot as root or run them yourself when needed. they wont persist after a reboot.

ok, now im really off. :sweat_smile:

Nice work @dglt

You can either use a cronjob or run it as a service at boot to execute the commands.

1 Like

Sweet, I'll give that a red hot go

Hey have a Logitech MX Master and same problem, Mouse is lagging.
My PC has no build in BT so i bought a BT dongle from TP Link.
Connecting the mouse is no problem, but its lagging very hard.

I dont know if its a problem with the dongle or with the BT settings.
I tried:

  • change the usbhid.mousepoll
  • and all the commands here, nothing helps.

Evhz displays this:
mouse_hz_mxmaster

i have the same MX Master 2S mouse and i found this solution working. i also did running these command on boot via rc.local but the problem is i still have to re-pair my mouse to make the cursor running smooth again. and at this time, i don't need to execute these commands again. so it seems that the commands were executed properly during boot and the re-pairing the mouse could to be the issue here now. what should i do?

theres probably way of setting those values so they never change like making them immutable but not sure thats a good idea.

after you boot, rc.local runs those commands but you need to pair it again for them to take effect? yes?

what if after you reboot you just disable and enable bluetooth instead? does the desired behavior become active?

Forum kindly sponsored by