Bluetooth preventing suspend

Hello,
I recently bought a bluetooth speaker. Everything is working fine, but when I try to suspend it immediately returns in login screen, like I used keyboard or mouse.
Any idea on how to troubleshoot it?

Thanks

There is most likely a fix for this, it involves writing a systemd service.

I have many other posts on this topic if you search the forum.

https://archived.forum.manjaro.org/t/kernel-4-19-0-3-not-network-after-suspending-gnome-edition/63544/2

https://archived.forum.manjaro.org/t/wifi-adapter-tp-link-tl-wn823n-must-be-reconnected-for-it-to-work/52968/19

https://archived.forum.manjaro.org/t/surface-pro-1796-wifi-not-resuming-after-suspend/48133/47

https://archived.forum.manjaro.org/t/thinkpad-x230t-wont-suspend-under-kernel-419rc4-4-18-4-17-4-14-4-9/59798/21

Here are some external links with excellent systemd reference material:

The ArchWiki - systemd

Red Hat - systemd-targets

Red Hat - systemd unit files

Systemd manpage

1 Like

Thanks, but I would really like to understand what is going on.
I probably should have added more details.
I am using KDE, and when I am using battery, everything is fine. Bt speaker will not change anything when I try to suspend.
When my laptop is connected to charger, external monitor, mouse and keyboard, after I suspend it will immediately go back to the login screen. If I have no BT speaker connected, I should move mouse or press a keyboard key (that is the behavior I want).

Did you read any of the links I posted?

The old post and dash manoeuver. Make your post and log off the second your post is made.

Good luck getting your issue fixed.

Since it's not a live chat I expect to be free to read and answer whenever I have time to.
I read the posts and I would be happy to do a systemd service, but I would prefer not to have any hackish kill-all-network-manager script on suspend.
Rather I asked

Any idea on how to troubleshoot it?

because I was hoping to get some information about why the bluetooth was causing the suspend to break, learn something and maybe do a focused disable like disabling an entry in /proc/acpi/wakeup

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by