Boost Python Error In Job "bootloader"

Hello, I'm new to Linux and currently trying to switch over from Windows 10. The issue at hand is at the end of the installation process, (Manjaro 20.0.1 KDE) I've attempted to use both Manual partitioning and Erase Disk numerous times over the span of 6 Hours and 27 total reboots. I made sure to check on my PC's BIOS and turned off secure boot like I've had suggested and set SATA mode to AHCI. My Drivers are set to Nonfree as I'm using a Nvidia Card, Here I have two screenshots of two different attempts using both Manual partitioning and Erase Disk. I should mention that I am trying to install from a USB Drive and as of writing I did attempt one more time although using Replace partition which gave me the same error as the ones above. I would really appreciate the help and do apologize if this question or similar issue has been discussed already, Thanks!

Both screenshots show more or less the same. Care to show the partitions you created?
lsblk -f

If your system is UEFI then the partition table should be GPT with a /boot partition.
If legacy then it should be MBR without a /boot partition.

Here I used GPT while attempting Manual partitioning as instructed in the Installation guide but it gave me the same error..

Ok, i don't know if there is a misunderstanding in the wiki, or is something else.
Click on New Partition Table and make sure is selected GUID aka GPT.
Double click on Free Space and make it be 512MiB for the boot partition and is set like this:

image

Create the root partition / or whatever layout you want (if you want a separate /home) from the remaining Free Space.

Since you have a nvme device i would suggest to let the swap partition out. You can add later a swapfile or use systemd-swap. The system will perform a bit better IMHO.

Continue the install. It should have no error.

1 Like

I follow the instructions for this error and yet every time i try to install Linux! the device i wish to install manjaro on is an acer spin 1 111 32n 4GB ram intel pentium cpu
boost.python error in job bootloader|690x437 of any distro i get this same error

Also having the same issues, tried multiple things in various threads, looks like this was a common issue in March.

Edit: For some reason it worked when I used the preset split partition function in calamares. No other set up worked, I have two Manjaro ISOs on the hard drive but I guess only one valid bootloader so it's functional for now haha

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by