Boot and pad problem after installation

After failing to install Xubuntu on a new Acer Spin 1 laptop, and messing up the system boot in the process, I've tried Manjaro and have been successful except for two remaining problems:

  1. I still need the installation usb stick to start it up. From the "Hello" page, if I then choose the option to "find efi" the installed manjaro fires up and then I can dismount and remove the usb stick. New software that I install and data that I add are all still there when I go through that process again. So the installed manjaro is clearly fine, except that it won't boot itself ... if the usb stick is not inserted I get a "No bootable system found" message. How can I get the computer to go straight to the installed system without having to use the usb stick to boot it? Secure boot is disabled.

  2. The other issue is that the touch pad doesn't work properly - it moves the curser but doesn't select anything. A usb mouse works fine. (Sorry if this should have been a seperate topic ... if so, please ignore and just help me with the boot issue.

I'm not a techie and need fairly precise instructions please. Thank you.

One problem at a time, is better for everyone here. Try to use the search forum, both your issues are discussed and solved for many.
This is to solve your boot problem

Thanks; forum protocol points noted and understood.
I've done as suggested, except that your stage [2] produced: "Could not prepare Boot variable: No such file or directory".
After stage [3] I now have both bootx64.efi and grubx64.efi in my /boot/efi/EFI/boot folder, but Manjaro still doesn't show up in efibootmgr.
This is an Acer Spin 1 machine with solid-state internal memory rather than hdd, and gparted shows it as mmcblk0p rather than sda, so at your stage [2] I also tried the line with that amendment, but it still produced the error message.
I notice that the stage [2] line uses two different types of speech marks - is that significant? I tried copying the line to preserve the two types, and also typing it which gave "" in both places, but it made no difference.
Thanks for any further help.

This is more complete post, but you might want to follow also what is added after.

For mmcblk0p devices there is another discussion here

@gohlip is the most knowledgeable regarding GRUB and how to fix it in any circumstances. I can't add anything new to the table, i don't have that level of understanding as he has, but following his posts i could fix some, so you might do that too. It will take a bit of time to read and follow, but i'm sure whatever it is sda or nvme devices, his solutions work 100%.

1 Like

Thank you @bogdancovacui. I'll have a good look through @gohlip's stuff on this and hope to find a solution for my particular system. Thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by