/boot/efi doesn't look like an efi partition

Hi, I am dual booting manjaro with windows 10 in UEFI mode, two days ago I reinstalled windows and I lost grub, now I am trying to recover it by creating a new efi partition with flags boot and esp, when I try to install grub after mounting the partition on /boot/efi:
it says

/boot/efi doesn't look like efi partition

I tried

sudo mkdir EFI

in /boot/efi it says
file exists.

ls /boot/efi

replies nothing. what should I do please help. should I reinstall?

Have tried this tutorial first?
Are you trying these commands from LiveCD?
Give some info as listed in the linked tutorial.

Yes I am trying on livecd and based on this tutorial Using livecd v17.0.1 (and above) as grub to boot OS with broken bootloader.

Did you get to boot your installation then?
If yes then post these info:

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by