Boot EFI stopped working in a removable external HDD on Mac mini

Unfortunately I learned the commands that I have learned from UUID not found after todays update and I ruined my boot and my grub. I copied the boot and etc folder that I backed up. It stopped working. I have to reinstall.

Ah, it is my 8th time that I have to format Linux.

What should I do when I intend to update or upgrade for not ruining the bootloader? Is the command sudo pacman -Syyu dangerous?

No, but the following are:

  • not updating
  • partial updates
  • interrupted updates

I don't think you need to reinstall manjaro, just reinstall grub.

If you are afraid of updates, you could use btrfs+timeshift so you can easily return to previous functioning state when something goes wrong.

Ah, yes, @Chrysostomus, good news, as you have said, I do not need to reinstall because...

I have discovered what caused to ruin the boot and grub. It was Krusader which did not complete the copy of backed-up folders boot and etc and left everything empty files. Krusader did not tell when the copy is complete. Instead of Krusader, I used Deepin File Manager as sudo and copied the backed-up and the folders returned to the normal. I rebooted and it worked, but I am still in the rootfs (same no UUIDs found, hibernation error, blabla) as upward.

We can now creturn to the issues of no UUIDs and of hibernation error.

I will avoid Krusader.

Let's have your "sudo parted -l" one more time. All disks, all output.

If it is from a mac-mini, say so.
If it is from another system, say so.
Whatever, all disks. All output from each.

Do mot mix gpt with msdos
Do not mix uefi and bios-legacy.
If you take the external disk and put it into another with another mode (msdos or uefi or...) you are also asking for trouble.

You have too many messed up things besides above.

if your swap defined by your fstab of your external is in an internal disk
How is it going to work if you put into another system without that internal disk anymore?
Remove all swap in your fstab first. Remove 'resume' in mkinitcpio.conf and 'mkinitcpio -P' and resume=UUID in /etc/default/grub and 'update-grub'
After that, we'll handle swap. Make everything work fine first without your swap getting in the way.
And no other fstab entry that refer to any internal disk partition.
If your swap is that of that external disk, then it is okay.

If you mix mados and gpt, you will need to reinstall
If you mix uefi and bios-legacy, you will need to reinstall.
If this external disk is set up in (properly) in a system of say gpt/uefi,
Do not put it in another system of msdos/bios-legacy
And never ever update it in that separate system. which is different from the set up system.

You are just doing too many things and you are confusing everyone with output from another system. Whenever you output, say it is from mac-mini or from another system,.

Without solving one thing, do not try to bring up another problem.
So fix in from say mac-mini and then we'll fix another system later. Okay?

First. No fstab entries of any internal disk partition.
Then Remove swap. mkinitcpio and grub. (IF swap is that of internal disk)
Then only this system. No other system.
sudo parted -l

1 Like

OK, as you have suggested, do you mean better I boot from Live Media on Mac mini? Installed originally from my Mac mini since last week. I use my external HD only mostly on Mac mini and almost never on my laptop.

Can you boot up your Manjaro (in the external disk) at all from the mac-mini?
And I don't mean livecd.

Boot up this way.

Do you know whether it is install as uefi or as bios-legacy?
Boot up the same way.

And I need from the booted up OS (not livecd)

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

All disks all output do not omit anything.
If erro message print.
If no message, sa so.
Need all output,.
do not stop at any command. continue.

grub > echo $grub_platform

I boot up in uefi.

If I run configfile /boot/grub/grub.cfg, I will be booted into rootfs like up.

Like what? up? What's up?
Ok, most likely you cannot boot up.
Then still at grub prompt

grub> search.file /etc/manjaro-release  root
grub> probe -u $root --set=abc
grub> ls ($root)/boot/

What is kernel and intramfs? 4.14?
Then use 4.14, otherwise change below to what you have.. (like 4.19 or 4.18 or...)

grub> linux /boot/vmlinuz-4.14-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.14-x86_64.img
grub> boot

Boot to OS and print out terminal output.

[edit] - you don't even have a working grub.cfg.

1 Like
grub> ls ($root)/boot/
efi/ memtest86+/ grub/ intel-ucode.img amd-ucode.img initramfs-4.19-x86_64.img vmlinuz-4.19-x86-64.img initramfs-4.19-x86_64-fallback.img linux419-x86_64.kver

It is 4.19. OK, let me run these commands...

Unfortunately I am still in the rootfs, but the errors are different:

ERROR: resume: no device specified for hibernation
Waiting 10 seconds for device /dev/disk/by-uuid/d3b51cb0-3d23-4827-8074-930b75264081...
ERROR: device 'UUID=d3b51cb0-3d23-4827-8074-930b75264081' not found. SKipping fsck. 
:: mounting 'UUID=d3b51cb0-3d23-4827-8074-930b75264081' on real root
mount: /new_root: can’t find UUID=d3b51cb0-3d23-4827-8074-930b75264081.

Try again from the begiining. You've done something wrong?
Start livecd, at grub menu press 'c'

grub> search.file /etc/manjaro-release

What do you get 2 output?
Then choose the one of the external disk.
(but why do you have 2 output? do you have 2 manjaro's? tell us. NOW!)

grub> set root=(hdx,y)

verify with first line below kernels are there.

grub> ls ($root)/boot/
grub> grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

1 Like

No, I did not, I was too careful to type slowly and avoided the misspellings.

I started from Live Media and I ran this command:

grub> search.file /etc/manjaro-release
error: no such device

My external HD has only one Manjaro.

Yesterday I have made an update, using ```sudo pacman -Syyu`.

Then I will start again from the begiining to make sure I did not do something wrong

No. Stop.
It won't work.
You are patching something that will still fail.
As said right from the begfinning and I had repeated 3 times.

Reinstall. fstab uuid will keep changing.
I'll explain next post for you yourself to check again. Just for you to understand.

1 Like

This post will show what why your system won;'t work.
And please, do not put this in another system and show some output.
Always in the min mac ffrom now onwards.
If you want to put it in another system later on when you had reinstalled and working fine. Tell us it is in anohter system and we'll go from there. Meantime. Always in mac-mini.

Okay? Promxe? Nah.. that's too condescending. ringt.

Boot up livecd in mac-mini with the external connected.

At livecd terminal, print out

efibootmgr -v
sudo parted -l
sudo blkid

Reminder: all disk, all commands, no omission. all output. blah blah blah.

Now, go to file manager of livecd and get into the partition of the external manjaro OS.


Next action, reinstall. swap and all partitions in external disk only.

1 Like
  • efibootmgr -v
efibootmgr -v
BootCurrent: 0000
Timeout: 5 seconds
BootOrder: 0002,0080,0001,0000
Boot0000* ubuntu        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* deepin        HD(1,GPT,2b51e9de-db7c-473e-9238-db0d2691cb4c,0x28,0x64000)/File(\EFI\deepin\shimx64.efi)
Boot0002* Manjaro       HD(1,GPT,2f0c8eb3-8ad5-4ef0-86e3-798143b8dd4e,0x800,0x96800)/File(\EFI\Manjaro\grubx64.efi)
Boot0080* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0081* Mac OS X      PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,822f779b-012e-4aa9-9596-75ebfedddec9,0x64028,0x3a1ec0c0)
Boot0082*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,0d3bd842-ba9a-442d-a33b-4f70567f7dcf,0x64028,0x3a1ec0c0)
BootFFFF*       PciRoot(0x0)/Pci(0x1f,0x2)/Sata(0,0,0)/HD(2,GPT,000072ce-62da-0000-532e-0000b35c0000,0x64028,0x3a1ec0c0)/File(\System\Library\CoreServices\boot.efi)
  • sudo parted -l
sudo parted -l
Model: ATA Hitachi HTS54755 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size   File system  Name                  Flags
 1      20.5kB  210MB  210MB  fat32        EFI System Partition  boot, esp
 2      210MB   499GB  499GB  hfs+
 3      499GB   500GB  650MB  hfs+

Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sdb: 4005MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      32.8kB  2122MB  2122MB  primary               boot
 2      2122MB  2127MB  4194kB  primary               esp

Model:  Mass Storage Device (scsi)
Disk /dev/sdc: 500GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  317MB   316MB   fat32                 msftdata
 2      317MB   8338MB  8022MB  linux-swap(v1)
 3      8338MB  500GB   492GB   ext4
  • sudo blkid
udo blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
/dev/sda1: LABEL="EFI" UUID="67E3-17ED" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="2b51e9de-db7c-473e-9238-db0d2691cb4c"
/dev/sda2: UUID="0ad0d00c-4782-3d2c-a629-5acbd1792bc1" LABEL="High Sierra" TYPE="hfsplus" PARTUUID="822f779b-012e-4aa9-9596-75ebfedddec9"
/dev/sda3: UUID="01cb061d-937b-3aba-943c-0ba15f417b93" LABEL="Recovery HD" TYPE="hfsplus" PARTUUID="4cf1744f-ccc4-4df8-b7c0-71560b6792a4"
/dev/sdb1: UUID="2018-09-08-09-10-02-00" LABEL="MJR180BE" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL="MISO_EFI" UUID="053D-0742" TYPE="vfat"
/dev/sdc1: UUID="8AA6-986B" TYPE="vfat" PARTUUID="2f0c8eb3-8ad5-4ef0-86e3-798143b8dd4e"
/dev/sdc2: UUID="1a9ae34a-453b-40ba-843a-201a7911cc49" TYPE="swap" PARTUUID="4abe231a-ebfa-4cdc-82dc-3f94167e99e2"
/dev/sdc3: UUID="d3b51cb0-3d23-4827-8074-930b75264081" TYPE="ext4" PARTUUID="3f4a6849-f78f-46ad-9958-e519808e2e9b"
  • /etc/fstab:
# <file system>                               <mount point>  <type>  <options>  <dump>  <pass>
UUID=8AA6-986B                                /boot/efi      vfat    defaults,noatime 0 2
UUID=1a9ae34a-453b-40ba-843a-201a7911cc49     swap           swap    defaults,noatime 0 2
UUID=d3b51cb0-3d23-4827-8074-930b75264081     /              ext4    defaults,noatime 0 1

Okay. Got it.

Still at livecd OS.
Now, lets, do a few things first.

  1. fsck root partition of external OS.
    Check again with 'sudo blkid' where partition is of uuid 'd3b51cb0-3d23-4827-8074-930b75264081'
  2. If it is still shown as /dev/sdc3, (otherwise change to correct one)
    sudo fsck /dev/sdc3
  3. sudo parted /dev/sdc set 1 boot on

ps: let us know if fsck has errors.

Then boot up installed OS (sdc3) again.
Restart computer with live media.
Do not boot up OS.
At install menu, go to grub prompt.

grub> insmod ext2
grub> search.file /etc/manjaro-release  
grub> search.file /etc/manjaro-release  root
grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

When booted to external disk installed OS (/dev/sdc3)
At terminal...

sudo grub-install --removable
1 Like
/dev/sdc3: UUID="d3b51cb0-3d23-4827-8074-930b75264081" TYPE="ext4" PARTUUID="3f4a6849-f78f-46ad-9958-e519808e2e9b"

Is it still correct?

[quote="gusbemacbe, post:38, topic:59612"]
Is it still correct?

Yes, it is still sdc3. Continue.
I (will) added what to do when booted. in edit. Not new post

Do both external HD and USB drive (Live Media) need to be plugged at the same time?

sudo fsck /dev/sdc3
fsck from util-linux 2.32.1
e2fsck 1.44.4 (18-Aug-2018)
/dev/sdc3 is mounted.
e2fsck: Cannot continue, aborting.

Should I ignore it and continue it?

Yes. MUST!!
You did not plug in last time? no wonder!!!

No, unmount it. You must unmount it.
Ah your DE mounts automaticall. UNMOUNT IT!!

1 Like

Forum kindly sponsored by