Boot manjaro with syslinux

I have a ssd formated in three partitions.

On the first partition is manjaro (sda1). For now manjaro deepin, but I will install manjaro xfce or thru net install or directly thru manjaro xfce.

On the second partion (sda5), there is porteus linux a slacware derivative. Porteus has been installed thru syslinux. Here is the menu entries:

[code]PROMPT 0
TIMEOUT 30
UI vesamenu.c32
DEFAULT gui
MENU BACKGROUND porteus.png
MENU TITLE Porteus-v3.1 64bit

MENU WIDTH 30
MENU MARGIN 2
MENU ROWS 10
MENU HELPMSGROW 17
MENU TIMEOUTROW 28
MENU TABMSGROW 15
MENU CMDLINEROW 22
MENU HSHIFT 4
MENU VSHIFT 5

menu color screen	37;40      #00000000 #00000000 none
menu color border	30;44      #00000000 #00000000 none
menu color title	1;36;44    #ffF6FF00 #00000000 none
menu color unsel	37;44      #ffffffff #00000000 none
menu color hotkey	1;37;44    #ff8037b7 #00000000 none
menu color sel		7;37;40    #ff111B78 #003f7fbf none
menu color hotsel	1;7;37;40  #ffaf67f7 #003f7fbf none
menu color scrollbar	30;44      #00000000 #00000000 none

menu color tabmsg	31;40      #ffB6F538 #00000000 none
menu color cmdmark	1;36;40    #ffff0000 #00000000 none
menu color cmdline	37;40      #ffffffff #ff000000 none
menu color pwdborder	30;47      #ffff0000 #00000000 std
menu color pwdheader	31;47      #ffff0000 #00000000 std
menu color pwdentry	30;47      #ffff0000 #00000000 std
menu color timeout_msg	37;40      #ff809aef #00000000 none
menu color timeout	1;37;40    #ffb72f9f #00000000 none
menu color help		37;40      #ffD5F538 #00000000 none
menu color msg07	37;40      #90ffffff #00000000 std

LABEL arch
MENU LABEL manjaro Linux
LINUX /boot/vmlinuz-4.4-x86_64
APPEND root=/dev/sda1 rw
INITRD /boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img

LABEL gui
MENU LABEL Linux 4.4.12-1-MANJARO x64
KERNEL /boot/vmlinuz-4.4-x86_64
APPEND initrd=/boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img root=UUID=9d7e6e8a-d65b-4036-8f72-dd8069fdbdb9 rw resume=UUID=ad800b6d-428c-451f-8eb8-1ee7ecaac8f1 quiet splash
TEXT HELP
Run Manjaro the best way we can.../initramfs-linux.img
ENDTEXT

#echo 'Loading Linux 4.4.12-1-MANJARO x64 ...'

linux /boot/vmlinuz-4.4-x86_64 root=UUID=9d7e6e8a-d65b-4036-8f72-dd8069fdbdb9 rw resume=UUID=e84dce4a-6c3d-493e-9c71-34798a0f0b3f quiet splash

echo 'Loading initial ramdisk ...'

initrd /boot/intel-ucode.img /boot/initramfs-4.4-x86_64.img

LABEL gui
MENU LABEL Graphics mode (KDE)
KERNEL vmlinuz
APPEND initrd=initrd.xz from=/64_V31 changes=/64_V31/kde extramod=/64_V31/kde login=root
TEXT HELP
Run Porteus the best way we can.
Try to autoconfigure graphics
card and use the maximum
allowed resolution
ENDTEXT

LABEL gui
MENU LABEL Graphics mode (XFCE)
KERNEL vmlinuz
APPEND initrd=initrd.xz from=/64_V31 changes=/64_V31/xfce extramod=/64_V31/xfce login=root
TEXT HELP
Run Porteus the best way we can.
Try to autoconfigure graphics
card and use the maximum
allowed resolution
ENDTEXT
[/code]

Can someone correct the menu entries for manjaro, there is a kernel panic, the way I set them. I have put the vmlinuz an initrams in both sda1 and sda5.

Thanks.

'LLo,

LABEL arch
MENU LABEL Linux 4.4.12-1-MANJARO x64
KERNEL /boot/vmlinuz-4.4-x86_64
APPEND root=/dev/sda1 rw quiet intel-pstate=disable
INITRD /boot/initramfs-4.4-x86_64.img

Something like above should be working better for Manjaro, but why are they two entries for or where is the entrie for Porteus ?

But above all you need also specific Porteus something.img & vmlinuz-something for LABEL gui which is default one (you'll find them on sda5 under /boot)

@fassil:
Your instructions did the job.

Is there a way to chainload to sda1 instead of having manjaro initramfs and vmlinuz in a folder in the porteus partition.

'LLo,

Yep & it's the only not obvious issue with syslinux & multiboot in case of kernel update of the "slave" distrib, you have to copy new initramfs & vmlinuz each time* ! I assume you want to mainly use manjaro, so you just have to reinstall syslinux from it as following:

syslinux-install_update -i -a -m

& copy/modify porteus /boot/syslinux/syslinux.cfg in manjaro at the same place & change default line by arch instead of gui & logicly the two following lines too (with a new .png in syslinux directory):

MENU BACKGROUND porteus.png
MENU TITLE Porteus-v3.1 64bit

  • It can be also & simply solved with an alias :wink:

By chainloading I was thinking about something like chainloading from syslinux to grub2(/mnt/sda1), see hyperlinks:


http://www.syslinux.org/wiki/index.php?title=Comboot/chain.c32

COM32 chain.c32 APPEND hd0 1 text help Boot into manjaro endtext

'LLo,

Maybe, but i don't really know because i don't use grub anymore since i've no more redmondia on my DD..!

You've used this "redmondia" several times in the past. I assumed you mean Windows.
In this case, substituting "windows" for "redmondia" doesn't mean much.

So what's redmondia?

Oh, also I don't use sysylinux, but try booting core.img instead of chainloading or the kernels.
It can be done from grub-legacy to boot grub2 and from what I read, lilo and others as well.
But I don't know syslinux to write the syntax.

Yep, it's just a turn of phrase about the historical registered office of the firm (like cupertinia for mac/apple :wink:)

For syslinux with linux-multiboot, except the kernel update of non default distrib wich can be easy solved, it's very simple. One command to install in mbr & one single text file to configure :wink:

Ps: & if all goes wrong (but it never happens) i have a mbr restore (via dd) ready to come back with this old good grub inside :wink:

Anyway, my last menu entry does not work. I was left with a command line entry:

boot:

Since then I am unable to reboot into porteus.

Personally, I was very happy with grub legacy, but when I installed manjaro with grub2, there is no way that I will achieve after that a grub legacy on mbr.

I too was very happy with grub-legacy. And I was happier when grub 2 came along. (I know many people were unhappy).

If you want (but up to you) to 'achieve' grub2 , we're here.
Cheers.

After posting this, it got me thinking that bootctl can also boot up core.efi (uefi, not bios-legacy, so core.efi, not core.img) since grub 2 is multiboot compliant. And it works. Here the link.

So it is possible to use core.img (or core.efi) on rEFInd, syslinux, lilo, bootctl, efistub, grub-legacy...etc to boot grub 2 OS's.
But need to write out proper syntax for each.
Good luck.

1 Like

To solve my problem in syslinux, I just reinstalled syslinux. It is ok now.

I am able to use grub2. It is just cumbersome with some files there and there. I have to use 40_custom for porteus. Automatic saving of the menu entry for grub2 will not work on the 40_custom entries. Unless I did miss something.

Grub legacy was really simple in terms of changing menu entries. You change a menu entry and the you save the menu.lst. Nothing more. But its obsolete.

I am trying to understand syslinux, I work with manjaro but also with another distribution that comes stock with syslinux.

Thanks.

'LLo,
@francois.e -> well done :wink:

To complete about syslinux:

  • if on a multiboot Hd you want "rock-solid" GPT instead of Extended + logical for having more than 4 partitions without any piece of the two Os (win*/osX*) which require EFI, it's absolutly possible to use it in bios mode.
    Personaly, "enjoying the simplicity" I have only 4 primary partitions in bios mode (three / & a common data) for a triple-boot -> 2 manjaro + Kaos at this time.
    Once said that, the three important entries of my syslinux.cfg as following:

LABEL archbase
MENU LABEL Manjaro Base
LINUX /boot/vmlinuz-3.18-x86_64
APPEND root=/dev/sda1 rw quiet intel-pstate=disable vga=773
INITRD /boot/initramfs-3.18-x86_64.img

LABEL arch
MENU LABEL Manjaro Light
LINUX /boot/light/vmlinuz-4.1-x86_64
APPEND root=/dev/sda3 rw quiet intel-pstate=disable vga=773
INITRD /boot/light/initramfs-4.1-x86_64.img

LABEL archtest
MENU LABEL Kaos Test
LINUX /boot/test/vmlinuz-linux
APPEND root=/dev/sda4 rw quiet intel-pstate=disable vga=773
INITRD /boot/test/initramfs-linux.img

Syslinux was installed from sda1 whis is also default, so it'll always boot with the wmlinuz & initramfs in /boot/ (even after a kernel update).
For the two other, i also create in /boot two repertories (test & light) with same name as partition label for keeping things as clearly as possible with different wmlinuz & initramfs (because it's so easy to play with kernel with manjaro :slight_smile:). I have special following alias for kernel update (this one for/in manjaro light):

alias sysly='sudo mount -t ext4 /dev/sda1 /mnt && sudo cp /boot/initramfs-4.1-x86_64.img /mnt/boot/light && sudo cp /boot/vmlinuz-4.1-x86_64 /mnt/boot/light && reboot'

To run before or after reboot when it's failed via Ctrl+Alt+F* (only in case of kernel update). If you volontary change of kernel, you also have to edit /boot/syslinux/syslinux.cfg to chande kernel numbers/version. Notice that Kaos haven't any of these number in its initramfs & vmlinuz (it's not so easy to switch kernel in as with manjaro).

Tested with debian, ubuntu's like installed on sda4 (obviously without any bootloader/grub during install or otherwise in the just installed /. It always worked :wink:
& as already said, i had grub2 installed from sda1 before the switch to syslinux & a working copy of the mbr within via dd in case of..!

O_ops -> i have also the current mbr with syslinux saved if i forget to not install grub when i distro-hoppe on sda4 :wink:

  • For this one, i don't know if it's possible without f■■■■■g EFI/$ESP..!
1 Like

As I said I too was very happy with grub-legacy and was very busy in forums helping out with problems especially after a new install or with 2 or more disks.

find stage 1
setup (x,x)
root (x,x)

But when grub 2 came out, I was 'out of a job' :wink:
Until Manjaro implemented intel-ucode. :joy:

Cheers. Take care .

1 Like

Cheers to both of you.

Forum kindly sponsored by