/boot partition when re-installing Manjaro(dual-boot with Windows 10)


I have Manjaro KDE 17.1.6 installed as dual-boot with Windows 10. I want to re-install it with older version - Manjaro KDE 17.0.6. How should I re-install it correctly? I found on the Internet that I just run new installation from USB, format partitions which I want to use for /root and /swap and thats it. But my biggest concern is, what about /boot? When I was installing Manjaro two days ago for the first time, I created /boot and /swap partition on my HDD but I did put /boot on SSD, where Windows boot partition was previously, so I changed /sda1 to /boot/efi. Now when I want to re-install, should I again put /boot/efi on /sda1 or not this time, and just format already existing /root and /swap?(I do not have anything installed on Linux so far, so I can format those partitions).

In case I did not explain clearly, just ask

Yes, but it might be better if you provide your partitions layout
Out of curiosity, why would you want to use an older ISO version?
You know, sometimes, newer ISOs include several fixes to installation software introduced in older ISOs.

1 Like

and if I do this /boot/efi on /sda1 again, shouldn't I somehow delete previous /boot/efi? I know I can not format that small /sda1 partition because I would loose booting for Windows, but still, after I reinstall, will I have just 2 options(Windows and new Manjaro) or 3 options(Windows, New Manjaro, Old Manjaro - even though this old will not work of course).

I will try to post here "lbsk" but I am not sure if I will be able to get it, I will answer in few minutes(I am writing from Windows).

And about that older version. I decided to dual-boot just 2 days ago, but I have several problems with Manjaro. Very often I am not even able to boot into system, when I finally get in there after a few attempts, some applications do not respond from time to time and mainly I have a problem with a driver probably. MHWD is not working at all, when I open it it just says it is not responding and there is no way to kill that process only reboot(tried to uninstall it and installed again, but did not help). But here is another problem, I can not reboot because when I shutdown/reboot whole system just freezes and nothing happens, I have to push power off button for a few seconds. I found somewhere here, that Jonathan(not sure about his name, it should be someone from Manjaro team I suppose) said that Manjaro 17.1.6 has some graphics issues, so I want to try that. Btw here is my whole problem, but no one replied Shutdown/boot freeze, not responding programs, and more

partitions layout

sda 8:0 0 931,5G 0 disk
├─sda1 8:1 0 827,5G 0 part
├─sda2 8:2 0 4G 0 part [SWAP]
└─sda3 8:3 0 100,1G 0 part /
sdb 8:16 0 238,5G 0 disk
├─sdb1 8:17 0 260M 0 part /boot/efi
├─sdb2 8:18 0 16M 0 part
├─sdb3 8:19 0 237,4G 0 part
└─sdb4 8:20 0 831M 0 part
sr0 11:0 1 1024M 0 rom

sda - HDD
sda1 - My windows partition for my data
sda2 - swap for linux
sda3 - /root and /home partition for linux

sdb - SSD
sdb1 - boot for windows and linux
sdb2 - no idea
sdb3 - this is where my Windows is installed
sdb4 - no idea

And I have to correct my previous post because /boot/efi is on sdb1 not sda1

If you're goona use /boot with efi, and Win, then use systemd-boot to help you dual-boot.
but if you use /boot/efi. then use grub,..., and the refind may also be useful.
It sounds like you already used "/boot", (not knowing about systemd-boot, but now want to reinstall with /boot/efi ?

so, what does:
sudo efibootmgr -v

Oh my mistake. I meant I created /root and /swap partition and then lastly /boot/efi on SSD.

But what is systemd-boot?
And I am not sure about GRUB either, I think it is that thing that let me choose if I want to start Linux or Windows, am I right?

Provide also
fdisk -l

sudo efibootmgr -v

BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0000
Boot0000* Windows Boot Manager HD(1,GPT,a54b2dc8-8813-4c47-ae86-ac8edd7fcd45,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...K................
Boot0002* Manjaro HD(1,GPT,a54b2dc8-8813-4c47-ae86-ac8edd7fcd45,0x800,0x82000)/File(\EFI\MANJARO\GRUBX64.EFI)

And I want to add, I followed this guide to install Manjaro, I did what he did in this guide about my partitioning with exception, that after install I did not need to update grub because I was able to choose Windows/Linux immediately http://linuxbsdos.com/2016/11/07/how-to-dual-boot-manjaro-16-10-windows-10-on-a-computer-with-uefi-firmware/

fdisk -l

Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 0273B7CD-8174-4FFD-BCA0-A6C2ABD65C39

Device Start End Sectors Size Type
/dev/sda1 2048 1735311359 1735309312 827,5G Microsoft basic data
/dev/sda2 1735311360 1743699967 8388608 4G Linux swap
/dev/sda3 1743699968 1953525134 209825167 100,1G Linux filesystem

Disk /dev/sdb: 238,5 GiB, 256060514304 bytes, 500118192 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 99E29536-4D7F-412F-B0E1-DB1ACBB63CF5

Device Start End Sectors Size Type
/dev/sdb1 2048 534527 532480 260M EFI System
/dev/sdb2 534528 567295 32768 16M Microsoft reserved
/dev/sdb3 567296 498413908 497846613 237,4G Microsoft basic data
/dev/sdb4 498415616 500117503 1701888 831M Windows recovery environment

Now it's better! :+1:
To your benefit, please read this guide to understand how the boot process functions with Grub bootloader
Check your EFI partition for current files (sdb1).

ls -R /boot/efi

When installing new, select sdb1 mount point as /boot/efiwithout formatting (IMPORTANT!!), sda3 as /with re-formating and sda2 as swap .
Depending the installer, you may need to manually apply the efi fix mentioned at the link's Guide (even after a failure to boot, using the Live ISO to repair, as for the Guide).

UEFI - additional command

If system is uefi, the following additional command is recommended at the end of step 6.
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

1 Like

Ok I read that guide. And what exactly should I look for in EFI partition? Or you wanted me just to check that partition so I can see what is in there?

for this

and this
or post the command output.

Ok I can see it, but output is long so I just took a screenshot, that file is almost at the top


It looks fine.
I believe you have understood what you need to do.

yeah I hope so. I am going to try to re-install it now. I will post here after installation whether I was successful or not in about 30 minutes.

Thank you a lot

1 Like

I am desperate. I can not start installation of Manjaro anymore.
It is always stucked at "Started TLP system startup/shutdown"...
As I was googling how to fix it, I found out that this problem is here for more than 3 years and still no universal solution for that...this is so frustrating. Does not matter if I choose free or non-free drivers...it is always same...I do not know what to do ...Any idea?

Or do I really need to install some other linux distro? :frowning_face:
I really enjoy Manjaro but if I can not get it working...

here is screenshot where it is stucked

It is not very kind behavior when one says "I told you so!", but

Sorry to disappoint you but I tried to instal Manjaro KDE 17.1.6, Manjaro KDE 17.0.6, Manjaro XFCE 17.1.6, I tried to install all of them with free and also non-free drivers but no success...I spent whole day trying to fix this but nothing works. As I said earlier, this problem is probably caused by having both Nvidia and Intel GPU and Manjaro can not find right driver, and this problem persists for several years now, without any obvious solution. Any other idea please? :frowning:

Try Manjaro-Architect ISO installer.
It is no graphical and is the best on these cases.
The abilities (about installation) are the same and more than other ISOs.
The only caveat is the environment (no nice GUI) but I believe if you read the installation guide, you can have a successful installation.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by