Boot problem after full disk

Hello, after update I am stuck at the "Manjaro" screen with the 5 loading lights. Restarted a few times also left it loading for a few hours, no go.

Initially update failed because my disc was full, I emptied the pacman cache and gained a few GB, finished update. Before restart I got "your system is up to date". any thoughts? I use xfce, thanks

had the same issue (aborted update by accident ^^)
for me, chrooting and reinstalling kernel + update-grub was enough to recover

If you press Esc while booting what do you see? Also, can change to a console (in ex.: CTRL+ALT+F2)?

Thanks mbb, pressing esc while booting does nothing, ctrl alt f2 does not go to console[quote="Termy, post:313, topic:23538, full:true"]
had the same issue (aborted update by accident ^^)
for me, chrooting and reinstalling kernel + update-grub was enough to recover

thanks Termy, no experience, chrooting reinstall kernel update grub would probably take me hours or a day to figure out, any easy tutorials around?

thanks oberon, would that be ctrl alt f2? no response, also no response at manjaro screen with up down arrow. The only text screen I can enter is the bash grub one. Yes I tried booting to a different kernel, same results.

thanks Termy, going there now!

I booted from manjaro usb stick, ran lsblk in terminal. I can see my manjaro partition sda2, when I do sudo mount /dev/sda2 /mnt I get "cannot find
/dev/sda2/mnt in /etc/fstab

That is the first action, so, I cannot proceed with the instructions.

No, what I mean is: When you're on the grub screen where you select your kernel, instead of hitting enter, press 'e', then navigate to the line starting with "linux..." and at the end of that line add a space and a 3, then press F10. This should boot you directly to a console instead of the display manager.

OK, this worked in that I can see that screen, go to end of Linux line add space, 3, press f10. I tried it with both the kernels available, it went to the stuck Manjaro loading screen, not a console.

  • go to the boot line you want to start and press CTRL-E to edit that line
  • go to end of Linux line
  • remove quiet and splash
  • add a space followed by 3
  • press CTRL+X
  • login with your root user
  • finalize the update
1 Like

thanks oberon and philm. At the end of the process I get this screen and a flashing cursor, unable to input any text. I tried process with both kernels available, 4.9 and 4.4:

  1. First try to fsck your OS partition.
    You have to do this from another OS or from livecd as the OS partition needs to be unmounted.
  2. Then continue to try to login with prompt (press 'e', remove...) but this time also remove the resume part as well. Remove 'resume=UUID=xxxxxxxxxxxx' in addition to 'quiet' and 'slash' and add '3'
  3. When logged in with password, continue with updates (maybe set mirrors first)
  4. When all finish, print out
    cat /etc/fstab
    sudo blkid
    cat /etc/default/grub

Good luck.

Thanks gohlip, in case it matters, the update was finished, I got "your system is up to date"... I did see my os partition earlier from usb manjaro, I will go back to it. I'm looking at fsck on wikipedia, what am I doing unmounting the os partition? thanks

The command is
sudo fsck /dev/sdax

where /dev/sdax is the OS partition.
But we cannot fsck any partition when it is mounted, so we have to do this from another OS or from a live media.
Before doing the fsck partition, check the correct partition with one of
sudo fdisk -l
sudo parted -l
sudo blkid

reminder - remove the 'resume=UUID=xxxxxxxxxxxx" when you boot up after fsck

I ran fsck on the OS partition, does that unmount it? or is there another command to run after sudo fsck /dev/sda2?

Okay, done. (meaning nothing else to do in fsck, not everything is done).
Does that give any message. or just say ""Clean...blah blah blah"
Then proceed to the next part to boot up in prompt.

ManjaroRoot: clean... I'll go back to the other procedure then

OK, I believe I did everything correctly, I get the same result as shown in above picture "can't access tty; job control turned off" flashing cursor.

I'll have to get back to this in a bit, I believe I did choose the correct partition to fsck my OS

Yes, please check if you fsck the right partition, and from a livecd.
Since you're going to the livecd, you can also proveide (from livecd)
sudo fdisk -l
sudo parted -l
sudo blkid

Then go to livecd file manager, go into the Manjaro installed parttition and print out the /etc/fstab, /etc/default/grub for us.

I have a manjaro installation dvd I can use, out of curiosity can these tasks also be done from manjaro installation on a usb stick?

Forum kindly sponsored by