Boot problem after full disk

Yes, from any installation media, dvd or usb.

OK, thanks, I believe this is the information asked for:

[manjaro@manjaro ~]$ sudo fdisk -l
Disk /dev/sda: 29.9 GiB, 32044482560 bytes, 62586880 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x26452ea5

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 524287 522240 255M 83 Linux
/dev/sda2 524288 24076287 23552000 11.2G 83 Linux
/dev/sda3 24076288 56324095 32247808 15.4G 83 Linux
/dev/sda4 56324096 62586879 6262784 3G f W95 Ext'd (LBA)
/dev/sda5 56326144 62586879 6260736 3G 82 Linux swap / Solaris

Disk /dev/loop0: 139.6 MiB, 146341888 bytes, 285824 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop1: 168.4 MiB, 176615424 bytes, 344952 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop2: 806.7 MiB, 845844480 bytes, 1652040 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/loop3: 315.8 MiB, 331165696 bytes, 646808 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sdb: 7.2 GiB, 7756087296 bytes, 15148608 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0c201ef9

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 63 15148223 15148161 7.2G b W95 FAT32
[manjaro@manjaro ~]$ sudo parted -l
Model: ATA Cavalry SSD (scsi)
Disk /dev/sda: 32.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 1049kB 268MB 267MB primary ext2 boot
2 268MB 12.3GB 12.1GB primary ext4
3 12.3GB 28.8GB 16.5GB primary ext4
4 28.8GB 32.0GB 3207MB extended lba
5 28.8GB 32.0GB 3205MB logical linux-swap(v1)

Model: TOSHIBA TransMemory (scsi)
Disk /dev/sdb: 7756MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number Start End Size Type File system Flags
1 32.3kB 7756MB 7756MB primary fat32 boot

[manjaro@manjaro ~]$ sudo blkid
/dev/sda1: LABEL="ManjaroBoot" UUID="df14a659-5993-448a-a08b-b1d18f3c3b52" TYPE="ext2" PARTUUID="26452ea5-01"
/dev/sda2: LABEL="ManjaroRoot" UUID="c73ddae9-ad8e-4b8f-8087-a59d34fb0aaa" TYPE="ext4" PARTUUID="26452ea5-02"
/dev/sda3: LABEL="ManjaroHome" UUID="a8765daa-33d7-4649-80ca-29855605777e" TYPE="ext4" PARTUUID="26452ea5-03"
/dev/sda5: LABEL="ManjaroSwap" UUID="82886d16-f1c4-4d98-ad3b-c9b5183336fe" TYPE="swap" PARTUUID="26452ea5-05"
/dev/sdb1: LABEL="MYLINUXLIVE" UUID="C8D5-5927" TYPE="vfat" PARTUUID="0c201ef9-01"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/loop3: TYPE="squashfs"
[manjaro@manjaro ~]$

/etc/fstab: static file system information.

Use 'blkid' to print the universally unique identifier for a device; this may

be used with UUID= as a more robust way to name devices that works even if

disks are added and removed. See fstab(5).

UUID=df14a659-5993-448a-a08b-b1d18f3c3b52 /boot ext2 defaults,noatime 0 2
UUID=c73ddae9-ad8e-4b8f-8087-a59d34fb0aaa / ext4 defaults,noatime 0 1
UUID=a8765daa-33d7-4649-80ca-29855605777e /home ext4 defaults,noatime 0 2
UUID=82886d16-f1c4-4d98-ad3b-c9b5183336fe swap swap defaults,noatime 0 2


GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Manjaro"

GRUB_CMDLINE_LINUX_DEFAULT="resume=UUID=82886d16-f1c4-4d98-ad3b-c9b5183336fe quiet splash"

GRUB_CMDLINE_LINUX=""

If you want to enable the save default function, uncomment the following

line, and set GRUB_DEFAULT to saved.

GRUB_SAVEDEFAULT=true

Preload both GPT and MBR modules so that they are not missed

GRUB_PRELOAD_MODULES="part_gpt part_msdos"

Uncomment to enable Hidden Menu, and optionally hide the timeout count

#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

Uncomment to use basic console

GRUB_TERMINAL_INPUT=console

Uncomment to disable graphical terminal

#GRUB_TERMINAL_OUTPUT=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'

GRUB_GFXMODE=auto

Uncomment to allow the kernel use the same resolution used by grub

GRUB_GFXPAYLOAD_LINUX=keep

Uncomment if you want GRUB to pass to the Linux kernel the old parameter

format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

GRUB_DISABLE_RECOVERY=true

Uncomment and set to the desired menu colors. Used by normal and wallpaper

modes only. Entries specified as foreground/background.

GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

Uncomment one of them for the gfx desired, a image background or a gfxtheme

GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/boot/grub/themes/Manjaro-Default/theme.txt"

Uncomment to get a beep at GRUB start

#GRUB_INIT_TUNE="480 440 1"

2 things.

o fsck - I hope you're certain you've done your fsck and that it gives no error ("clean" is not an error).
If uncertain, it is best to do again fsck (from a livecd)
Do all partitions except swap.
sudo fsck /dev/sda1
sudo fsck /dev/sda2
sudo fsck /dev/sda3

o When booted to grub menu, go to grub prompt (grub>) by pressing 'c'
check

grub> echo $root

It should give 'hd0,msdos1'
Write down the kernels and initramfs files from

grub> ls ($root)/

It should list vmlinuz-4.9-x86_64 and initramfs-4.9-x86_64.img
if not, write down correct kernels, continue

grub> linux /vmlinuz-4.9-x86_64 root=/dev/sda2 rw 3
grub> initrd /initramfs-4.9-x86_64.img
grub> boot

Note it is /dev/sda2 not /dev/sda1
When booted, at terminal

sudo grub-install /dev/sda
sudo update-grub

yes, all "clean", no errors, checked it twice: boot, root, home all clean [quote="gohlip, post:409, topic:23538"]
grub> echo $root

It should give 'hd0,msdos1'
[/quote]

no, it gives hd0 msdos2, checked it twice [quote="gohlip, post:409, topic:23538"]
grub> ls ($root)/
[/quote]

input> ls ($root)/ does not list kernels. checked twice, It goes: lost+found/ boot/ home/ var/ etc/ bin lib lib64 sbib dev/ mnt/ opt/ proc/ root/ run/ srv/ sys/ temp/ usr/ root-image-pkgs.text xfce-image-pkgs.txt[quote="gohlip, post:409, topic:23538"]
grub> linux /vmlinuz-4.9-x86_64 root=/dev/sda2 rw 3
[/quote]

error --- file not found

grub> echo $root
It should give 'hd0,msdos1'

That's the problem here,
see this is your fstab that you provided

You have a /boot partition and that's wherre your kernels are.
So "grub> ls ($root)/" does not give anything because your kernels are not there.

So let's start again, next post, to be not cluttered.

Tha

OK, thanks, I don't understand what is the next thing to do?

grub> set root=(hd0,1)
grub> ls ($root)/

See your kernels now?
Write down.
It should list vmlinuz-4.9-x86_64 and initramfs-4.9-x86_64.img
if not, write down correct kernels, continue

grub> linux /vmlinuz-4.9-x86_64 root=/dev/sda2 rw 3
grub> initrd /initramfs-4.9-x86_64.img
grub> boot

Note it is /dev/sda2 not /dev/sda1
When booted, at terminal

sudo grub-install /dev/sda
sudo update-grub

Wait! Just saw this.

You have a /boot in your sda2? And your fstab has sda1 listed as /boot?

All obviously wrong!
Next post (meaning wait for my next post.)

grub> ls ($root)/boot/

See your kernels finally?
Then

grub> linux /boot/vmlinuz-4.9-x86_64 root=/dev/sda2 rw 3
grub> initrd /boot/initramfs-4.9-x86_64.img
grub> boot

When booted, go to your /etc/fstab and comment out one line

UUID=df14a659-5993-448a-a08b-b1d18f3c3b52 /boot ext2 defaults,noatime 0 2

to

# UUID=df14a659-5993-448a-a08b-b1d18f3c3b52 /boot ext2 defaults,noatime 0 2

Then

sudo grub-install /dev/sda
sudo update-grub

I don't think so, expecting to see "4.9, 4.4..." or something. It says
partition hd0 msdos2 ... Manjaro root ... UUID c73ddae9-ad8e-4b8f-8087-a59d34fb0aaa ...

You've typed wrongly
Try again

grub> ls ($root)/boot/

ls <space> ($root)/boot/

($root)/boot/          no <space> in between

If no kernel listed,
Try again...

grub> set root=(hd0,1)
grub> ls ($root)/

Any kernels?

If both do not give any kernels, go to livecd and use livecd file manager and check where the kernels are.
If not in sda1 and not in sda2 /boot/, then you have missing kernels.
Nothing will boot without kernels

This did not go well, "no hd0 found", something or other.

Before I continue: I appreciate your help! and everyone else. but...

No kernels? I've been using this system for a long time, updating regularly. All that happened was this update got interrupted due to lack of space. I cleared the cache in pacman, finished update, and it hangs at the manjaro screen. Could that destroy my kernels?

When doing the various checks from the live usb, I did carefully confirm that each partition does now have extra space. I believe the root partition had 2.6 gb of space.

And, when I try to boot, it does show 4.9 and 4.4 as choices in the "advanced" area

Check both sda1 and sda2 /boot
Let us know.

[edit] - There's another way, (if you did not also lose your intel-ucode)
grub> search -f /intel-ucode.img
grub> search -f /boot/intel-ucode.img

Any of the above give anything?

here is a picture of the ManjaroBoot folder. The Boot folder in ManjaroRoot is empty. There is no boot folder in the home partition. Is there a better way to search using the terminal? thanks

So... it is there.
It's not missing .
That's in sda1, right?

Now so continue, (please type carefully, please)

grub> search -f /intel-ucode.img

What's it? If output , write down, let me know. continue below

grub> search --no-floppy -f --set=root /intel-ucode.img
grub> ls ($root)/

I am stopping here first otherwise we get things wrong again.
Come back with output

Yes, sda1[quote="gohlip, post:434, topic:23538"]
grub> search -f /intel-ucode.img
[/quote]

hd0, msdos1[quote="gohlip, post:434, topic:23538"]
grub> search --no-floppy -f --set=root /intel-ucode.img
grub> ls ($root)/
[/quote]

lost+found/ grub/... then... it lists my kernels... yay? :slight_smile:

Yay, yes! :grin:

When booted

Check with one of
sudo fdisk -l
lsblk -f
sudo parted l

That the disk where Manjaro device resides is sda

Then

If disk is sdb, do 'sudo grub-install /dev/sdb' Hope you understand.

OK, thanks, will have to return later, thanks a lot! [haven't done next steps yet...]

OK, carefully entered commands, fail... results shown in picture below:

Sorry to hear that. Perhaps reinstalling the OS may be the better option. Back up any data first, ya.
Good luck.

Forum kindly sponsored by