Boot problems - only seeing 1 out of 3 distros installed

Two days ago I came back home after shopping and laptop had automatically shut down for some reason, perhaps a delayed suspend. In any case, it had actually turned itself off. And when I used the power button to start again, it could no longer find the distro had been using (Manjaro Deepin). There are 3 currently installed, Manjaro Deepin & KDE and LinuxLite, which I was using before.

I had a problem at some point during installation of all these in that sometimes it would use grub (or whatever) on my data hardrive (2TB, sda) which I believe had been put there by mistake in one of the installations, and other times it would boot on sdb, a 500 GB SSD where I have all systems installed.

Then I did a search and found a script that could switch the grub file from sda to sdb or vice versa. And that would fix the problem. Unfortunately, I didn't bookmark that page as I usually do and cannot find the script. But in any case, I don't like this happening and need to clean it all up.

However, am way over my paygrade. Am a decidedly amateur user, though have been using Linux for 4+ years now.

Can anyone advise what to do to rescue/find the correct configuration of the boot-up files? (I don't understand how it works or what to look for and what to call them all - grub, conf., fstab all that stuff.)

But if I can restore things to what they were, how do I prevent this happening again?

Or does it make sense to simply reconfigure the SSD system hard drive to have less partitions and then re-install the two Manjaro distros and have a proper backup. (I have a backup of the Deepin but cannot find it when booted into the Manjaro KDE, the only one whose bootup prompt works.) It would be nice to have a simple restore program or rescue disk for when things like this happen, but I didn't get that far in learning Manjaro/Arch programs to do that.

Thanks in advance.

From what I could tell, you're on msdos/bios-legacy.
First get back your manjaro grub using this first post here. The [Simple First Start] will do.

Now, it also looks like you're having grub set to the 2 hard drives' mbr from different OS's. That's okay and one way of dealing with it (not my way, but it's okay). You may want to look at how one guru deals with it here.

But... before you do anything, you need to confirm (likely, but be sure) that all your disks are in msdos and that all your OS's in all disks are in bios-legacy. If unsure, provide the output as listed in the first link.

And finally, if you want only say, Manjaro KDE to be the default boot for all, regardless of which disk the OS is in, set that as default in both disks' mbr and then set all other OS's grub to its own partition. This way, you don't have to worry about 'switching grub files from sda to sdb'.
In Manjaro KDE..
sudo grub-install /dev/sda
sudo grub-install /dev/sdb

In all other OS's
sudo grub-install --force /dev/sdxy
where /dev/sdxy is the partition of that OS.

Good luck.

[EDIT] - assuming the 2 disks are internal and none removable.
If external and occasionally removed, tell us.

1 Like

Ha! I did the grub-install/dev/sda and sdb and now cannot boot anything at all and am in a live cd.

I think maybe I have to scrub the drive and start all over, though I would rather not.

It has dual Legacy/UEFI and have changed it to UEFI only. This is after not being able to boot anything. I wonder if I should change the Boot flag to a different partition and then if I get lucky choosing the right one it will boot again? All the systems are there in their various partitions but I cannot boot into any of them and don't know how to create a proper boot config from them. They were being seen in the previous boot menu, but only one of the three (KDE) could be booted. Now that one has gone too because of the grub-install thing.

Anyway, it's doubtful I'll be back here to get an answer since have no functioning OS any more.

It's funny: I came to Linux years ago partly because I don't like the spyware aspect of MS, plus dicking around like this when things go wrong. My first two years with Linux things generally went well (apart from installing printers, no bluetooth, not great video playback etc.) but of late have been having more issues. My goal is to have a simple operating system to write in a word processor, play movies, surf web and little more. Have a high-powered workstation laptop (Lenovo W530) with 32 GB ram etc. but just can't seem to get a simple OS up and running without all these endless installation and similar issues. Must be doing something wrong, but don't yet know what.

In any case, though I hate to have to go through a fresh installation, getting the trackpad working (not easy), getting ExpressVPN working (like pulling teeth) etc., I guess will have to scrub the drive and start over.

Have a backup partition with lots of Timesaves on it but no idea how to use them with only a livecd.... and on top of that, some live cd's won't let me create flash usb OS, and others do but they don't work, some live cd's won't connect to the internet or won't let me open GParted without a PW, so the whole thing has been difficult.

Sorry. Am rambling. Just to say, thanks for the attempt, but it looks like am in a pickle and don't know how to restore anything and probably have to start over.

That. And you most likely attempted to fix grub when you're booted in the wrong mode (uefi/bios-legacy) of that working OS. It is probable that you have (had) a uefi OS in a msdos partition or a bios-legacy OS in a gpt partition (without bios_grub partition).

Probably the best for you. But remember to 'reset' your drives to msdos or gpt using gparted and use uefi for gpt and bios-legacy for msdos. Do not mix uefi and bios-legacy or gpt and msdos.
Good luck, see you around.

Thanks. I was hoping for a reply!

Question: I believe I might have some sort of grub file on my data HD (2 TB) and that's maybe what started all this. For a couple of weeks I had no issues once had switched the code from sda to sdb using a script I can't find any more. But that stuff should never have been on sda (data) in the first place. That said: is there a way for me to be sure that nothing like that is on that data drive to confuse things again in the future? I have looked using Cont. H and can't see anything but would like to be sure.

Then I will remove the data drive entirely to do a fresh install on the SSD (easy to do with a Lenovo). But removing the data drive won't help if there are files in there somewhere which will later on confuse things again.

I am hoping - if it makes sense - to do UEFI only rather than dual.
And then do I still have to have msdos partition?

Put another way:
If you were doing a fresh install, how would you set up a 500GB SSD? All one partition? Or several.
Also, if you want several OS's (which I only do for backup if the main one goes down and I still haven't learned how to restore images properly in Linux which I did without thinking in Windows), is it best to put them in several different partitions or can they share the same Home folders (Documents, Videos etc.).

I have all my data on my 2TB data drive, some going back to the 80's when I first started computing. I believe that is a FAT format but since I can't open Gparted in this livecd am not sure. The SSD is all Ext 4 except for one 30GB swap partition. So I used the SSD for system files, basically, nothing else. And I'd like to keep it that way.

If there were a way for all different OS's to share the same Home folders, that would be great too, though right now I don't use any of them because they tend to get lost when I have system problems like this.

I could also use help understanding how to set things up right so that I can make easy image backups and effect a restore if/when things go pear-shaped like this week. I thought I'd taken care of all that with Timeshift but haven't been able to access any of those files or install Timeshift from a livecd, it never goes through for some reason...

I have never found a good explanation for the best way, or various options, of how to set things up. It's always a gamble every time.

Simple rules with multiple disks and OS's.
o Have all disks gpt or msdos. Make all the same.
If starting with new disk or clearing one, use gparted,
device tab --> Create Partition table --> select gpt or msdos
(note this will clear all data in whole disk)
Then make partitions ready for installation.
o If gpt, use uefi
If msdos, use bios-legacy.
Do not mix uefi OS's and bios-legacy OS's.

Oh, your next post....
Personal rules I keep. I always have sufficient partitions. So I do not go resizing, deleting, partitions. I could format them for new installations but that's all I would do. Good reasons for it, but I'll skip the explanations for now.

So have enough partitions to cater for new OS's and a large data partition for created and downloaded files. I don't have /home partitions and there's never a need for other partitions like /boot, /usr, /var and so on (generally speaking). I see no need for encryption (we have other ways to keep data safe) and I've never understood the need for lvm. All these add more complexities and more things that could go wrong and more difficulties to fix if things go wrong; and .... I just don't see much benefits anyway. All these are my personal views. I normally do not go into personal preferences and I would never discourage others if they want to do things their way. But since you asked me.... :wink:

And having multiple disks for multiple OS's is... (to me) cause more trouble for newer users, and for more experienced users, have no advantages.

Oh , stick with ext4 format. just a suggestion, of course.
And read the wiki and this forum.. lots of good people here with good advice and suggestions.

Wish you all the best.

1 Like

I see you marked this post as a solution, I don't figure out why..
Do you want to fix your installation(s) as they are now?
If yes, provide info.

You should have done one at a time, but still, a proper answer needs sufficient info.
Boot into your Live media, mount the root partition of your Manjaro installation (the following commands assume mount point /mnt) and provide (in proper formatting):

sudo parted -l
inxi -puo
cat /mnt/etc/fstab
cat /mnt/etc/default/grub | head 
sudo grep -im 1 -A 20 "Manjaro" /mnt/boot/grub/grub.cfg

Also, report what mode you booted Live media (UEFI or MSDOS).

After we fix this, we'll need fstab from your other installations.

Thank you. I will try the above.

I did not knowingly mark as solution, but maybe someone else did seeing as I was on the verge of giving up and starting over.

As it happens, because I couldn't do much in Manjaro Livecd, I managed to make a working flash drive for LinuxLite when in Pop! OS livecd which has Popsicle, and then the LL has Timeshift already on it so was able to access its Restore files and restore the Manjaro KDE which am now typing from, albeit seemingly all the others which show up in the menu still don't boot up.

So will now try to repair the fstab etc. so that the other OS's can function too.

(The Bios is now set to Legacy only. Once I did that I could open the flash drive as livecd whereas before it didn't function at all.)

In terms of your instructions, since I have a working OS now should I still go back into a livecd mode in order to effect them or can I do it from the KDE OS now open?

Thank you very much.
Sorry to be such a pain. This aspect of OS operations has always confounded me and since have chronic Lyme (with brain infections), have very hard time following Wiki and other instructions. Some functions remain as sharp as ever, others are crumbling. (Sort of like Alzheimer's I think, many of whom test positive for Lyme as it happens...)

@AgentS possible OP got hit by the recent update fiasco?
He used timeshift to get it back.

ps: I don't have any problem with this update (or any...). Neither in KDE, OB, i3, lxqt... uefi or bios-legacy.

but not accompanied by evidence (logs) and not cleared out the usual Grub specific suspects.
(I am watching some crime detective series.. :rofl:)

I think I made a mistake when installing a few OS's to decide on a new one in that one time the default place for Grub was on my data disk which is sda for some reason (it used to be sdb and the system drive was sda, no idea how that change happened). So I think I had some OS's looking for Grub on sda and some on sdb. After the update, for whatever reason, things got scrambled and only one OS was left, the KDE one which am now using. All the others, though they show in the Bootup menu, don't work.

In one (LL), which I just tried to open in Rescue Mode, it says that the fstab file is on the 2 TB data (sda) drive. I cannot find it there on that drive, but I really need to get everything like that OFF the data drive so that I can get back to some sort of order with all this. Or maybe it isn't there anymore but the file is pointing to it anyway and needs to be rewritten. I suspect I have two bootup files and only one is working (for KDE) and all the others are called from a different one somewhere. In any case, I've got to get it all down to one file.

Will follow the instructions of Petsam once find out if need to be in livecd or can do it from extant KDE OS now typing from.

If from the installed KDE OS itself, the output from its terminal would be better.
efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi
note: ‘parted -l’ --> small ‘L’ and provide information of all disks.

Should be similar to what petsam ask from the /mnt from liveOS.

Oh. I'm going to sleep now. Over to petsam.
He's more grumpy, but nicer.. :rofl:

1 Like

Thank you, nicer gohlip, will try now!

[baronash@baronash-W530 ~]$ efibootmgr -v
EFI variables are not supported on this system.
[baronash@baronash-W530 ~]$ sudo parted -l
Model: ATA ST2000LM007-1R81 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:  

Number  Start   End     Size    Type     File system  Flags
1      1049kB  2000GB  2000GB  primary  ntfs

Model: ATA SAMSUNG MZMTE512 (scsi)
Disk /dev/sdb: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:  

Number  Start   End     Size    Type      File system     Flags
1      1049kB  52.7GB  52.7GB  primary   ext4            boot
3      52.7GB  116GB   62.9GB  primary   ext4
4      116GB   430GB   315GB   extended
5      116GB   168GB   52.4GB  logical   ext4
7      168GB   395GB   226GB   logical   ext4
6      395GB   430GB   35.7GB  logical   linux-swap(v1)
2      430GB   512GB   81.9GB  primary   ext4

[baronash@baronash-W530 ~]$ sudo blkid
/dev/sda1: LABEL="2TB" UUID="01D2CF5D4A044E30" TYPE="ntfs" PTTYPE="atari" PARTUUID="32547d65-01"
/dev/sdb1: LABEL="LL" UUID="de12c83c-cd58-4e8c-b3bd-7c895c9c03bd" TYPE="ext4" PARTUUID="32547d65-0
/dev/sdb2: LABEL="ManjaroK" UUID="bb71f71d-5b89-445f-9278-23c8fa5399c3" TYPE="ext4" PARTUUID="3254
/dev/sdb3: LABEL="BU" UUID="132494e7-884f-4f3e-b67e-b01f05b10840" TYPE="ext4" PARTUUID="32547d65-0
/dev/sdb5: LABEL="Deepin" UUID="78c591bd-7ab4-4633-9507-fdab1909f339" TYPE="ext4" PARTUUID="32547d
/dev/sdb6: UUID="aaa82da6-ed58-4dd6-97ec-ce8cf8c78611" TYPE="swap" PARTUUID="32547d65-06"
/dev/sdb7: LABEL="Xtra" UUID="cd9d6420-d645-4bd4-aeb1-a6e7df8e8e4b" TYPE="ext4" PARTUUID="32547d65
[baronash@baronash-W530 ~]$ findmnt-s
bash: findmnt-s: command not found
[baronash@baronash-W530 ~]$ findmnt -s
TARGET SOURCE                                    FSTYPE OPTIONS
/      UUID=bb71f71d-5b89-445f-9278-23c8fa5399c3 ext4   defaults,noatime,discard
/tmp   tmpfs                                     tmpfs  defaults,noatime,mode=1777
[baronash@baronash-W530 ~]$ findmnt/boot/efi
bash: findmnt/boot/efi: No such file or directory
[baronash@baronash-W530 ~]$ findmnt /boot/efi
[baronash@baronash-W530 ~]$ findmnt /boot/efi

Looks like target mount is sdb2 where Manjaro KDE is, but the boot flag is on sdb1. Could that be the mismatch?

Nothing with efi worked, but maybe that's because I disabled it in BIOS and am on Legacy only now?


Select each command output part and press </> in the post edit toolbar.

Cant sleep.
At kde os terminal, do
sudo grub-install dev/sda
sudu grub-install /dev/sdb
sudo update-grub

If you have still have problems after that, check the link and clear grubenv, install grub package and redo grub install and update grub.

1 Like

Add what I requested, please

If you have booted in Manjaro, don't include /mnt in the commands, or find the above with GUI app and and post/paste.

Same instructions i gave in my first post.
His system is ok, msfos, bios legscy .
Shouldnt fail the first time. His typo? Or the blasted quiet grub and the stupid menu grubenv?

What do yiu think?

Forum kindly sponsored by