Boot problems - only seeing 1 out of 3 distros installed

Yes, I found that icon and clicked on it.
But don't know what to do with it. Sorry to be such a dunce.

type or paste code here

I pasted it in and it was formatted the same way.

Provide what I asked you some posts ago, please, and be calm!
We are only playing around. Don't take us seriously! :slight_smile:


I provided the best I could.
You don't like it (I don't blame you!)
I don't know what else to do.
Several of the lines you gave me didn't output anything (which I included in the post).

If you are in your Manjaro, run these in terminal

cat /etc/fstab
cat /etc/default/grub | head 
sudo grep -im 1 -A 20 "Manjaro" /boot/grub/grub.cfg
grub-editenv list

When you have some free time, please read this

OK, I just saw this one. There is a delay between what is showing in gmail and what is here on board. Sorry.

[baronash-W530 baronash]# cat /etc/fstab
# <file system> <mount point> <type> <options> <dump> <pass>

UUID=bb71f71d-5b89-445f-9278-23c8fa5399c3       /       ext4    defaults,noatime,discard        0       1
tmpfs   /tmp    tmpfs   defaults,noatime,mode=1777      0       0
[baronash-W530 baronash]# cat /mnt/etc/default/grub | head 
cat: /mnt/etc/default/grub: No such file or directory
[baronash-W530 baronash]# cat /etc/default/grub | head 

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

sudo grep -im 1 -A 20 "Manjaro" /boot/grub/grub.cfg
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_24.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_48.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_bold_16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/dejavu_sans_mono_12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-18.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b12.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b14.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b16.pf2
loadfont ($root)/usr/share/grub/themes/manjaro/terminus-b18.pf2
insmod png
set theme=($root)/usr/share/grub/themes/manjaro/theme.txt
export theme
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5

grub-editenv list

Please change the command to this

sudo grep -m 1 -A 20 "Manjaro" /boot/grub/grub.cfg
sudo grep -m 1 -A 20 "Manjaro" /boot/grub/grub.cfg
menuentry 'Manjaro Linux' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-bb71f71d-5b89-445f-9278-23c8fa5399c3' {
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd2,msdos2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd2,msdos2 --hint-efi=hd2,msdos2 --hint-baremetal=ahci2,msdos2  bb71f71d-5b89-445f-9278-23c8fa5399c3
          search --no-floppy --fs-uuid --set=root bb71f71d-5b89-445f-9278-23c8fa5399c3
        linux   /boot/vmlinuz-4.19-x86_64 root=UUID=bb71f71d-5b89-445f-9278-23c8fa5399c3 rw  quiet
        initrd  /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
submenu 'Advanced options for Manjaro Linux' $menuentry_id_option 'gnulinux-advanced-bb71f71d-5b89-445f-9278-23c8fa5399c3' {
        menuentry 'Manjaro Linux (Kernel: 4.19.16-1-MANJARO x64)' --class manjaro --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-4.19.16-1-MANJARO x64-advanced-bb71f71d-5b89-445f-9278-23c8fa5399c3' {
                set gfxpayload=keep

NOTE: I properly formatted the original load of output that was improperly formatted.

1 Like

We are fine, I guess!
Now, about the boot drives (from BIOS)...
You have two drives, one with one NTFS partition an one with your Linux OSes.
You should know that the drive identiy names (/dev/sdx) are known to change between boots. So, when you INSTALL grub, you should ALWAYS check what is your target drive name, with

lsblk -f

If your OSes drive is /dev/sdb, install grub with this

sudo grub-install --recheck /dev/sdb

Then, you have to SET the BIOS disk boot order to boot first that drive (that you installed grub), confirming the drive characteristics (i.e. Samsung 500GB etc).

About your other OSes, run once this and see the command output, if it "Found" the other OSes.
If not, report your observations/output.

sudo update-grub

OK! Thanks. Did it and (properly formatted!):

sudo grub-install --recheck /dev/sdb 
Installing for i386-pc platform. 
Installation finished. No error reported. 
[baronash-W530 baronash]# sudo update-grub 
Generating grub configuration file ... 
Found theme: /usr/share/grub/themes/manjaro/theme.txt 
Found linux image: /boot/vmlinuz-4.19-x86_64 
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img 
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img 
Found Linux Lite 4.2 (18.04) on /dev/sdb1 
Found Manjaro Linux (18.0.2) on /dev/sdb5 
Found Manjaro Linux (18.0.2) on /dev/sdb7 
Found memtest86+ image: /boot/memtest86+/memtest.bin 

Going to reboot now and will see what happens...

1 Like

No change. KDE opens, the others don't. One just goes blank (and I waited more than 2 mins!), the other runs some terminal script but then stops; the third has Kernel Panic and freezes, have to power down.
So no change.

You mentioned sleep... are you in Deutschland oder?

I think I know what it might be, but lack the skills to define it terminologically.
I think the other systems were set to boot from sdb1, whereas this installation is on sdb2. There used to be a boot flag on sdb1, though right now in GParted there doesn't seem to be any

OK. Schlaff gut!

I was doing other things and waited for a popup notification (when you answer to someone).
Next time, click the "Answer" button, or quote my post, or mention like @petsam.

We'll see when you provide the relevant info for the other OSes and explain what are they (Debian based etc.).
Normally they should be booting with your new GRUB you have.

Mount each at a time and get

  • /etc/fstab
  • their grub.conf part of the first menu option (like in this post)
  • Their CMDLINE lines in /etc/default/grub (as in this post)

But it would be better if you describe what errors you get on each.
I 've just noticed you have two more Manjaro installations and one LinuxLite. Is this correct?

As a best guess, I suggest you boot to TTY and update the system packages and grub (not install, only update-grub).
After you do this (at least for the Manjaro ones), boot into the main (KDE) Manjaro and run again update-grub.
If they still fail, we make another topic for each.
Or you can search similar topics to see how they are fixed.
Also study the SuperGrubTutorial

Guten Morgen. Nein, Ich nich bin in Deutschland.

From the grub prompt (press 'c'' at grub menu) Try to boot up the other Manjaro

grub> search.file /etc/manjaro-release

That should give you 3 output
(hd1,gpt2), (hd1,gpt5) and (hd1,gpt7)
Continue and boot one of the others
(I assume kernel is in linux4.19, else change to the correct ones)

grub> set root=(hd1,5)
grub> probe -u $root --set=abc
grub> linux /boot/vmlinuz-4.19-x86_64 root=UUID=$abc rw 3
grub> initrd /boot/initramfs-4.19-x86_64.img
grub> boot

If /when booted to prompt, login with password and do the following at prompt

sudo pacman-mirrors -f3
sudo pacman -Syyuu
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo grub-editenv - set boot_success=0
sudo grub-install
sudo update-grub

Reboot and see if you can boot to Manjaro at sdb5.
If working, then do the same to Manjaro at sdb7 using the same grub prompt from menu.

Good luck.

1 Like

Thank you very much for trying so hard. I began to have many problems with the working KDE installation, programs not opening properly, freezing and so forth (after the 900 MB upgrade I re-ran after restoring), so reluctantly decided (before your message came through) to start fresh. I spent too much time trying to reformat SSD drive with a boot drive, a Backup area and so forth but kept being unable to install (probably not knowing how to format them, choose where to have / and so forth) and so went with a POP_OS installation since it has a flash drive utility and also does all that sort of formatting for you. (Also, for some strange reason, all my Manjaro installation disks would not connect to internet, saying 'wrong password' even though it wasn't. Too many glitches!!)

Before returning to Manjara - as would like - first will need to research and understand better backup plans. Meanwhile, POP installs with a recovery partition which can be called during boot up in event of problems. However, the way they configure a new install, it will be very hard to do a side-by-side, and also there are no extended partitions and so no area to put BU files for a program like Timeshift, and also the Boot partition is only 500 MB. In any case, I have something now with an easy Restore function built-in, so hopefully that will do the trick when problems like this occur again.

In Windows years ago I ran Hard Disk Manager, had many system snapshots and it was very easy to restore whenever things got wobbly. Have never learned how to do that in Linux easily and only once was able to restore things when had problems. Nearly always need to re-install, which is why never keep data on same HD as the systems.

To be very honest, am beginning to reconsider going back to Apple (had a Macintosh in 1985-90). I don't like the expense, but do like the way things work together well, hardware and software. I still have a good feeling about Manjaro but suspect will never acquire the skills needed to use it properly. I like driving car, but have no idea how to fix it and hire mechanics for that. With Linux, you need quite a bit of mechanics skills to operate well and it seems every disto has many installation and post-installation issues which are hard to figure out unless you are quite proficient at coding and suchlike. This was my first experience with Arch-based and there is something about it (and/or Manjaro) that 'feels' very good, so hopefully can return at some point. Meanwhile, have to get out of computer-tinkering and into just using.

Anyway, once I take another crack at installing Manjaro, will continue, but for now am pausing. It all became way too complicated, and to make matters worse, I never even got to understand what went wrong, what the problem was. Way too much fumbling around in the dark despite the worthy efforts of people here trying to help. Again, my skill level is too low I suspect.

Thanks again and very sorry for any inconvenience for the trouble some of you went to in order to help.

1 Like

For your long gracious post, it feels only right to give a response instead of just a 'like'. :grinning:
You're welcome and no trouble as we like doing what we're doing.
Best wishes and hope to see you here some time. Cheers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by