Boot problems with SD card cloned with Win32DiskImager

Hello. I cloned my Arch Linux system SD card using Win32DiskImager and booting with the cloned card hangs when trying to mount my disks.

My kernel is 5.7.2-2-ARCH, running on a Wandboard Quad.

The original card boots fine. I have mounted both cards and can compare them. diff says that the two system partitions are identical. fdisk -l shows identical results for the two cards.

Physically the cards are not identical. They are both SanDisk 32 Gb SDHCs, but the cloned card is UHS-1 while the original is not.

In a little more detail: With the cloned card, the system begins trying to mount the disks, which are set to mount by UUID, and it can't find them. It eventually gives up trying to mount them and then hangs indefinitely trying to start the log-in service.

I also tried cloning the card with the disks application under Linux Mint on my PC, but the results are the same. However disks does find unreadable sectors and replaces them with 0s.

Does anybody have any ideas on this? Could it have something to do with the difference in cards? With the cloning process? Or must I look elsewhere? I'm happy to provide any needed info.

TIA
Les

Even though this belongs on the Arch ARM forums, I will ask if the UUID is correct in the /etc/fstab file? Does it match the UUID that the partition has on the new SD?

PS: Best way to clone SD cards, is with DD. :slight_smile:

Thanks. I doubt if I'd have gotten such a quick answer if I'd posted first in the ARCH ARM forum! I was about to post there.
To answer your question, yes, I've checked the UUIDs of the two HDDS. When you say

the UUID that the partition has on the new SD

you do mean in the /etc/fstab on the new SD?

To clone with dd I would have to use --no-errors or something, right? I should mention that the "original" SD card is a clone of a card that had unreadable sectors.

Yes. I mean the actual UUID of the partition on the disk, as seen by lsblk, should be the same as the one mentioned in /etc/fstab.

Yep, I've checked that. Just double-checked and they're the same. The message when the new card hangs is

[ *] (1 of 6) A start job is running for…/D0E64202E641E974 (26s / 1min 30s)
[
] (5 of 6) A start job is running for…/2EE265B0E2657D49 (51s / 1min 30s)

and my fstab says

UUID=D0E64202E641E974 /mnt/readynas ntfs-3g defaults,uid=1002,gid=0
UUID=2EE265B0E2657D49 /mnt/nastemp ntfs defaults,uid=1002,gid=0

I didn't know that Arch used ntfs in their RPI setups...
Both the UUID's you mention contain ntfs filesystems. That seems wrong. They should be vfat and ext4.

Come to think of it, it seems that the system is trying to mount your NAS partitions, which fail and boot stops.

Try uncommenting those 2 lines in your fstab and reboot.

They're formatted as ntfs for the time being because I wanted to be able to access them directly in Windows, which I still need to use. But they mount with no problem with the other card.

Okay. So they are not your NAS, but your RPI filesystem?
I'm just confused about the mountpoint they have set in the fstab.

Well, the Wandboard running Arch IS my NAS. I don't have an RPI. The partition is named like that because originally all the files on it were on an actual Netgear ReadyNAS.

I would still try to uncomment those 2 partitions, since they are not required to boot. Just to see if that makes the system boot.

If it does, then you need to find out why the ntfs partitions does not want to mount, by trying to mount them manually.

Wow. Okay, I'll try that and get back to you. Uh, you do mean comment OUT the two partitions?

Something odd happened: I mounted the system partition on the new SD card and commented out the partitions in /etc/fstab, but when I reboot with the new card the fstab has reverted back and the boot still hangs.

I'm going to try again....

I must have mounted the partition as ro by default. No error thrown by nano trying to write the file...

No, I see that the partition is mounted as rw. But the changes to fstab didn't register. I'll try another time...

Okay, now rather than hanging trying to mount the partitions on the HDDs, the boot process has hung with:


[  OK  ] Created slice system-systemd\x2dcoredump.slice.
[   19.086798] systemd[1]: Finished udev Coldplug all Devices.
[  OK  ] Finished udev Coldplug all Devices.
[ ***  ] (3 of 3) A start job is running for…ice Nodes in /dev (18s / no limit)
[**    ] (3 of 3) A start job is running for…odes in /dev (1min 30s / no limit)
[  107.730656] systemd[1]: dev-ttymxc0.device: Job dev-ttymxc0.device/start timed out.
[ TIME ] Timed out waiting for device /dev/ttymxc0.
[  107.762637] systemd[1]: Dependency failed for Serial Getty on ttymxc0.
[DEPEND] Dependency failed for Serial Getty on ttymxc0.
[  107.786622] systemd[1]: serial-getty@ttymxc0.service: Job serial-getty@ttymxc0.service/start failed with result 'dependency'.
[  107.798020] systemd[1]: dev-ttymxc0.device: Job dev-ttymxc0.device/start failed with result 'timeout'.
[***   ] (2 of 2) A start job is running for…odes in /dev (3min 57s / no limit)

Another start job for "... gress polling" is also showing in that last line. I'm now at 11 minutes and still hung...

I know this might not be what you want to hear. But have you tried recreating the install, instead of using clones?

Backup important settings files, like /etc/fstab, create a new Arch install on the new SD card, and then set it up from scratch?

I feel that because you have created a clone of an SD card with known bad sectors, you might just have some corrupted filesystem data.

Gulp.

It's not what I wanted to hear.

Rather than Arch, is there a version of Manjaro I can use on the Wandboard? I can send the specs if you want.

We don't support the Wandboard, specifically. So I'm not sure if it's possible to use one of the other board images for it. That depends alot of the SoC it uses.

From what I can see its a Freescale i.MX6 Cortex A-9.

Anyway thanks for your help and I'll start preparing for a reinstall. If I'm reluctant it's because it's taken months to work out all the problems I've had with this installation and I had just gotten where it worked. Which is why I want to clone the SD...

I can understand, which is why I wrote that you probably didn't want to hear it. :stuck_out_tongue:

Currently, we don't support any i.MX SoC's...

Anyway thanks for your advice, which I'm sure is very good. It's just that all this is very hard for me, and with Arch Linux it's very hard to get help. I've had to learn Linux from scratch since my NAS died and I had to recover all the files on it and then set up a "little NAS" on the Wandboard. I'm 74 years old and I'm sure my brain needs the exercise, but the garden also needs weeding and my wife needs cuddling... :wink:

Well, if I have to do it it'll be an opportunity for me to re-trace all the problems I've solved over the past year and document them so others can get the benefit.

Forum kindly sponsored by