Boot Stuck at TPM Error


I tried installing Manjaro from a live USB. But somehow, on my MSI (i5-8500H, GTX 1050), it wouldn't create an load GRUB. The only way to boot into Manjaro was by forcing the BIOS to choose the Manjaro EFI file from the live USB. I managed to solve the issue using grub-install mentioned here, along with the additional steps for UEFI.

Additionally, there were some issues with the display drivers as well. The screen wouldn't refresh at all, unless prompted by a large movement of a window. For example, scrolling through settings, printing new line in Konsole, or even simple things such as right-clicks of the mouse couldn't be seen on the display. To overcome this, I tried changing the drivers from Bumblebee to NVIDIA only (not 390xx), followed by sudo nvidia-xconfig. Upon restart, the display was set to a very low-resolution. This link suggested that I rename, or delete, the /etc/X11/xorg.conffile, which I deleted.

Since then, the system gets stuck while booting. I even tried turning ACPI off in grub using acpi=off, but nothing seems to work. These are errors that I get.

ACPI Exception:AE_NOT_FOUND, Evaluating _PRS (20170728/pci_link-176)
tpm tpm0: TPM self test failed
iTC0_wdt iTC0_wdt: can't request region for resource [mem 0x00c5f]

Thank you, in advance, for your time and patience.

First of

shouldn't be used that way. If your machine has a dual GPU then, either you disable from bios the integrated intel one, or if is not possible then you have to use the bumblebee with some helpful info too from here ... or you make use of prime from here

that from what i know is the legacy one, older in other words, but your

is perfectly fit for the latest drivers.

For the

part, once you gain control of your desktop, or from TTY, create a file in /etc/modprobe.d/ ... use this commands:
sudo nano /etc/modprobe.d/blacklist.conf
and add this to it:
blacklist iTCO_wdt
press Ctrl+O to save and Ctrl+X to exit

1 Like

It is not a TCP error Transmission Control Protocol
But a TPM error Trusted Platform Module - ArchWiki
I changed the title

Show your hardware, open Terminal/Console

inxi -Fxzc0 --usb

Thank you for replying

I'm sorry, but I'm quite new to this platform. I do not know how to spawn a TTY shell in a system that won't boot. Could you please tell me where to look, or what should I search for, to find a guide?

If TPM isn't needed, disable it in BIOS if possible.
You can also blacklist tpm modules, just like described above for iTCO.

However I think that none of that is related to the fact that your system doesn't boot.
Seems to me like the 12038597th problem with dual graphics.

1 Like

Thank you for fixing the title.

I'm sorry, but the system won't boot at all, for me to access the terminal.
However, this is what I managed to gain, by booting onto a live USB. Hope it's useful.

  Host: manjaro Kernel: 4.14.52-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.1.1 Desktop: KDE Plasma 5.13.2 tk: Qt 5.11.1 
  Distro: Manjaro Linux 17.1.11 Hakoila 
  Type: Laptop System: Micro-Star product: GL63 8RC v: REV:1.0 
  serial: <filter> 
  Mobo: Micro-Star model: MS-16P6 v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E16P6IMS.104 date: 04/08/2018 
  ID-1: BAT1 charge: 41.4 Wh condition: 42.8/43.2 Wh (99%) 
  model: MSI Corp. MS-16P6 status: Unknown 
  Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Skylake rev: A L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36872 
  Speed: 868 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 800 2: 801 
  3: 800 4: 801 5: 814 6: 801 7: 801 8: 800 
  Card-1: Intel driver: i915 v: kernel bus ID: 00:02.0 
  Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: nouveau 
  v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: intel,nouveau 
  unloaded: fbdev,modesetting,nv,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 18.1.3 direct render: Yes 
  Card-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.14.52-1-MANJARO 
  Card-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel bus ID: 00:14.3 
  IF: wlo1 state: down mac: <filter> 
  Card-2: Qualcomm Atheros QCA8171 Gigabit Ethernet driver: alx v: kernel 
  port: 3000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  HDD Total Size: 946.10 GiB used: 2.02 GiB (0.2%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-17Z10T0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade 
  size: 14.59 GiB 
  ID-1: / size: 5.73 GiB used: 88.4 MiB (1.5%) fs: overlay dev: ERR-102 
  Hub: 1:1 usb: 2.0 type: Full speed (or root) hub 
  Device-1: SanDisk Cruzer Blade bus ID: 1:2 usb: 2.1 type: Mass Storage 
  Device-2: Realtek RTS5129 Card Reader Controller bus ID: 1:3 usb: 2.0 
  type: Vendor Specific Class 
  Device-3: N/A bus ID: 1:4 usb: 1.1 type: Human Interface Device 
  Device-4: Intel bus ID: 1:5 usb: 2.0 type: Bluetooth 
  Hub: 2:1 usb: 3.1 type: Full speed (or root) hub 
  System Temperatures: cpu: 53.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 218 Uptime: 1m Memory: 7.64 GiB used: 652.4 MiB (8.3%) 
  Init: systemd Compilers: gcc: 8.1.1 Shell: bash v: 4.4.23 inxi: 3.0.12

I managed to do this from a terminal on a live USB. However, the system still refuses to boot.

should be clarified first

Manjaro was installed on a UEFI System alongside Windows 10 (1709 update) by selecting the Replace an existing partition option in Calamares. A 128 GB partition was created in Windows beforehand.

You did it to live media if you didn't chroot the actual install.
Look at the wiki about it

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by